Skip navigation

USB3 ONLY external drive ejecting during backup

971 Views 8 Replies Latest reply: Feb 24, 2014 9:24 PM by Fergus7 RSS
amtpict Calculating status...
Currently Being Moderated
Jan 18, 2013 2:05 PM

This has been discussed and posted in various ways here, but I haven't seen/found a solid solution yet which might be out there.

Has anyone figured out the solution to a USB3 drive ejecting on it's own?

 

My staff's OWC USB3 external portrable hard drive keeps ejecting during any operation: time machine, Carbon Copy, Lightroom, importing, moving files, etc. 

 

Attached is a screen shot of the warning box that comes up when the drive ejects itself.

Screen Shot 2013-01-18 at 10.47.28 AM.png

 

COMPUTER:

The machine is a 2012 NON-Retina MBP.

OSX 10.8.2

 

EXTERNAL DRIVE:

The drive is an OWC Mercury Elite On the Go drive: USB3 only

http://eshop.macsales.com/item/Other%20World%20Computing/MSU37750GB16/

 

We have used the drive, and cable on my 2011 MBP, OSX 10.7.5 with only USB2 on my machine, and it runs perfectly fine under all conditions.

 

ATTEMPTED FIXES:

Repaired disk permissions

Disk Warrior

Defrag

All Updates for OSX

Re-install OSX

All updates for 2012 MBP

 

Taken to Apple "Genius" bar twice.  They confirm the failures.  Initially blamed the drive/enclousure/cable.  Then blamed that there were firmware and other updates that would fix it....which they did not. 

 

YET TO ATTEMPT :

Creating a 10.7.5 boot partition on the 2012 MBP and test that.

Trying a powered external drive on the 2012 MPB

Trying a FW800 drive

 

Any thing else I am missing?  Trying to avoid having to send it into Apple Care and be without a needed machine for week+, and concerned that like others, it won't be fixed anyway.

 

Appreciate your thoughts.

MacBook Pro, Mac OS X (10.6.8)
  • ctyankee11 Calculating status...
    Currently Being Moderated
    Jan 23, 2013 10:21 AM (in response to amtpict)

    I'm also having this issue with new Sans Digital Towerraid+ TR4U+B.  Drives disconnect after 10 minutes of non-use.  I don't have this issue with Newer Tech.: Guardian Maxximus in JBOB mode using Firewire 800 port attach.  Drives disconnected and connected correctly after sleep.  I've tried all the support remedies; cable changeout, etc.  Sounds like Disk enclosure issue. 

  • SlickRick Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 29, 2013 8:50 AM (in response to amtpict)

    I have something similar on a brand new iMac 27" i7 top of the line model.  I bought a USB 3 enclosure from OCW for a 120 gig SSD. I was using it as the cache drive for Photoshop CS6.  It began to display the same issues you are describing. I brushed it off and blamed the cheap enclosure I purchased.  This all occurred 1 week ago on 1-22-2013.

     

    On Saturday 1-26-2013 I was backing up a sweet sixteen shoot via time machine connected to the USB3 port and the drive ejected mid way of a 70 gig back up. I found that strange because I've never had a problem with that drive or the enclosure it's in. (By the way this is a USB2 enclosure)  I tried it 3 more times and the same issue occurred.  I figured it was the cable and switched it with another USB cable and this time it worked.

     

    Not thinking much about I assumed the problem was the cable.  The next morning I realized I still had one 8 gig compact flash card in my camera and I needed to back that one up.  This time I used my USB 3 RAW STEEL UDMA card reader to ingest the work. There were only 20 images on the card. During import the compact flash drive froze on the third image. I had to force quit and redo the import again.  It took 3 times before I had no issues importing the images.  I could not figure out what the **** was going on until it hit me. 

     

    During my trouble shooting I realized the 3 drives were, when they ejected themsleves, connected to the same port in the back of my iMac.  The second one closest to the SD card reader port in the back.  That was the free port I kept switching to use these different peripherals.

     

    I need to do a little more testing but I'm almost certain something is wrong the the USB3 ports in the back of the new computers. Never had these issues with my late 2009 iMac. 

     

    The last thing I want to is haul this machine into Apple after it took me 4 days to get it set up the way I use it for my Photography business.

     

    Disappointed big time!

     

     

    Screen Shot 2013-01-29 at 10.42.09 AM.png

  • William Donelson Level 4 Level 4 (2,495 points)
    Currently Being Moderated
    Jan 8, 2014 6:52 AM (in response to amtpict)

    USB3 radiates the same frequencies used by WiFi and many wireless products, and it also susceptible to them.

     

    USB3 is a terrible hack, and it's designers should be shot. I have wasted perhaps 30-40 hours trying MANY USB3 hubs; none of them are remotely reliable.

     

    If you must use USB3, use short best quality cables, and try to put them and your USB3 devices far away from otther WiFi or wireless items.

  • Fergus7 Calculating status...

     

    I just got a new IMAC and experienced the same issue with a RAID 10 array with 4 drives spontaneously disconnecting in the middle of a data transfer with the message "you should eject disk properly, etc. etc." message.

     

    As many others I tried all the obvious solutions. Different cables, different drives, etc. Then I read something about radio wave interference from wireless keyboards. Well, I don't have wireless keyboards or mice (don't like them) but still, it stuck in the back of my mind.

     

    I did find that a USB 2.0 cable with noise suppression dongles at each end worked just fine, if a bit slowly. Anyway, I found an old set of ferrite couplings that were made for video cables back in the day and placed one set at each end of the USB 3 cable. I then moved my RAID array as far from the computer as possible and plugged it all back in. The problem has not reoccurred even with the transfer of very large folders of files from a networked PC RAID.

     

    Just a thought but it seems to have worked for me although the fact that this sort of thing is necessary does not speak well for Apple.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.