Skip navigation

how do I undo BC Partition repair in disk utility?

649 Views 5 Replies Latest reply: Feb 2, 2013 11:30 AM by gmillerx RSS
gmillerx Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 29, 2013 3:41 PM

Here's the summary:


8-core MacPro2,1 running 10.6.8, Paragon NTFS for Mac, Bootcamp Win7.


4 internal HDD drives: two 1.5TBs for data, one 1TB for MacOS, one 1.5TB for Win7 bootcamp.


I mostly use the Mac side for music production (but rarely), and the Win side for business and everything else. Scores and scores of Win apps installed over the years. [4 monitor system], well over 500K files on the drive.


I just backed up the data from the two data-only drives, and made a bootable clone of the MacOS drive (SuperDuper). I have never successfully been able to clone the Win7 Bootcamp NTFS drive (even with Winclone back in 2009) because of volume sizes (or something). I decided to try again, from WITHIN Windows this time (all other attempts were from the Mac OS side).


I bought, downloaded, and installed Acronis True image from within the Win7 bootcamp system. [I obviously did not know that it was gonna modify my MBR, and I had no idea at the time that the GPT and MBR areas were somehow 'mingled' on a bootcamp drive.]


So, when I performed the Acronis-requested reboot (my default boot is into the Bootcamp/Win7 drive), it failed to boot and requested some Windows recovery media or something. I was concerned that anything i put in the DVD drive would sabotage my priceless (in retrospect) stable/optimized Win7 bootcamp system. So, i just hard-powered down the Mac and tried to restart.


I did the Alt/option key, and i was presented with the Mac or Win drive icons. I selected Win, and then I got a different boot error message--'no MBR found'.


But this time i realized that Acronis had stepped where it shouldn't have, and I figured the Mac side could fix the boot problem (maybe with bootcamp assistant or something).


If i had stopped THERE, and searched the forums i could have found how to fix THAT problem--that has been answered tons of times…


But, instead, i went to Disk Utility and asked it to repair my Bootcamp partition (I have Paragon NTFS and it has worked for years, and so I did not have a reason to doubt Disk Utility's ability to Repair an NTFS volume--not that i have tried it before, of course).


Disk Utility repair ran for about 10-15 minutes and said it fixed about 10-20 things.


The drive information (in the side bar and below) still had the BOOTCAMP partition, reported that it was NTFS, said that there was 308 GB still available of the 1.5TB drive, and that it contained 1.19TB 'used'. Looked normal to me.


I closed Disk Utility and then opened a Finder window to see if DU left any 'artifacts' of its 'fixes' on the BOOTCAMP partition, and all the files were gone! Even though DU said it had 1.19TB 'used', all of my files are gone. [I rebooted also, to verify that it was not some 'delayed reporting' issue.]


When I enable 'hidden files' to show, what I get on the Bootcamp partition are these three entries:

.DS_Store (16KB), .fseventsd folder (with a 1KB UUID file inside it), and a .Trashes folder with zero KB.


At this point, I panic and assume the position of despair. There is no 'undo' key for the D/U that I can find. I do an orderly shut down of the system, physically remove the Win7 BC drive, and make/verify a sector-by-sector clone of the drive (on a Win7 laptop, using Acronis--22 hours).


In Win7 Disk Management, the GPT partition (on the original drive) shows up and the BOOTCAMP partition shows up--with the proper size--but windows does NOT recognize the partition as being NTFS. It reports it as being RAW and 'urges' me to format it (yeah, right…).


So, I place the sector-by-sector duplicate back into the Mac, boot up (only the Mac OS is given as an option), and am ready to 'work on' recovering the Win7 BC partition (if possible).


I am avoiding trying to fix the booting problem, because recovery of the 1.2TB of a working system is much more critical for me.


The clone HDD reports the same in DU, except now the GPT partition shows up as greyed-out 'disk1s1', right above the "BOOTCAMP" partition in the sidebar. [I understand from researching this that disk1s1 is somehow related to the bootloader for BC?]


I used the demo version of Data Rescue 3 to scan for recoverable files from the drive, but it doesn't even report the .files. (I am running the deep scan now, but will take about another 9 hours to complete that).


Has anybody got any suggestions on how to reclaim this partition and its system?


Here are a couple of other details from diagnostic tools:


Model Name:    Mac Pro

  Model Identifier:    MacPro2,1

  Processor Name:    Quad-Core Intel Xeon

  Processor Speed:    3 GHz

  Number Of Processors:    2

  Total Number Of Cores:    8

  L2 Cache (per processor):    8 MB

  Memory:    13 GB

  Bus Speed:    1.33 GHz

  Boot ROM Version:    MP21.007F.B06


newmac:~ gmmx2$ sudo gpt -r show disk1

       start        size  index  contents

           0           1         PMBR

           1           1         Pri GPT header

           2          32         Pri GPT table

          34      262144      1  GPT part - E3C9E316-0B5C-4DB8-817D-F92DF00215AE

      262178        2014        

      264192      409600      2  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

      673792  2929602560      3  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

  2930276352         783        

  2930277135          32         Sec GPT table

  2930277167           1         Sec GPT header


newmac:~ gmmx2$ diskutil list


   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *1.0 TB     disk0

   1:                        EFI                         209.7 MB   disk0s1

   2:                  Apple_HFS Macintosh HD            999.9 GB   disk0s2


   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *1.5 TB     disk1

   1:         Microsoft Reserved                         134.2 MB   disk1s1

   2:                        EFI                         209.7 MB   disk1s2

   3:       Microsoft Basic Data BOOTCAMP               1.5 TB     disk1s3


   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *1.5 TB     disk2

   1:                        EFI                         209.7 MB   disk2s1

   2:                  Apple_HFS D3                      750.0 GB   disk2s2

   3:       Microsoft Basic Data DATA3                  749.9 GB   disk2s3


   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:     FDisk_partition_scheme                        *1.5 TB     disk3

   1:               Windows_NTFS SSDSUB                 1.5 TB     disk3s1



[Disk 1 is obviously the BC one]



newmac:~ gmmx2$ sudo fdisk /dev/disk1


Disk: /dev/disk1    geometry: -5415437/4/63 [-1364690128 sectors]

Signature: 0xAA55

         Starting       Ending

#: id  cyl  hd sec -  cyl  hd sec [     start -       size]


1: EE    0   0   2 - 1023 254  63 [         1 - -1364690129] <Unknown ID>

2: 00    0   0   0 -    0   0   0 [         0 -          0] unused     

3: 00    0   0   0 -    0   0   0 [         0 -          0] unused     

4: 00    0   0   0 -    0   0   0 [         0 -          0] unused     




I cannot be the only one who has much such a catastrophic error, so I am hoping that there is something I have overlooked (being only a part-time Mac user) or there is some utility somewhere which can fix this--


Or if you need more data, let me know...


thank you for your time--gmm

MacPro, Windows Vista, BootCamp
  • youngmacdonald Level 1 Level 1 (80 points)
    Currently Being Moderated
    Jan 29, 2013 4:09 PM (in response to gmillerx)

    There is a mbr / bcd tool I use in windows called easybcd I would put this on your windows 7 laptop and use this to remake or add a bcd to point to the hard drive from your Mac pro. Good luck

  • The hatter Level 9 Level 9 (58,560 points)

    What you don't do is use Disk Utility.


    On Mac Pro - install Windows on its own hard drive.


    Paragon Software's CampTune is your best friend. That and system restore images. Tehre is also WinClone 3.x (both are cheap $20 programs).


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.