Skip navigation

Pages can't open a document, what to do?

5862 Views 11 Replies Latest reply: Feb 17, 2014 2:01 AM by tessaleandra RSS
timtam84 Calculating status...
Currently Being Moderated
Jan 29, 2013 11:12 AM

Hi,

 

Since a couple of days Pages won't open any document for me. This includes documents I open immediatly from an e-mail, documents that I open via Pages or documents that I open via Documents. I get the message Pages has stopped immediatly then, including a large error screen. I'm also unable to open a template or a blank page. The message I get is for example 'The document 'Blank Canvas.template' can not be opened'.

 

Is there anyone who can help me fixing this problem? I found out Pages does work in a guest account, but I have all the documents that I need on my own account.

 

Thanks a lot!

MacBook Pro (15-inch 2.53 GHz), OS X Mountain Lion (10.8.2)
  • PeterBreis0807 Level 7 Level 7 (27,450 points)
    Currently Being Moderated
    Jan 29, 2013 2:07 PM (in response to timtam84)

    You either have a damged preference file (plist) which can be trashed from the System folder and Pages will recreate it, or a damaged font cache or a damaged font.

     

    Check your fonts by selecting them all in Font Book:

     

    Menu > File > Validate Fonts

     

    FontNuke [free] will clear your cache.

     

    Peter

  • jtouhalisky Calculating status...
    Currently Being Moderated
    Jan 29, 2013 3:50 PM (in response to PeterBreis0807)

    Peter

     

    Do you know specifically what the title for the Pages preferences is? I have looked through the preferences files and there are not any that say Pages.

     

    As I am having the same problem as Tim.

  • jtouhalisky Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 29, 2013 5:09 PM (in response to timtam84)

    I am providing more information, so hopefully it helps others:

     

    Pages 09 (v4.3) downloaded by itself, from app store on Jan 25, 2013. (Wow, how quickly for something not to work correctly, come on Apple... sorry had to spout)

     

    21.5 inch Mid2011 iMac with OS 10.7.5, 2.5 GHZ Intel Core i5, 16GB Ram

     

    Have seen other posts with this issue back in 2011, stating to remove preference fie (iWorks.Pages), however I looked for this file and any stating Pages and there were none to be found. So what file(s), specifically do we remove.

     

    The problem specifically, Pages 09 will not open it's own document it has opened/saved before. Specifically, Pages 09 comes up with an error box stating .....The document " ..." cound't be opened.

     

    The document is viewable in Preview, but will not open in Pages 09. Oh and if you are wondering. Copying and pasting from Preview to Pages does not work, as text is missing or replaced with & and other symbols.

     

    Any help would be appreciated and hopefully, APPLE is listening, because it appears this problem has been happening for awhile (I apologize again for spouting, but working for the past 4 days on this research paper for nothing!)

  • PeterBreis0807 Level 7 Level 7 (27,450 points)
    Currently Being Moderated
    Jan 29, 2013 5:21 PM (in response to jtouhalisky)

    com.apple.iWork.Pages.LSSharedFileList

     

    com.apple.iWork.Pages.plist

     

    Both inside the Preferences folder

     

    Peter

  • jtouhalisky Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 29, 2013 6:40 PM (in response to timtam84)

    Peter

     

    Found the files you suggested by doing the following:

     

    Go (upper left menu drop box) while holding down OPTION > Preferences > and dragged the files you suggested (com.apple.iWork.Pages.LSSharedFileList  and   com.apple.iWork.Pages.plist) to the trash.

     

    Still unable to open Pages 09's own documents previously created before 5 pm today.

     

    I also re-installed Pages 09 from the App store, to no avail.

     

    And also created a new user, logged in as new user, dragged the files to the new users drop box and tried to open Pages 09 files as a different user, but still unable to open.

     

    I had also tried Repairing Disk Permissions before all of this, but that did not help either.

     

    I am on hold with an APPLE representative right now, they had me try the above also, but unfortunately not working. But at least their helping and seem to be standing behind their products. I will repost if I get positive news and results.

  • jtouhalisky Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2013 2:37 PM (in response to timtam84)

    Tim

     

    Click on your desktop so FINDER appears in the upper left corner.

     

    While clicking the GO menu tab, hold down the OPTION KEY, and LIBRARY will suddenly appear in the menu selection.

     

    While holding the OPTION KEY still, click LIBRARY.

     

    From the folders in the library, open the PREFERENCES folder. (make sure you VIEW as List, so it is easier to find, since the list will give in alphabetical order)

     

    Scroll down to

     

    com.apple.iWork.Pages.LSSharedFileList

    com.apple.iWork.Pages.plist

     

    Tim, I tried draging the preference files to the trash, but did not work for me. Hopefully it works for you. I even had a very nice Senior Advisor from Apple try to help me last night and we still got no where. Even he could not open the Pages 09 document file on his own computer, as I had emailed him a copy.

     

    Just alittle note of what happened to me (21.5" mid-2011 iMac, 2.5 GHZ Intel Core i5, 16GB ram, OS 10.7.5 :

    Jan 25, 2013 downloaded Pages 09 (v4.3) from App store to my computer.

    By Jan 29, 2013 I had typed a 58 page document using the research template within Pages (5 sections: Cover Page, Table of Contents, Chapter Page, Text Page, Bibliography).

    On Jan 29, 2013 from 4:30 pm - 5:30 pm while typing research paper I had no problems "saving a version", at 5:36pm I selected the Bioblography from the section pull down menu and then "saved a version" of the document and planned to 'fill in the Bibliography' after eating dinner.

    I came back from dinner and Pages 09, gives me an Error box..... that the document cound't be opened.

    I can View the document in Preview, unlike others that said they had the same problem, but could not view their documents in Preview.

     

    But I noticed last night while discussing the matter with the Apple Advisor, that the last page (page 58) is actually blank, rather than having the standard "Bibliography title" at the top, like the template selection has on Pages 09. So something happened within the software when I made a selection from the "sections" pull down menu.

     

    Also, the only other program I had running at the time was iTunes (v10.6.3).

     

    The Apple Advisor even remotely accessed my computer last night but found nothing remarkable and took a copy of the document and hopefully Apple will have an answer and possible something to prevent it from happening to anyone else.

  • Peggy Level 8 Level 8 (38,085 points)
    Currently Being Moderated
    Jan 30, 2013 5:34 PM (in response to timtam84)

    Go menu.png

     

    Peggy_sig.png

  • Akivirtanen Calculating status...
    Currently Being Moderated
    Jan 21, 2014 12:51 AM (in response to timtam84)

    Wow

    I have been looking for this solution for a lng time and the instruction help me a lot. Now i can use it again. Thanks so much.

  • tessaleandra Calculating status...
    Currently Being Moderated
    Feb 17, 2014 2:01 AM (in response to Peggy)

    if i click on fonts the folder is empty! my error is -1712. any idea?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.