Skip navigation

how to disable adobe reader in safari

35208 Views 18 Replies Latest reply: Mar 31, 2014 6:26 AM by stokyo RSS
1 2 Previous Next
quatrieme Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 29, 2013 7:31 PM

I am aware there is this thread on basically the same problem How can I regain Preview as my default PDF browser in Safari?.

However my circumstances are a bit different.

 

One of my content vendors uses FileOpen to lock their PDFs and that is why I even bothered to install adobe (v10.1.4). Thru the install process I was careful not to have adobe become the default viewer by checking all the relevant boxes I saw.

 

When I go to Finder and doubleclick on a PDF, they are still opened by Preview. Right click->Get Info does show Preview as default viewer.

 

However in Safari, Adobe has taken over despite in Adobe->Preferences->display pdf in browser is not only unchecked but grayed out. But even though grayed out, right below that checkbox shows Adobe Reader.app is the browser view and I see no way of changing it.

 

In Library/Internet Plug-ins there are NO pdf plug ins. In fact I have only a single one (picasa).

 

I am not aware how to get to Username/Library/Internet Plug-ins as the reference thread talks about.

 

Whatever the solution, I still need adobe working on my machine otherwise I cannot view the content from that one vendor.

 

Any suggestions? Thanks.

 

Message was edited by: quatrieme to clarify Adobe->Preferences settings

MacBook Pro, Mac OS X (10.7)
  • Linc Davis Level 10 Level 10 (107,850 points)
    Currently Being Moderated
    Jan 29, 2013 7:54 PM (in response to quatrieme)

    From the Safari menu bar, select

      

    Help Installed Plug-ins

      

    Besides the following, what plugins are listed?

    • iPhotoPhotocast
    • Java
    • QuickTime
    • Shockwave Flash
    • WebKit built-in PDF
  • Linc Davis Level 10 Level 10 (107,850 points)
    Currently Being Moderated
    Jan 29, 2013 8:07 PM (in response to quatrieme)

    Back up all data.

     

    Triple-click the line of text below to select it, the copy the selected text to the Clipboard (command-C):

     

    /Library/Internet Plug-ins

     

    In the Finder, select

      

    Go Go to Folder

      

    from the menu bar, or press the key combination shift-command-G. Paste (command-V) into the text box that opens, then press return.

      

    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then quit and relaunch Safari, and test.

      

    I've seen an unconfirmed report that the "Silverlight" web plugin distributed by Microsoft can also interfere with PDF display in Safari, so you might need to remove it as well, if applicable.

      

    If you still have the issue, repeat with this line:

     

    ~/Library/Internet Plug-ins

     

    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • Sandra47 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2013 10:25 AM (in response to quatrieme)

    You  are wonderful. This finally solved my problem.

  • kctalker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 1, 2013 8:19 AM (in response to quatrieme)

    Awesome! Thanks for the help on this! Those two plug-ins were the culprits for me, too!

  • Chris Damico Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 13, 2013 12:46 PM (in response to Linc Davis)

    Hi same problem here and I cannot get the command go - go to folder to open up the folder.  It is telling me "The folder can't be found"

     

    I checked the internet plug-ins folder on my library and there are only 2 plug-ins listed but are not related.

     

    When I go to help - internet plug-ins in safari the same adobe items are listed as the original author showed.

     

    Help I need my preview back it's killing me!  I deleted Reader and what I thought to be all of the associated files.

  • Chris Damico Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 13, 2013 1:08 PM (in response to Chris Damico)

    OK I figured it out... I was able to find the plugin by searching for it by name "AdobePDFViewer....plugin"

     

    Deleted and whoala it worked!! Thanks

  • DoubleDeadGuy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 3:10 PM (in response to Linc Davis)

    I used the AppCleaner app to delete Adobe Reader and it took care of the Internet Plugins and application support stuff. So now there is absolutely nothing in my internet plugins folder, but I'm still having the problem. Help would be greatly appreciated. Adobe Reader is just awful.

     

    Using latest versions of all software and a 2013 MB Air.

  • kctalker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 5:51 PM (in response to DoubleDeadGuy)

    Dumb question for you, DoubleDead: Did you empty the Internet Plug-Ins from your user Library folder and not the system Library folder? The original post directs you to the system's Library folder; perhaps that difference is affecting you.

  • DoubleDeadGuy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 2, 2013 10:15 AM (in response to kctalker)

    Thanks, I think that was the problem. I just did a spotlight search and found it. I just made the jump up from 10.5 so I'm still acclimating to where everything is located.

  • kaycek1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2013 6:27 AM (in response to quatrieme)

    I am also having this problem.  I tried to follow Linc Davis's instructions, but I keep getting the message "folder not found".......

  • sigbiz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2014 2:50 AM (in response to quatrieme)

    There's a simpler workaround that works for me (MacBook Pro), Mavericks and Safari 7.

    If you let Safari do its useless display and move the cursor to bottom middle of the screen you get the four icons appear.  Click on the third symbol (The one after the expand / reduce size) and - the PDF then opens in Adobe Reader.

  • ultramantis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2014 7:00 PM (in response to quatrieme)

    Here is a link to the official Adobe page telling you how to do it. What I found is changing it under get info is not enough. Adobe recommends creating a new folder in your library called disabled Internet plugins. You can read the official adobe page or get to it under preferences in Adobe reader under internet.

     

    http://helpx.adobe.com/acrobat/using/display-pdf-browser-acrobat-xi.html

     

    There is one little hitch, you can't just move the files. You have to move them to the trash first and then move them to that file. If you don't it thinks you just want to make copies.

     

    Beware every time you install adobe reader, it will take over Safari. It has done this for years. The problem that has been mentioned is the two plugins:

     

    AdobePDFViewerNPAPI.plugin

    AdobePDFViewer.plugin

     

    In \Library\Internet Plug-ins

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.