1 Reply Latest reply: Jan 29, 2013 11:07 PM by mende1
D-Rut Level 1 Level 1 (0 points)

I bought this MacBook refurbished in early 2009, and I think this was made in 2008. I tried to download OS X Mountain Lion, and even though I already have 10.6.8 (or whatever the order of numbers are) it told me it's not compatible.

 

Please tell me that I don't have to buy another laptop just so I can have iCloud between my iPad, iPhone and MacBook...


MacBook, Mac OS X (10.5.8)