Skip navigation

Cant Netboot: tftp "error code 512: Access violation" on fresh install

1454 Views 3 Replies Latest reply: Jan 31, 2013 8:04 AM by Brian Nesse RSS
wolverinetheanml Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 29, 2013 1:32 PM

Hey everyone,

Im trying to netboot clients from my mac server running on a late model mac mini. Eventually I want to be doing this with the Deploy Studio software package

On a completely fresh install of Mountail Lion with Mountain Lion Server I have been using the documentation provided on the DS website set up the Mac Server, and installed and run Deploy Studio Assistant to create a netboot set.

To put it shortly at this point it won't netboot as it should.  With the netinstall service running on the server, the first red flag is that when selecting the startup disk on the client mac, the netboot image doesnt show up. Even if I set the startup using the bless command it wont boot from the network. After examing the logs on the server I can see that the server is acknowledging the bsdp requests and returning a list. This exchange reccurs for a number of repeats and then the exchange ends abruptly and the client boots to the local OS. Running through some of the troubleshooting information on the internet I was led to test the tftp connection. From the client I ran tftp to the ip of the server and attempted executing get /Library/Netboot/.../booter. This returns "Error code 512: Access Violation."

My instinct and the apparent instinct of the internet is that this is a permissions problem. So to correct this, starting with the file 'booter' and working my way up the folder tree, set gradually higher levels of permissions until now I am at the point where permissions is 777 all the way up to the folder tree, and I am continuing to get the same error.

Next, thinking that maybe this is really some oddball network issue related to my org that I dont understand, I set up a private network with just my machine and a client, enabling dhcp from the mac. Even this got me the Error Code 512: Access Violation message when running the tftp test, and just in case I also just went ahead and tried to netboot it and got the same conversation in the log.

In the process of doing this I changed about every setting I could think to change including jacking around with the tftp.plist and got nowhere. So I have now started with a totally fresh install again and leaving deploy studio out of the picture created a netboot set from the mountain lion installer and again with a completely fresh install I'm having exactly the same issue with netbooting, and when I test the tftp connection I get the same "Error Code 512: Access violation"

Anyone have any ideas?

Mac mini, OS X Mountain Lion (10.8)
  • Brian Nesse Level 4 Level 4 (2,750 points)

    Did you enable tftpd in "insecure" mode?

     

    man tftpd

  • Brian Nesse Level 4 Level 4 (2,750 points)

    Yep, that's configured for insecure mode.

     

    Another test is to look in /private/tftpboot/NetBoot.

    There should be a link in there. Make sure it points to a valid volume containing a /Library/NetBoot/NetBootSP0

     

    Did you enable verbose mode when you tested? Also, did you have spaces in the nbi name? As I recall the tftp command line doesn't like that much.

     

    bnesse5:~ brian$ tftp bnesse6

    tftp> verbose

    Verbose mode on.

    tftp> get NetBoot/NetBootSP0/NetBoot_DS_Test.nbi/i386/booter

    getting from bnesse6.apple.com:NetBoot/NetBootSP0/NetBoot_DS_Test.nbi/i386/booter to booter

    Received 313526 bytes in 2.6 seconds 964695 bits/sec


Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.