Skip navigation

iPhoto Disappeared After Clean Install of Mt. Lion

2573 Views 31 Replies Latest reply: Feb 10, 2013 7:44 PM by Neil2 RSS
1 2 3 Previous Next
Neil2 Calculating status...
Currently Being Moderated
Jan 30, 2013 10:18 AM

I did a clean install of Mountain Lion last month.  I reinstalled all my apps from freshly downloaded installers except iPhoto.  I don't know where to download the installer or how else to re-install it.  Do I have to wipe my drive clean again and install Leopard from my original DVD that came with my iMac?  That would be a huge job to get back to Mountain Lion.  Thanks in advance for any help.

 

BTW, the clean install of Mountain Lion caused permission problems.  The thread is here:  https://discussions.apple.com/thread/4758498

iMac (27-inch Mid 2010), Mac OS X (10.7.4)
  • LarryHN Level 9 Level 9 (54,870 points)
    Currently Being Moderated
    Jan 30, 2013 10:46 AM (in response to Neil2)

    How did you restore the iPhoto lbrary

     

    LN

  • Terence Devlin Level 10 Level 10 (121,680 points)
    Currently Being Moderated
    Jan 30, 2013 10:47 AM (in response to Neil2)

    Post the first 50 lines only of the crash report

     

    Regards

     

     

    TD 

  • Terence Devlin Level 10 Level 10 (121,680 points)
    Currently Being Moderated
    Jan 30, 2013 11:12 AM (in response to Neil2)

    That looks like you need to reinstall the app:

     

    Dyld Error Message:

      Library not loaded: /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlid eshow

      Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto

      Reason: image not found

  • LarryHN Level 9 Level 9 (54,870 points)
    Currently Being Moderated
    Jan 30, 2013 11:15 AM (in response to Neil2)

    Did you "copy" it from the TM drive or did you use TM to restore the iPhoto library?

     

    The files on the TM drive are not complete and you use Time Machine to go to the desired item a tthe desired time, select it and click on restore to have TM restore it properly

     

    LN

  • Old Toad Level 10 Level 10 (113,195 points)
    Currently Being Moderated
    Jan 30, 2013 11:22 AM (in response to Neil2)

    You need to download and apply the iLife Support 9.0.4 updater to install a missing component,

     

    /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlideshow

     

    OT

  • LarryHN Level 9 Level 9 (54,870 points)
    Currently Being Moderated
    Jan 30, 2013 11:23 AM (in response to Neil2)

    see the section on how to restore using Time Machine - http://support.apple.com/kb/HT1427?viewlocale=en_US&locale=en_US

     

    LN

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.