1 2 3 Previous Next 31 Replies Latest reply: Feb 10, 2013 7:44 PM by Neil2
Neil2 Level 1 Level 1 (0 points)

I did a clean install of Mountain Lion last month.  I reinstalled all my apps from freshly downloaded installers except iPhoto.  I don't know where to download the installer or how else to re-install it.  Do I have to wipe my drive clean again and install Leopard from my original DVD that came with my iMac?  That would be a huge job to get back to Mountain Lion.  Thanks in advance for any help.

 

BTW, the clean install of Mountain Lion caused permission problems.  The thread is here:  https://discussions.apple.com/thread/4758498


iMac (27-inch Mid 2010), Mac OS X (10.7.4)
  • 1. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    Sorry, I was looking at the wrong installer.  I found the restore disks for my iMac and it does allow me to install iPhoto seperately. The application program installers are on a different disk from the os restore.  There is an option to customize my installer to only install iPhoto. So, now I have iPhoto 8.1.2 installed.

     

    NEW PROBLEM: iPhoto crashes on launch.  I ran software update, and it said 'no updates available.'  Could this be related to my permission problem linked above?  I didn't see anything about permissions in the crash report.  There was something in there about a library not loaded, image not found.

  • 2. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    LarryHN Level 9 Level 9 (56,675 points)

    How did you restore the iPhoto lbrary

     

    LN

  • 3. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Terence Devlin Level 10 Level 10 (123,800 points)

    Post the first 50 lines only of the crash report

     

    Regards

     

     

    TD 

  • 4. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    Process:         iPhoto [5183]

    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

    Identifier:      com.apple.iPhoto

    Version:         8.1.2 (8.1.2)

    Build Info:      iPhotoProject-4240000~8

    Code Type:       X86 (Native)

    Parent Process:  launchd [141]

    User ID:         501

     

     

    Date/Time:       2013-01-30 13:49:02.546 -0500

    OS Version:      Mac OS X 10.8.2 (12C60)

    Report Version:  10

     

     

    Interval Since Last Report:          391638 sec

    Crashes Since Last Report:           275

    Per-App Crashes Since Last Report:   5

    Anonymous UUID:                      DA5FCAE2-3DFF-3B40-D681-6B155650B349

     

     

    Crashed Thread:  0

     

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

     

     

    Application Specific Information:

    dyld: launch, loading dependent libraries

     

     

    Dyld Error Message:

      Library not loaded: /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlid eshow

      Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto

      Reason: image not found

     

     

    Binary Images:

        0x1000 -   0x9fbfee  com.apple.iPhoto (8.1.2 - 8.1.2) <436E886C-E26D-2C7D-9745-252829318EFE> /Applications/iPhoto.app/Contents/MacOS/iPhoto

      0xb31000 -   0xb31fff  com.apple.Cocoa (6.7 - 19) <354094F0-F36B-36F9-BF5F-FD60590FBEB9> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

      0xb34000 -   0xdb0ff7  com.apple.QuickTime (7.7.1 - 2599.13) <FE609160-E1EF-341D-9B6A-205D3E03A4D2> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

      0xe59000 -   0xe59fff  com.apple.Carbon (154 - 155) <C0A26E7B-28F1-3C7E-879E-A3CF3ED5111C> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

      0xe5c000 -  0x1044ff3  com.apple.CoreFoundation (6.8 - 744.12) <E939CEA0-493C-3233-9983-5070981BB350> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x1172000 -  0x1172fff  com.apple.CoreServices (57 - 57) <956C6C6D-A5DD-314F-9C57-4A61D41F30CE> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

    0x117b000 -  0x1189fff  com.apple.opengl (1.8.6 - 1.8.6) <1AD1AE7B-B57B-35B5-B571-32A34F0DA737> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

    0x1191000 -  0x11f9ff7  com.apple.framework.IOKit (2.0 - 755.18.10) <9A80E97E-544F-3A45-916D-6DB7ED217E33> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x1224000 -  0x12fafff  com.apple.DiscRecording (7.0 - 7000.2.4) <BCFA6387-F4B4-3B16-A46E-B7E77C8FB769> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording

    0x1352000 -  0x13a0ff3  com.apple.SystemConfiguration (1.12.2 - 1.12.2) <7BA6C58B-0357-356F-BB69-17ACB5E35988> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

    0x13c7000 -  0x13d5ff7  libz.1.dylib (43) <245F1B61-2276-3BBB-9891-99934116D833> /usr/lib/libz.1.dylib

    0x13db000 -  0x13dbfff  com.apple.Accelerate (1.8 - Accelerate 1.8) <4EC0548E-3A3F-310D-A366-47B51D5B6398> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

  • 5. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    Larry, I copied my iPhoto library from my Time Machine drive.

  • 6. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Terence Devlin Level 10 Level 10 (123,800 points)

    That looks like you need to reinstall the app:

     

    Dyld Error Message:

      Library not loaded: /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlid eshow

      Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto

      Reason: image not found

  • 7. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    Strange.  I just installed it a few minutes ago from my system restord disk. I can do it again.  I have the disk handy.

  • 8. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    LarryHN Level 9 Level 9 (56,675 points)

    Did you "copy" it from the TM drive or did you use TM to restore the iPhoto library?

     

    The files on the TM drive are not complete and you use Time Machine to go to the desired item a tthe desired time, select it and click on restore to have TM restore it properly

     

    LN

  • 9. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    I think I just copied it, but I don't remember now.  I didn't know the difference.

  • 10. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    When I went to reinstall iPhoto again just now, I noticed the warning that I need to restart afterward.  I didn't do that last time.  I'll try a restart now.

  • 11. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Old Toad Level 10 Level 10 (115,690 points)

    You need to download and apply the iLife Support 9.0.4 updater to install a missing component,

     

    /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlideshow

     

    OT

  • 12. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    LarryHN Level 9 Level 9 (56,675 points)

    see the section on how to restore using Time Machine - http://support.apple.com/kb/HT1427?viewlocale=en_US&locale=en_US

     

    LN

  • 13. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    Mr. Toad, is iLife Support 9 appropriate for iPhoto 8?

  • 14. Re: iPhoto Disappeared After Clean Install of Mt. Lion
    Neil2 Level 1 Level 1 (0 points)

    The restart didn't fix the problem.  It still crashes on launch.  I'll try reinstalling and restarting again.

1 2 3 Previous Next