Skip navigation

Time Machine Very Slow (321 Days) Please Help!

728 Views 11 Replies Latest reply: Feb 22, 2013 12:26 AM by GerardFromUlrum RSS
daerve Calculating status...
Currently Being Moderated
Jan 30, 2013 10:58 AM

Hi all, I've got a 2012 MBP and have had problems with TM since day one.


I'm running all the latest software with a brand new Time Capsule and it states that it will take over 300 days to back up.


I originally used a NAS and TM was very very slow along with having to reformat and start again every few weeks so I gave in and got a TC thinking it would solve my problems but it's returned again.


I've tried reformatting, disabling spotlight, wired and wireless connections, different hard drives and still the problem persists. Occasionally it also fails to find the backup disk so I have to reformat and start again.


It's driving me absolutely insane because despite messing and messing, trying different solutions the problem always seems to return at random. It will work great for a week or 2 then it's back to square one.


Can someone please restore my sanity and help?

  • baltwo Level 9 Level 9 (59,180 points)
    Currently Being Moderated
    Jan 30, 2013 11:15 AM (in response to daerve)

    See Pondini's TM FAQs, for starters.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • baltwo Level 9 Level 9 (59,180 points)
    Currently Being Moderated
    Jan 30, 2013 11:32 AM (in response to daerve)

    Ah! The proverbial missing data. Sorry, but I don't do TM, so just pointed you to the definitive resource. Good luck.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • Eric Root Level 6 Level 6 (13,910 points)
    Currently Being Moderated
    Jan 30, 2013 12:49 PM (in response to daerve)

    One option is below, but you will have to start over.


    Incremental backup: Go to System Preferences/Time Machine and click on the options button. Exclude items until you get a reasonable size backup (10-20 GB seems to work). Backup and then using the - in the options window make more available for backup. Repeat until everything is backed up. It takes more time and effort this way, but it gets the job done. This is how I normally do a first time backup.


    It has been my experience that Time Machine tends to 'choke' if you try to do too much at once.


    Apple support article that mentions being slow:


    Time Machine Problems

  • Linc Davis Level 10 Level 10 (107,930 points)
    Currently Being Moderated
    Jan 30, 2013 5:05 PM (in response to daerve)

    If you have more than one user account, these instructions must be carried out as an administrator.

    Launch the Console application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.

    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left.

    Enter the word "Starting" (without the quotes) in the String Matching text field. You should now see log messages with the words "Starting * backup," where * represents any of the words "automatic," "manual," or "standard." Note the timestamp of the last such message. Clear the text field and scroll back in the log to that time. Select the messages timestamped from then until the end of the backup, or the end of the log if that's not clear. Copy them (command-C) to the Clipboard. Paste (command-V) into a reply to this message.

    If there are runs of repeated messages, post only one example of each. Don't post many repetitions of the same message.

    When posting a log extract, be selective. Don't post more than is requested.

    Please do not indiscriminately dump thousands of lines from the log into this discussion.


    Some personal information, such as the names of your files, may be included — anonymize before posting.

  • Linc Davis Level 10 Level 10 (107,930 points)
    Currently Being Moderated
    Jan 31, 2013 7:45 AM (in response to daerve)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether your problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • GerardFromUlrum Calculating status...
    Currently Being Moderated
    Feb 22, 2013 12:26 AM (in response to daerve)

    Hi guys,


    Have y'all checked Spotlight yet?

    I was experiencing the same problem. A TM backup with a size of about 670 MB took more than 24 hours.

    Did some digging and found out that Spotlight's indexing process was running.

    Switched it off using:


    sudo mdutil -a -i off


    TM backup is now back on its original speed, AFAICT.






More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.