13 Replies Latest reply: Sep 1, 2013 12:05 PM by Robin Curtis
pxphilli Level 1 Level 1 (0 points)

Is anyone else having connection problems with Mail 6.2? I'm running OSX 10.8.2 and Mail 6.2 (1499)?

 

When Mail starts all my mailboxes connect to their respective servers (GMail, iCloud and an ISP). IMAP and SMTP connections are all good and mails can be sent and received. But then............ after a while (I've not timed it so I don't know exactly but say 20 to 30 mins) the connections begin to drop. First the SMTP connections to the ISP go then the SMTP ones to GMail then iCloud, then the IMAP connections drop. All connection settings are correct (it was working remember) and using the same connection settings on my iPhone everythig works just fine, but the Connection Doctor (Or whatever it's called) tells me that the mail account can't connect to the network/IMAP/SMTP server and asks me to check my connection settings. The only way to get it to work is to close Mail and restart it, whereupon everything is hunky dory for the next 20 to 30 mins.

 

As it's happening to all my mail accounts including Apple's own iCloud server I don't think it's a mail server issue. As I have internet connectivity it's not a network connection issue in that sense. As it was connected but then drops the connection I'm assuming that Mail is sending something it shouldn't to the respective server when it tries to connect to send and receive mails.

 

Everything was just fine until about a week ago and I didn't do any s/ware upgrades.

 

Is anyone else experiencing similar issues or does anyone have any help they can offer to fix it? It's kinda tedious to keep closing and starting the Mail App.


MacBook Air (13-INCH, MID 2011), OS X Mountain Lion (10.8.2)
  • 1. Re: Connection problems with Mail 6.2
    Linc Davis Level 10 Level 10 (117,860 points)

    Does the Connection Doctor window show that Mail is connected to the Internet?

  • 2. Re: Connection problems with Mail 6.2
    pxphilli Level 1 Level 1 (0 points)

    I have an internet connection, it's not that which is the issue unless for some reason the Mail App isn't accessing the internet whilst the laptop, Safari and other programmes are. The next time it happens I'll cut and paste the complete message but the traffic lights go red and the message says, network connection unavailable, check you've entered the correct user name, password and information in account settings etc.

  • 3. Re: Connection problems with Mail 6.2
    Linc Davis Level 10 Level 10 (117,860 points)

    When Mail says it's not connected to the Internet, do other Internet applications work, such as web browsing? Do other devices on the same network connect?

  • 4. Re: Connection problems with Mail 6.2
    pxphilli Level 1 Level 1 (0 points)

    Yes, other internet applications work and other devices on the same network are connected. The problem just seems to be with Apple Mail. Hopefully the screenshot I took will insert here so it can be seen. You can see the comments in the Connection Doctor window and the alert triangle on the Mail screen next to each mailbox account. You can also see that SMTP connections are fine but IMAP are not connected. Where it suggests that SSL is deselected, it is already. Where it suggests that server port 143 may not accept connections, it does, this is the port specified by the ISP in that instance.

     

     

    file://localhost/Users/paulphillips/Desktop/Screen%20Shot%202013-01-30%20at%2020 .27.48.png

  • 5. Re: Connection problems with Mail 6.2
    pxphilli Level 1 Level 1 (0 points)

    Screen Shot 2013-01-30 at 20.27.48.png

    Screen shot added, drag and drop obvisoulsy doesn't work in this instance.

  • 6. Re: Connection problems with Mail 6.2
    Linc Davis Level 10 Level 10 (117,860 points)

    Follow the instructions under the heading "Mail Connection Doctor shows one or more red dots in the account Status column" on the page linked below:

     

    Mail: Troubleshooting sending & receiving email messages

  • 7. Re: Connection problems with Mail 6.2
    pxphilli Level 1 Level 1 (0 points)

    Have worked my way through this but now have to do one final thing which is to wait until Mail stops connecting again (I recently restarted it so it's all OK at present) and then do one of the things suggested in the support link you kindly provided. I'll let you know. Thanks for your help so far.

  • 8. Re: Connection problems with Mail 6.2
    pxphilli Level 1 Level 1 (0 points)

    Linc,

     

    OK, after several hours this time the connection was dropped again. Again on the IMAP connection. The message next to each account showing the error is

     

    The server returned the error: The server “mail.degrimme.com” cannot be contacted on port 143 or

     

    The server returned the error: The server “imap.gmail.com” cannot be contacted on port 993

     

    However, these are the correct server ports and if I were to close down Mail and restart the App then the acounts would connect via these ports and run perfectly OK for a while until ceasing to connect again. ... More below the image

     

    Screen Shot 2013-01-31 at 15.37.24.png

    I also ran a port scan using Network Utility and was told that port 993 at imap.gmail.com was open

     

    Port Scan has started…

     

    Port Scanning host: 173.194.66.108

     

      Open TCP Port: 993    imaps

    Port Scan has completed…

     

    I get the same result on the other accounts after a Port Scan i.e. port 993 is open, yet Mail is telling me that it can't connect to this port.

  • 9. Re: Connection problems with Mail 6.2
    Linc Davis Level 10 Level 10 (117,860 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether your problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • 10. Re: Connection problems with Mail 6.2
    pxphilli Level 1 Level 1 (0 points)

    Will do and will let you know although it may be a few days as I'm away this weekend. Thanks for your assistance.

  • 11. Re: Connection problems with Mail 6.2
    whh1953 Level 1 Level 1 (0 points)

    This is exactly the same issue I am having - you have articulated the problem very well. 

  • 12. Re: Connection problems with Mail 6.2
    Robin Curtis Level 1 Level 1 (40 points)

    Did you ever solve this problem?

     

    I realise that it is now September - and you encountered this in February 2013.  I was ok on a humble MackBook on 10.7, then moved (upgraded ?!)  to a MacBookPro on 10.8 Mountain Lion, and have this identical problem. Random, indeterminate dropping out of Mail connections - whether I am on my home network or my office network. IMPS, SMTP, POP - in no praticular order or preference. Using Connection Doctor to attempt to reconnect doesn't work. THe only solution is to stop Mail, and then restart it. All the connections get remade - mail omes and goes, and then the connections start to drop out - randomly - in no particualr order or preference.

     

    Have tried suggestions from Linc Davis - no luck so far. Thought it was damaged ethernet cables at one point - but have now ruled them out. Happens on both Wireless and hardwired ethernet. Have reinstalled OSX. Have done PRAM reset. Very strange!!

     

    Running Mail 6.5 Build 1508. OSX V 10.8.4

  • 13. Re: Connection problems with Mail 6.2
    Robin Curtis Level 1 Level 1 (40 points)

    Did you ever find a solution to this? I am having the exact same problem. Have posted below/earlier in reply to whh1953.

     

    Any comments / pointers much appreciated - having to restart Mail is a pain.  No problem with any other internet connected applications, eg Safari, Twitter. Firefox.