Skip navigation

How to Change Color on Mac OS 9

677 Views 6 Replies Latest reply: Jan 30, 2013 2:25 PM by Gary - former developer RSS
Tfkalk Calculating status...
Currently Being Moderated
Jan 28, 2013 6:25 PM

I recently got a PowerMac G3, and the machine has been displaying in grayscale when I first turn it on. Under the settings, it says 256 Colors. I can correct it, but then when I start the computer later, it reverts back. Is there a way to make the fix permanent?

PowerMac G3 (desktop), Mac OS 9.2.x
  • Don Archibald Level 10 Level 10 (101,125 points)
    Currently Being Moderated
    Jan 28, 2013 11:07 PM (in response to Tfkalk)

    Settings made via OS 9's control panels are retained in preference files. One or more of the applicable preferences files may have become locked, or damaged.

     

    Go to System Folder > Preferences. Locate the file named Display Preferences and the file named Monitor Preferences (the second one may be in a folder having the same name). Neither should be locked. If either is, you can unlock it ny doing a Get Info (Command-I) on the file.

     

    If neither file is locked, try throwing both of those files away, empty the Trash, then restart. New prefs files with default settings will be created automatically. This means you may need to redo the resolution choice as well as other settings, but you should need to do that only once.

     

    *****

     

    Another possibility, perhaps additional....

     

    If that machine had been stored for a long while, the internal battery may be too weak or dead. If that is the case, replacing it is the solution.

     

    However, if that machine is a Beige/Platinum desktop model (not an iMac nor a B&W), chances are the battery is okay - those older desktop G3 models usually won't display anything on the monitor if the internal battery is shot.

  • Jeff Level 6 Level 6 (11,160 points)
    Currently Being Moderated
    Jan 29, 2013 11:24 PM (in response to Tfkalk)

    Is this G3 a beige "All-in-One" model with the built-in screen or are you using a beige G3 desktop model with a connected display?

  • dalstott Level 4 Level 4 (2,445 points)
    Currently Being Moderated
    Jan 30, 2013 11:46 AM (in response to Tfkalk)

    Try reset of PMU or CUDA and PRAM if you haven't done it already.

     

    http://support.apple.com/kb/ht1939

  • Gary - former developer Level 1 Level 1 (95 points)
    Currently Being Moderated
    Jan 30, 2013 2:25 PM (in response to Tfkalk)

    This sounds to me like a hardware problem. Try using a different monitor.  Or try putting a video card in and running the monitor from that port rather than the one on the motherboard.

     

     

    Gary

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.