Skip navigation

USB Mouse, Keyboard not recognized in Windows

14785 Views 21 Replies Latest reply: Feb 8, 2014 2:11 AM by DlacVal RSS
1 2 Previous Next
Brother9 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 24, 2013 2:26 PM

Hello,

 

I have just installed Windows 7 Home Premium on my late 2012 iMac, the installation seems to have gone well except that after running the Bootcamp setup program Windows restarted and now does not recognize any mouse/keyboard - USB mouse and keyboeard as well as Magic Trackpad/Bluetooth keyboard are unresponsive. They worked before the restart, and also work in Safe mode.

 

Has anyone had/fixed this issue, or can direct me to instructions to help? I've looked over the forum and not found same issue. I'm assuming any fix would have to work in Safe mode as I can't do anything in Normal mode!

 

USB port issue?

 

I'm also assuming I will have to separately fix the Trackpad/Apple Keyboard issue, but first just want to get basic USB devices working.

 

Thanks!

iMac, Windows 7
  • Hotspur41 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 24, 2013 4:03 PM (in response to Brother9)

    Had exactly the same issue doing exactly the samw thing on my late 2012 iMac. Definatleu a software/driver issue.

    My work around:-

    Boot from Windows DVD, click repair, use System Restore to turn it back to before bootcamp driver install.

    Open the Windows Support folder you downloaded using Bootcamp Assistant, but don't run Setup, instead install each driver in all the folders individually.Only restart when all installed. I'm writing this in Windows now.

    However, I can't install the Bootcamp software, because it can only be installed by running Setup.

     

    I'm about to do this now. Wish me luck !!

    Will keep you posted

     

    Thanks

  • DubyaD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2013 5:44 PM (in response to Brother9)

    I tried your solution and did not have a positive result. USB keyboard and mouse work in Safe Mode, but I can not get them to work in Standard Windows login screen. The wireless mouse does not work in any mode. Anymore suggestions?

  • DubyaD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2013 6:10 PM (in response to DubyaD)

    Well... not sure why.. I unistalled the USB 3.0 eXtensible Host, leaving the driver on the system. Rebooted, after system set for a few minutes at Windows login screen the USB keyboard started working. Once in Windows 7 I reinstalled just the wireless mouse driver and now all works...

     

    Any idea of how you set Num-lock on the wired apple keyboard? In Windows the 10 key numerc section does not work for the numerals...?

  • Rad63 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 18, 2013 10:06 PM (in response to DubyaD)

    I am having the same problem except my installation is new so I can't do a system restore

    I can't get past the login password to remove that driver because the keyboard doesn't work.

    Any suggestions?

  • AC6VV-is-me Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2013 10:34 PM (in response to Brother9)

    Same sad story here.  Installing Win 7 Pro x64 on a new Mac Mini 2.6 quad core, windows worked until the Boot Camp Windows support software was added.  Probably the USB 3.0 problem.  This is a new installation, so there is no prior point to restore to.

     

    Help!

  • AC6VV-is-me Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2013 4:10 PM (in response to AC6VV-is-me)

    Just an update:  I talked to Apple tech support and was informed that I need to take this to Microsoft's Macintosh Support Group, which was after the tech has talked to Microsoft.  She gave me the number to call Microsoft.  I called it and after going through the menus I reached a polite person who insisted you can't run Windows on a Mac and that there is no Microsoft Macintosh Support group.

     

    Just for good measure I called the Apple group again and a different tech told me to call 1-800-Microsoft.  I did and got the same menus and a different tech who also insisted Macintosh and Windows computers are entirely different and Windows can't be installed on a Mac.  I asked for the Microsoft Macintosh Support Group again and was again told the group doesn't exist.

     

    I told the gentleman to have a nice day and hung up, so I could scream at the walls and use nasty words.

     

    BTW: If anyone at Apple or Microsoft is listening, the Apple case ID was 421511065 and the Microsoft case number was 1199297977.  Poor Bootcamp -- Nobody claims it.

  • AC6VV-is-me Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2013 10:01 PM (in response to AC6VV-is-me)

    Good News: I got it working OK.  Not sure exactly what fixed it, but will list what was done differently in case it helps someone else.

     

    1. Did a clean install from the Windows 7 Pro x64 disk I had purchased.  The first time I had used an ISO image downloaded from the Internet (not MS site) to create the thumb drive installer, per Bootcamp 4 instructions.

     

    2. Updated the Windows install using MS Update.  I had to install some drivers I found on the Bootcamp disk I made the previous time.  Those drivers were anything relative to Network and WiFi, so I was able to access the Internet.  Before that I couldn't connect.

     

    3. After the above, I repeated the download process that downloades the Windows support software for Bootcamp and made a new CD.

     

    It worked.

     

    I still find the service from Microsoft and even Apple to be an exercise polite but useless finger pointing.  Neither organization wanted to help me.  As with most tech support groups, the object is to get rid of the problem if possible by blaming someone else.  Imagine what might have happened if the Apple tech would have actually conferenced me on a call to Microsoft!  Tech support is non-existent for Bootcamp.

     

    Drop a line to AC6VV@arrl.net if you need anything explained about the above.  Cheers.  -John

  • Raldz Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 26, 2013 5:55 PM (in response to Brother9)

    I had the same issue and here is what resolved my issue:

     

    1. Go to Devie Manager
    2. Look for "Other Devices"
    3. right click on "Keyboard Hub"  <-- this apparently is my Appple Keyboard with USB mouse connected to it
    4. select Update Driver.. (must be connected to internet)...  then wait..
    5. should be working after the update (see attached image)Capture.PNG
  • Root777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2013 8:18 AM (in response to Brother9)

    So I had the same issue.

    After installing bootcamp drivers I had to go into safe mode and uninstall Intel's USB 3.0 drivers.

    Then I was able to get into windows "normal mode" and run windows update. I'm not sure which update fixed this issue but one did. Then after installing all the updates you can reinstall the USB 3.0 drivers and reboot.

    Now everything should work. Good luck to all!

  • DrPhlux Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 27, 2013 11:11 AM (in response to Brother9)

    Same problem with my Mid 2013 iMac 27 inch.

     

    Booted in safe mode with networking. Downloaded and installed:

     

    "USB 3.0 Driver: Intel® USB 3.0 eXtensible Host Controller Driver for Intel® 7 Series/C216 Chipset Family"

     

    from here:

     

    https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=21129

     

     

    Fixed everything.

  • Harleymhs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2013 3:40 PM (in response to Raldz)

    Well, YOUR FIX worked like a charm! I re installed the 3.0 usb controler, then applied YOUR fix for the keyboard! Now I have Apple Keyboard and USB 3.0 GREAT JOB! Thank you for taking the time to post your fix!!!! GOOD WORK!

  • sveur Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2013 4:23 AM (in response to DrPhlux)

    I have a similar problem. I'm trying to install W7, but the keyboard and trackpad are both unresponsive. Can I download those drivers and put them somewhere into the usb-install stick i've made?

  • sveur Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2013 7:16 AM (in response to sveur)

    SOLVED.

     

    I just did it all over again, and it worked. Removed the partition and installed from boot camp again.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.