Skip navigation

Should I use Safari 5.1.7 or stick with 5.0.5?

849 Views 13 Replies Latest reply: Mar 9, 2013 7:41 AM by Saxman RSS
Saxman Level 2 Level 2 (175 points)
Currently Being Moderated
Jan 29, 2013 12:36 PM

I immediately upgraded to Safari 5.1 a couple years ago (or more)  when it first came out, and got hit with a total mess of issues. Called Apple's second-level tech support, and was told they were aware of these major bugs, and would have a fix ASAP.

Well, a month or two went by & nothing, called again, and then they denied ever acknowledging any issues. So, I downgraded my Safari back to 5.0.5, and it's been working OK. However, lately it seems to be giving me more problems, and I thought it may be time to update, to what is now 5.1.7, and hopefully, they've corrected the many issues, especially the Autofill function which made you have to click on each option, instead of just having it AUTOmatically fill in the blanks.

 

Can anyone tell me if I would be better off upgrading, or should I just stick with 5.0.5?  Thanks...

iMac, Mac OS X (10.6.8), 21.5in. ,3.2 GHz i3, 12GB Ram
  • seventy one Level 6 Level 6 (8,525 points)
    Currently Being Moderated
    Jan 29, 2013 12:51 PM (in response to Saxman)

    They have updated further but with your 10.6 you should be on Safari 5.1.7.   That is if you have updated your OSX via the combo updater to 10.6.8.

     

    Once you are on Snow Leopard you will need to apply the Combo updater,  Mac OS X 10.6.8 Update Combo v1.1,  and follow with a software update to pick up any later improvements.

     

    Then sort out Safari 5.1.7

     

    But don't be tempted to go further.


  • LaRizzo Calculating status...
    Currently Being Moderated
    Jan 29, 2013 2:01 PM (in response to Saxman)

    Neither.

     

    IMHO, use Chrome.

  • seventy one Level 6 Level 6 (8,525 points)
    Currently Being Moderated
    Jan 29, 2013 3:41 PM (in response to Saxman)

    I don't believe Safari is inheritently buggy but the scope of its operations, as such, exposes it to much greater contamination than any normal application.   Nor have the developers done as much to ease things as they could have done.  How often for instance, do we read that to resolve a problem we should first turn off all Safari extentions and return them one by one to isolate some guilty element.

     

    In my experience, and it's not that great compared with many on these forums, Safari has performed excellently.   I have had Snow Leopard from its introduction and updated Safari as became necessary.   I run Firefox too, but only as support.

    As for Chrome, I tried it as an experiment and found it nothing but buggy ... and not without some easily caught malware either.

     

    So that's my opinion for what it's worth.    I'm happy with Safari 5.1.7 and with no thoughts of going to Mountain Lion, I shall not encounter Safari 6, which I hear is indeed buggy.

  • Lilscoop Calculating status...
    Currently Being Moderated
    Jan 30, 2013 10:23 PM (in response to seventy one)

    My system is running MAC OS X Version 10.6.8 and Safari Version 5.1.7.  Yesterday I clicked on Software Update within About My MAC because I hardly ever use my MAC and thus don't update regularly.  Now Safari won't open and I've ben researching this for two days now.  I'm wondering if updating the software caused this?

     

    Seventy One, I updated my OS X to 10.6.8 but I have no idea if I did it via the combo updater.  I had bought the disk, which was Snow Leopard 10.6 but held on to it for a really long time because I had heard of issues with Snow Leopard.  I suppose it is possible by the time I finally went to install Snow Leopard I could have been automatically upgraded to 10.6.8 rather than just 10.6, which was the disk version I had bought.  Since you're saying one would have needed to update to 10.6.8 but only through the combo updated, how would I know if this is how I had updated my OS X or not?  I don't know why Safari won't open...  HELP!

  • seventy one Level 6 Level 6 (8,525 points)
    Currently Being Moderated
    Jan 30, 2013 11:47 PM (in response to Lilscoop)

    It would seem that your progression with update and upgrades had become rather disjointed but if you had earlier applied the combo updater it would have taken you to the point that was valid at the date you did it.   Fortunately, you can apply the current version of Combo update over the top of previous versions so this you should do via ...

     

    Mac OS X 10.6.8 Update Combo v1.1 

     

    and follow with a software update to pick up any later improvements.

     

    The version of Safari should be 5.1.7 after all this ... but have you previously downloaded one or more Safari extentions.   If so, try removing / disabling them.   Then try again.   If it works you could reinstall the extensions one by one.


  • seventy one Level 6 Level 6 (8,525 points)
    Currently Being Moderated
    Feb 10, 2013 7:30 AM (in response to Saxman)

    It does present you with line by line alternatives ... but you have to remember the number of alternatives that our own work presents to it.   It is a small niggle in the greater scale of things.   Incidentally, Chrome is something to watch very carefully, particularly the extentions where I found one that connected with the notorious MacKeeper malware. 

     

    I suspect the mutiplicity of extentions allied to Google's excessively profit motivated approach means they aren't tested as thoroughly as we may wish.

     

    Which is why, I M H O, Safari scores because its natural alliance to Apple is protective to us users.

     

    Wish you well, whichever line you take ... and thank you for the star.

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Feb 10, 2013 8:39 AM (in response to Saxman)

    All OS x 10.6.8 users should NOT be using Safari as Safari 6 was not issued to 10.6 and has security fixes.

     

    All OS X 10.6.8 users SHOULD BE using Firefox or Chrome.

     

    https://support.apple.com/kb/HT1222

     

     

    Also Apple is rather slow with updates, rather opting for a mass of fixes at rare times rather then more often monthly updates like Firefox and Chrome do.

     

    All OS X users are safer on Firefox and Chrome, and Firefox is more concerned about users privacy than spyware Chrome from "we read your emails" Google.

  • seventy one Level 6 Level 6 (8,525 points)
    Currently Being Moderated
    Feb 10, 2013 9:06 AM (in response to ds store)

    Yes, agreed with that ds, but we are talking about Safari 5.1.7 and I believe that is the recommended version for Snow Leopard10.6.8.  

     

    My problem with Chrome was close to becoming really bad news as removing MacKeeper was less straightforward than today.

     

    One thing I didn't mention to Saxman is that Safari is probably the reason we still get occasional updates for Snow Leopard despite it being unofficially unsupported now.   (Java update from a few days ago).

  • baltwo Level 9 Level 9 (59,180 points)
    Currently Being Moderated
    Mar 7, 2013 11:38 PM (in response to Saxman)

    FWIW, I still use 5.0.5 w/SL, since I detest, mightily, the iOSified crapola added to 5.1.x. It does the job.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.