Skip navigation

Why does Compressor see progressive source material as interlaced

350 Views 1 Reply Latest reply: Jan 31, 2013 5:20 AM by Russ H RSS
Jerome Colas Level 2 Level 2 (215 points)
Currently Being Moderated
Jan 31, 2013 12:14 AM

Hi.

I have an odd problem with Compressor.

 

I want to use Compressor to batch convert master files (with Avid DNxHD codec) to Apple ProRes codec.

Compressor as Apple-made presets for that, with audio passthrough

 

The problem is that Compressor outputs interlaced files although the source files are progressive :

- the source files (DNxHD) are progressive (described as progressive by MediaInfo, and they are recognized as 1080p by Finat Cut Pro X)

- the output files (ProRes) are interlaced (described as interleced by MediaInfo, and they are recognized as 1080i by Final Cut Pro X)

 

Looking further, I saw in Compressor's inspector that the field nominance for the source media was by default set to upper field, although it should be set to progressive.

If I manually change it for every source file to progressive (which should be done automaticallt by Compressor), I then get a progressive output.

 

But that defeats Compressor's purpose and is a source for error.

 

Am I missing something or is it a Compressor bug?

Would you have any advice on how to handle the (seemingly simple) task of transcoding files from DNxHD to ProRES in a batch?

 

Thanks in advance for your help and have a great day!

 

Jérôme.

MacBook Pro with Retina display, OS X Mountain Lion (10.8.2), and other Macs too
  • Russ H Level 6 Level 6 (12,945 points)

    Jerome Colas wrote:

     

     

    If I manually change it for every source file to progressive (which should be done automaticallt by Compressor), I then get a progressive output.

     

    But that defeats Compressor's purpose and is a source for error.

     

    Jérôme.

    I'm not sure what this means.

     

    And I wonder whether it's a metadata thing and, and while disconcerting, whether it will have any practical effect on your project.

     

    As a test try a single clip. Turn on frame controls with output fields set to progressive. See if it is now identified correctly. If it is bring that into FCP and compare against that against the one that is identified as interlaced.

     

    If Frame Controls doesn't work, then I think I would use MPEG Streamclip. It's fast and has a very good batch feature.

     

    Good luck.

     

    Russ

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.