9 Replies Latest reply: Jan 31, 2013 11:48 AM by babowa
birdy176 Level 1 (5 points)

Just spent non-productive 90 minutes with 2 male techies, no names given, a Ms A., Ms S., a Mr. B and a supervisor A.


The first of these told me that I should re-install the two Snow Leopard disks I had received in the mail since that version includes the Quick Time MPEG-2 component. When I assured him that I had only one S.L. disk, he called for the intervention of another collleague.


Not so, according to the next techie, #2. S. L. came on only one disk and the item should be in the Time Machine. Told him TM stopped working when I installed Snow Leopard.


He then passed me on to Ms A., to whom I retold my troubles in all its inglorious details. She apologized and assured me that Ms S. could find my purchase order for the component but it would take a few minutes to pass that message on to her.


Ms S. told me ten minutes later that the forwarded message from Ms A. merely told her to take over my query which turned out NOT to be within her area of expertese. After repeating my thrice-told novel I was turned over to Mr. B. (#5) who told me that Snow Leopard is not compatible with apps from Leopard for which I had originally purchased the component.


He now sought the assistance of Super A., the sixth person I had the distinct pleasure to talk to after over an hour on the wire. He asked for permission to take over my screen to look for the component in the Time Machine the access to which I had lost since upgrading to Snow Leopard. My search shows almost 200 GB on the Time Machine recorded over two years.


He agreed and assured me that a Snow Leopard upgrade would NEVER cause the loss of any files and that opening the Time Machine and holding down the Option button would give me  that access. We failed to find anything relating to my purchase and he suggested I re-purchase the app. although I was able to give him date, case and purchase order number but the bean counters do not have records going back to 2010.

After we hung up I was not able to replicate entering the Time Machine's recording made before the upgrade in Novermber 2012. Thus I could not recover the Apple email which confirmed my original purchase of the MPEG component nor anything else recorded over the previous 14 months.



With the loss of 35% of Apple's market share I can understand that nobody of any authority would risk his job approving a free product repacement.


Am thoroughly disgusted with Apple Care whose paid-for subscription had expired after 3 years.



  • babowa Level 7 (29,955 points)

    I have had occasion to download the MPEG 2 component again, So I went to my account at the Apple store and looked under purchases. I do not know if they have a cut off date but when I tried it the last time I was able to download it again.


    Aside from this, do you have any other problems or questions?

  • birdy176 Level 1 (5 points)

    Thank you, Babowa,


    Am also in the Pac. NW. South Coast. Your reply tells me that mine is NOT an isolated problem.


    The last of the techies above checked into my purchasing history but the order could not be found due to having been made 2 years ago. My own notes show that I had to re-install the components twice since then after having problems but the Apple Store had no problem with recognizing my bona fides. At that time I was still under the extended Apple Care protection which may have something to do with the splendid cooperation I received.


    I was using the MPEG component to translate movies taken with a Panasonic video camera D-300 which uses small RAM discs and produces *.VOB format that had to be made readable for Quicktime before the file could be burnt to DVD. It is a somewhat cumbersome process, quite unlike downloading videos of lesser quality from my Fuji Finepix camera using SD cards.


    Reading your last kind question, the answer is YES!


    How can I enter my Time Machine on an external dedicated 500 GB drive to search the period BEFORE I upgraded to Snow Leopard, i.e., the dates visible before November 11, 2012? The individual marks and dates ARE visible but only barely, in contrast to the recent ones AFTER November 23 which "light up" when touched by the cursor arrow.


    What I badly need is access to the Desktop folder dated July through October 2012 for it contains 300 pages of a book I was editing on a weekly basis. Some 10,000 photos were fortunately stored on a second external drive and are accounted for.

  • babowa Level 7 (29,955 points)

    Regarding your MPEG component: if you can find a copy of your invoice, then you can show them that; if not, I don't know what to suggest if their own records "disappear" after a given time. I saved the installer after the last time, so I can reinstall if it should become necessary. FWIW: that playback component is included in Mountain Lion; however, if you use something like MPEG Streamclip to convert your videos (I use it a lot), that still needs it.


    As for your Time Machine problems: unfortunately for you, I do not ever use Time Machine - I much prefer different types of backups, so I am woefully ignorant on that subject, except to give you this link to the all-encompassing articles from our TM guru, Pondini:






    If those don't answer your questions, post back and I'll see if I can get his attention.

  • birdy176 Level 1 (5 points)

    I marked this as "it answered my question" because I learned more from you than the Apple gurus who evidently don't monitor this forum. I don't know anything about the point system and the levels but you deserve the rank of a general for your help.


    I received the component via electronic transfer if I recall and charged my credit card. I never kept anything on file that related to my purchases from Apple because I held them in high regard and didn't feel like I needed any evidence of my dealings with them. They proved me wrong in that they now put the burden of proof on me. Any notes I kept of my contacts served as guidance before I contacted Apple Care for my questions.


    As I was told, I cannot upgrade to one of the Lions (or Bobcats...?) with a formerly poor Leopard machine, Upgrading to a new computer would be the way to go but it'll most likely be a Windows machine which I had used heretofore. Also, going on 85, anything I install will be discarded by my grandkids born with Chinese iPhones in both ears. Windows'  aggravations were minor because they have far more apps and programs - even free ones - than Apple.


    Will study the links you gave, thanks again!

  • babowa Level 7 (29,955 points)

    Thanks for your kind words! No, these forums are strictly user to user with volunteers trying to help others. And I have gotten expert advice here myself! Most of us don't do it for the points  - they say they are "reputation" points, but I can easily ruin my reputation all by myself, thank you - I don't need help with that!


    And yes, the component was a download. If you are able to access old TM backups, then go to an old one and see if you can find the component using this file path:


    HD > Library > Quicktime > AppleMPEG2Codec.component.


    If you find it - and these are instructions for regular files, not files contained in Time Machine backups since I don't know how they work - you can hold down Option key and copy/drag the component onto your desktop - that will creat a copy and leave the original where it is. You could then simply follow above path and drag it there.

  • birdy176 Level 1 (5 points)

    I spent 90 minutes yesterday afternoon on the Apple help line repeating four times the gist of my difficulties. The last technician I was referred to as a senior advisor asked for permission to look at my computer and was able to "see" the large number of files which appear as grayed out and not accessible. We established that the TM stopped auto recording on the day that I upgraded to Snow Leopard in mid-November. The date marks below that light up properly when the  cursor hovers above them, but the previous 12 months remain barely visible.


    When I dug up dates from my hand-written contacts and the purchase order number, I was told that their records don't go back that far. Therefore, even if I could gain access to the dates and sent screen prints, they would not be able to ascertain that I ever purchased this item.


    One would assume that a senior advisor could find it within his powers to order a replacement since I have a sufficient number of records to show that I had lost the components once before and had no trouble in being



    His parting advice was that I should re-purchase it or get a free one on-line. There's no such nugget to be found - they do a rudimentary check and then demand payment. The one that tried to rope me in wanted

    $ 60.- , three times the Apple cost.


    Of course today I was invited to give a testimonial. Mine was less than laudatory given the lack of anything usable from a platoon of associates who saw fit to put me on hold for almost half of  the tour de force.


    I read through the links you sent and one of the remarks describes what I should see when opening Desktop and then open TM to find an earlier date, ditto  for Mail, both of which I cannot access - nor any other file - for any dates before November  2012 till back August 2011, when I installed the external drive.

  • babowa Level 7 (29,955 points)

    As I said, I don't use TM (main reason: I have no control over the backups), but - and this is just a shot in the dark: since TM gets rid of old backups to make room for newer ones, could it be that your TM disk was full and all the older ones were deleted by TM?


    So you do have backups from Nov 2012 on? Have you tried my file path to see if you can find your old component in one of the backups? As for a senior rep to tell you that they won't cover a measly $20 purchase is a bit, well, measly. If you can't find an old one, I'd cough up the $20, and - important!!!!! Before you click it to install it, make a copy of it to a safe place (Documents folder or external drive (better), but not a TM drive). Then install it.

  • birdy176 Level 1 (5 points)

    The drive has some 170 GB out of 500GB available. I followed your file path and found mention of the component and date of installation. Clicking on that line causes this drop-down in the Quick Time folder:


    "AppleMPEG2Codec.component" could not be found. Hangul cannot open this type of file".


    Have no idea where this Mr Hangul hangs out..


    I guess I'll have to live without it and use one of my Windows machines to open * VOB  files from the video camera's RAM disk and burn DVDs on the Windows system which gives me no grief. It margianalizes the iMac but am fed up with the difficulties caused by Apple's paranoia in trying keep much of their stuff propriatary. It still serves as a giant photo album  and email client. Since I'm not a gamer (Windows has the great original Tetris from the nineties...), I don't miss it too much. I'll definitely never upgrade it again - which was  the cause of all this trouble.


    Should have thought about  that solution before plunging into this morass.


    Thank you for all your patience and help!



  • babowa Level 7 (29,955 points)

    The record of installation could just be the "receipts" file (every install gets recorded with that - that is, if you're using the OS installer and not just dragging an app into the applications folder).


    Anyway, it's your decision and you need to do what you feel comfortable with. Glad to have been of some help.


    FWIW, I'm near the border of OR & WA.