2 Replies Latest reply: Jan 31, 2013 8:40 AM by GTheys
NTSystems Level 1 Level 1 (0 points)

I want to purchase Aperture and have a circa 2010 iMac running Snow Leopard.  The App Store says I need at least Lion, however I have seen postings that indicate Aperure 3.3 can run on Snow Leopard.


Aperture 3, Mac OS X (10.6.8)
  • 1. Re: Is Aperture 3.4 compatible with Snow Leopard
    Niel Level 10 Level 10 (242,035 points)

    Aperture 3.3 and 3.4 require Lion or newer. Earlier Aperture versions will run on Snow Leopard, but you need the DVD version of Aperture to use the updaters. Contact the Mac App Store support for assistance.

     

    (70690)

  • 2. Re: Is Aperture 3.4 compatible with Snow Leopard
    GTheys Level 1 Level 1 (0 points)

    Hi

     

    Best is to buy Aperture 3 in DVD format. It's prior 3.3 and 3.4 and is easily available on amazon.com

    Doing this as we speak as I have the same issue than you ... Only drawback is that you might be stuck with version 3.0 or something which has the early day issues/bugs you can imagine.

     

    Hope it helps

     

    Georges