Skip navigation

Incorrect size when photo edited in photoshop

4895 Views 65 Replies Latest reply: Apr 1, 2014 4:00 AM by Gleb G RSS Branched to a new discussion.
1 2 3 ... 5 Previous Next
sojourner42 Calculating status...
Currently Being Moderated
Dec 25, 2012 7:27 PM

If I am viewing an image at full screen in iPhoto and then open it for editing in Photoshop, The resulting saved image is the wrong size when it uploads to Flickr. Sometimes, it also appears at the wrong size when viewed in iPhoto as well. Generally, rebuilding thumnails corrects the problem. Likewise, images opened from the iPhoto grid view also do not appear incorrectly. Granted, I just named two work-arounds, but neither is very satisfying. Anyone else have a better idea?

Mini, Mac OS X (10.6.4)
  • LarryHN Level 9 Level 9 (54,810 points)
    Currently Being Moderated
    Dec 25, 2012 7:49 PM (in response to sojourner42)

    Given that we only know what you tell us

     

    Whta version of iPhoto do you have? what is your exact workflow? How are you uploading to Flickr? What version of PS? Is PS set as the external editor for iPhoto? are you saving (not saving as) the photo to return it to iPhoto?

     

    What are the dimensions of the photo before editing, after editing, when uploaded to Flickr and when viewed in iPhoto

     

    LN

  • mkmichaelmk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 19, 2013 3:30 AM (in response to sojourner42)

    THIS IS THE SAME PROBLEM I HAVE !

    Hope you could find a solution? I have the same problem, with edited jpegs, that are saved after editing, (not "save as"..) -  they show in Iphoto when doubleclicking on them in Megazoom (just the upper left corner f.e.)

     

    Thank you.

  • LarryHN Level 9 Level 9 (54,810 points)
    Currently Being Moderated
    Jan 19, 2013 7:55 AM (in response to sojourner42)

    There have been reports of that here - search for them - I do not remember if there was a resolution or not but I think there was

     

    Maybe the workaroung is not going from full screen as Sojourner42 suggests

     

    LN

  • cfrombarrhead Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 31, 2013 9:14 AM (in response to sojourner42)

    I am having the same problem using elements 11 from the app store and iphoto 9.4.2. I have tried sending to elements from thumbnail and large image but on saving back to iphoto image opens megazoom. The work arounds seem to work until iphoto is closed or computer sleeps then images resume opening mega large. Is apple doing anything to resolve this?

  • Old Toad Level 10 Level 10 (112,990 points)
    Currently Being Moderated
    Jan 31, 2013 9:59 AM (in response to cfrombarrhead)
    Is apple doing anything to resolve this?

     

    Have you reported it to Apple via http://www.apple.com/feedback/iphoto.html?

     

    I'm using PSE 10 (not from the App Store) and am not having the problem.  From what I can recollect it seems to be more associated with PSE 11 from the App Store and iPhoto 11. 

     

    OT

  • cfrombarrhead Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 31, 2013 10:25 AM (in response to sojourner42)

    Thanks old toad

    I have filed a report using the link in iphoto itself.

    I find it odd that all the fixes you and others have suggested work untill iphoto is closed and reopened then problem returns and it only started on upgrading to iphoto 9.4.2. This must surly be internal to iphoto?

    I am sorry to say that I mistyped my version of elements which should be 10 from the app store.

    I am thinking of buying the full version of elements 11 from adobe and using the inbuilt catalogue and doing away with iphoto completly as I do not want to risk loseing or corrupting my photos. Thanks for your interest

  • LarryHN Level 9 Level 9 (54,810 points)
    Currently Being Moderated
    Jan 31, 2013 10:37 AM (in response to cfrombarrhead)

    the only solution to avoid risking losing your photos is a good backup system - iPhoto is no better or worse than any program since they all use the same file storage system - iPhoto in theory is better since it always keeps the original untouched where as many other managers modify the digital negative leaving you with fewer restore options

     

    Without a good backup you are 100% guarenteed to lose all of your files including your photos sooner or later no matter what software you use to manage them

     

    LN

  • Old Toad Level 10 Level 10 (112,990 points)
    Currently Being Moderated
    Jan 31, 2013 11:04 AM (in response to cfrombarrhead)

    The Adobe PSE organizer is essentially a file/folder viewer. You can give it a try by for organizing photos it's not nearly versitile or easy to use as iPhoto. 

     

    Have you tried launching iPhoto with the Option key held down and creating a new, test library.  Import some photos and check to see if the same problem persists. That will tell us if it's limited to just that library or more widespread.

  • mkmichaelmk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 31, 2013 12:54 PM (in response to sojourner42)

    Well, i have tried building a second library and also the repair library function. With iPhoto and PS Elements 11 this bug is still there. Here is my prehistoric workflow: Now I drag the picture from iphoto to the desktop, from there to photoshop elements and after editing I save it on the desktop and , voila, back to iPhoto, and delete the original. Once a version is enhanced, and therefore better, I like to erase the original file if I want to.

    This program has become very buggy and is kind of crap.

    The bigger version, Aperture , works better with "edit in photoshop", but as reward you blow up your library by saving back to aperture a 8-bit tiff, with 10x the size. With no right button function like "convert to Jpeg" or similar. Now that's a great improvement if you have a small fast ssd that gets full in no time. Thanks Apple - it's time to look around at the PC corner next time....

  • Old Toad Level 10 Level 10 (112,990 points)
    Currently Being Moderated
    Jan 31, 2013 2:10 PM (in response to mkmichaelmk)

    Do you have PSE setup this way in iPhoto?

     

    Using Photoshop or Photoshop Elements as Your Editor of Choice in iPhoto.

     

    1 - select Photoshop or Photoshop Elememts as your editor of choice in iPhoto's General Preference Section's under the "Edit photo:" menu.

     

    iPPSeditor.PNG

     

    2 - double click on the thumbnail in iPhoto to open it in Photoshop.  When you're finished editing click on the Save button. If you immediately get the JPEG Options window make your selection (Baseline standard seems to be the most compatible jpeg format) and click on the OK button. Your done. 

     

    3 - however, if you get the navigation window

    iPPSsave.PNG

     

    that indicates that  PS wants to save it as a PS formatted file.  You'll need to either select JPEG from the menu and save (top image) or click on the desktop in the Navigation window (bottom image) and save it to the desktop for importing as a new photo.

     

    This method will let iPhoto know that the photo has been editied and will update the thumbnail file to reflect the edit..

     

    NOTE: With Photoshop Elements  the Saving File preferences should be configured as shown:

    PSE9fileprefs.PNG

     

    I also suggest the Maximize PSD File Compatabilty be set to Always.  In PSE’s General preference pane set the Color Picker to Apple as shown:

    PSE9genprefs.PNG

     

    Note:  to switch between iPhoto and PS or PSE as the editor of choice Control (right)-click on the thumbnail and select either Edit in iPhoto or Edit in External Editor from the contextual menu. If you use iPhoto to edit more than PSE re-select iPhoto in the iPhoto General preference pane. Then iPhoto will be the default editor and you can use the contextual menu to select PSE for your editor when desired.

  • cfrombarrhead Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2013 2:04 AM (in response to Old Toad)

    Ok

    Yes I have other back up of my photos on seperate hard drive and aslo have timemachine backing up iphoto as well.

    I have tried all the possible fixes you good people have given two or three times. They seem to work untill iphoto is closed and reopened and then the problem returns. it only affects photos which have been worked on in elements lately. Previous photos worked on in elements are not affected, untill they are processes again in elements.

    I have iphoto set to use elements as the photo editor and move photos into elements by right click and choose edit in external editor. This opens elements and loads the photo. When work id finished I click save and the photo goes back to iphoto in jpeg largest file size.

    On double clicking thumbnail in iphoto to open the photo I get a mega zoom sized picture even in full screen you cannot see the whole picture. If however I swipe the photo untill the next photo in the event is displayed and then swipe back the picture returns to normal size.

    This has only happened since I upgraded to iphoto 9.4.2, is it possible to regress to 9.4.1?

    My concern on loseing photos is, I think, more a fear that as its running at present iphoto may do somthing to corrupt the images.

    When I used the rebuild thumpnails option the problem went away but when I closed iphoto a message displayed saying updating libary and lo and behold on reopening the problem was back.

    Photos displayed in other programmes such as keynote etc open correctly I must admit I haven't tried to print any yet to see what size they would turn out.

    I appriciate your help and views

  • cfrombarrhead Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2013 2:18 AM (in response to sojourner42)

    I have also tried making a new test libary but this has the same problem it is fine until iphoto is closed and reopened then the megzoom comes back

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.