Skip navigation

iOS 6 disables wi-fi on sleep mode - disappointing

91164 Views 249 Replies Latest reply: Nov 17, 2013 8:51 AM by Bill Stephenson RSS Branched to a new discussion.
  • vaancee Calculating status...
    Currently Being Moderated
    Jan 22, 2013 9:36 PM (in response to Jedi-John)

    You can test TX vs RX by logging onto your router.  You will see a speed connection for the RX, and a speed connection for the TX.

     

    Previous iOS will turn off the TX but leave the RX to listen for things like push notifications.

     

    In iOS 6, both TX and RX shut off.  Period.

     

    AT&T won't let me do Facetime over Cellular Data because I have the unlimited data plan.  Since Wifi shuts off, I am unable to receive Facetime calls when my screen is off.  This iPhone 5 is going right back to the store pretty soon if they don't fix it.  I'll just buy a Samsung Galaxy S3.

  • iditsuda Calculating status...
    Currently Being Moderated
    Jan 23, 2013 1:55 PM (in response to vaancee)

    The Galaxy S3 has the option to Keep WIFI on Always or Never when the screen is off.

     

    Anyway, I found a workaround that if I turn on wifi sync in iTunes at home, the wifi will stay connected. However, I don't want to install iTunes at work and all the places I use wifi, so this workaround only works at home.

     

    Apple needs to give the option to Keep WIFI on Always!

  • goatdog22 Calculating status...
    Currently Being Moderated
    Jan 25, 2013 12:42 PM (in response to iditsuda)

    Doesnt the phone use data if not connected to Wi-Fi? Didnt some of the providers stop offering unlimited data about the time the IOS6 update came out? i know for those of you with unlimited it doesnt really matter but I have 2g. In one month i had gone through 1g and trust me when i say i dont go anywhere that doesnt have wi-fi except driving. I only noticed this after the upgrade. i used almost 0 before it. Anyway just a thought. 

  • SiLv3sTeR86 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2013 11:26 PM (in response to yanipopo)

    Hi I have testing with my 2 modem for WIFI LOSS OR DISABLE when STANDBY or LOCKED

     

    iDevice SETTING:

    CERULAR DATA OFF

    3G OFF

     

    Results after locked 20mins:

    DLINK MODEL:  DSL-2640B which only availble wireless B/G

    MODEM SETTING: WPA2-PERSONAL

    MIXED B/G

    CHANNEL: AUTO

    iPhone 4      1 unit      IOS 6.0.1     WORKING FINE

    iPhone 4      1 unit      IOS 5.1.1     WORKING FINE

    iPad 1          1unit      IOS5.1.1     WORKING FINE

    iPad 3     1unit     IOS6.0.1          WORKING FINE

    iPhone 5     1unit     IOS6.0.2     LOSS WIFI when STANDBY or LOCKED, gmail, line, whatsapp no pop up...

     

    Results after locked 20mins:

    TPLINK TL-MR3420 which support B/G/N

    MODEM SETTING: WPA2-PERSONAL

    MIXED B/G/N

    CHANNEL: AUTO

    iPhone 4      1 unit      IOS 6.0.1     WORKING FINE

    iPhone 4      1 unit      IOS 5.1.1     WORKING FINE

    iPad 1          1unit      IOS5.1.1     WORKING FINE

    iPad 3     1unit     IOS6.0.1          WORKING FINE

    iPhone 5     1unit     IOS6.0.2     WORKING FINE, gmail, line, whatsapp pop up! WORKING!

     

    BEFORE received my iPhone 5, it come with IOS6.0.1, i DID NOT Test anything direct UPDATE to IOS 6.0.2.

    NIGHTMARE!!! Wifi keep disconnect and reconnect with my router! WIFI slow 0.22mb/s on my 4mb INTERNET!

    WHAT I DO:...

    DOWNLOAD and RESTORE IOS6.0.2, RESTORE FROM BACKUP     NOT WORKING! slow wifi, disconnect...

    RESTART iPhone 5  and RESTORE in DFU mode, SET as NEW     NOT WORKING! slow wifi, disconnect...

    ...WANNA GIVE UP!

     

    LAST I DO....

    RESET NETWORK SETTING...

    Celular and 3G OFF

    BRIGHTNESS TURN TO MAX, DISABLE AUTO BRIGHTNESS

    AUTO LOCK DISABLE

    and OPEN WIFI Page and CONNECT to YOUR WIFI, LEAVE the WIFI Page reload and reload and reload for 10pm to next day 7am (go to sleep, leave it 9hours reloading), KEEP THE WIFI PAGE RELOAD AUTOMATIC and BRIGHTNESS to MAX...

     

    OK! TURN OFF the WIFI, Shut Down iPhone with Power Button only, Start iPhone again...

    Connect WIFI, SIGNAL before 1bar Now can detect 2bar...I dont know why...

    WIFI did not drop and keep reconnect, stable! PROBLEM SOLVE!

    SPEEDTEST back to 4mb/s as previous slow speedtest 0.22mb+/s only...

     

    Now the Problem left is my iPhone 5 WIFI not support with my DLINK(wireless B/G only), I swap to TPLINK(wireless B/G/N), PROBLEM SOLVE, received PUSH MESSENGE(GMAIL, LINE, WHATSAPP) when iPhone Locked

     

    DONT ASK ME WHY IT WORKING! I JUST A NORMAL USER...

    Hope can help...GIVE ME a LIKE if WORKING...LOL

     

     

     






  • SiLv3sTeR86 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2013 11:54 PM (in response to goatdog22)

    Hi I have testing with my 2 modem for WIFI LOSS OR DISABLE when STANDBY or LOCKED

     

     

    iDevice SETTING:

    CERULAR DATA OFF

    3G OFF

     

     

    Results after locked 20mins:

    DLINK MODEL:  DSL-2640B which only availble wireless B/G

    MODEM SETTING: WPA2-PERSONAL

    MIXED B/G

    CHANNEL: AUTO

    iPhone 4      1 unit      IOS 6.0.1     WORKING FINE

    iPhone 4      1 unit      IOS 5.1.1     WORKING FINE

    iPad 1          1unit      IOS5.1.1     WORKING FINE

    iPad 3     1unit     IOS6.0.1          WORKING FINE

    iPhone 5     1unit     IOS6.0.2     LOSS WIFI when STANDBY or LOCKED, gmail, line, whatsapp no pop up...

     

     

    Results after locked 20mins:

    TPLINK TL-MR3420 which support B/G/N

    MODEM SETTING: WPA2-PERSONAL

    MIXED B/G/N

    CHANNEL: AUTO

    iPhone 4      1 unit      IOS 6.0.1     WORKING FINE

    iPhone 4      1 unit      IOS 5.1.1     WORKING FINE

    iPad 1          1unit      IOS5.1.1     WORKING FINE

    iPad 3     1unit     IOS6.0.1          WORKING FINE

    iPhone 5     1unit     IOS6.0.2     WORKING FINE, gmail, line, whatsapp pop up! WORKING!

     

     

    BEFORE received my iPhone 5, it come with IOS6.0.1, i DID NOT Test anything direct UPDATE to IOS 6.0.2.

    NIGHTMARE!!! Wifi keep disconnect and reconnect with my router! WIFI slow 0.22mb/s on my 4mb INTERNET!

    WHAT I DO:...

    DOWNLOAD and RESTORE IOS6.0.2, RESTORE FROM BACKUP     NOT WORKING! slow wifi, disconnect...

    RESTART iPhone 5  and RESTORE in DFU mode, SET as NEW     NOT WORKING! slow wifi, disconnect...

    ...WANNA GIVE UP!

     

     

    LAST I DO....

    RESET NETWORK SETTING...

    Celular and 3G OFF

    BRIGHTNESS TURN TO MAX, DISABLE AUTO BRIGHTNESS

    AUTO LOCK DISABLE

    and OPEN WIFI Page and CONNECT to YOUR WIFI, LEAVE the WIFI Page reload and reload and reload for 10pm to next day 7am (go to sleep, leave it 9hours reloading), KEEP THE WIFI PAGE RELOAD AUTOMATIC and BRIGHTNESS to MAX...

     

     

    OK! TURN OFF the WIFI, Shut Down iPhone with Power Button only, Start iPhone again...

    Connect WIFI, SIGNAL before 1bar Now can detect 2bar...I dont know why...

    WIFI did not drop and keep reconnect, stable! PROBLEM SOLVE!

    SPEEDTEST back to 4mb/s as previous slow speedtest 0.22mb+/s only...

     

     

    Now the Problem left is my iPhone 5 WIFI not support with my DLINK(wireless B/G only), I swap to TPLINK(wireless B/G/N), PROBLEM SOLVE, received PUSH MESSENGE(GMAIL, LINE, WHATSAPP) when iPhone Locked

     

     

    DONT ASK ME WHY IT WORKING! I JUST A NORMAL USER...

    Hope can help...GIVE ME a LIKE if WORKING...LOL

  • abfield Level 1 Level 1 (0 points)

    Thanks for testing all of this but my problem is that it works fine at home but not in the office. I have no control over the router settings at work so I can't change any of it. Like mentioned in an earlier post, if while at the office I go into settings on the iPad and iPhone and reset all Network settings and then reconnect to my corporate WiFi, everything works great. It's only once I come home and then back to the office the next day that it starts disconnecting again. Grrrrrrrrrr!!

  • Morac Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jan 28, 2013 11:15 PM (in response to abfield)

    I've found that some Wifi networks screw up iOS 6 just by connecting to them.  For example I went to my brothers place and when I came home, both my iPad 2 and iPhone 4S started randomly dropping packets for long periods of time.  The "fix" for this for me is to restart the device. 

     

    You can try rebooting your devices when you go to your office.

  • abfield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 29, 2013 6:00 AM (in response to Morac)

    I've tried rebooting at the office. No luck.

  • Muji_23 Calculating status...
    Currently Being Moderated
    Jan 30, 2013 6:15 PM (in response to yanipopo)

    HERE'S THE SOLUTION:

     

     

    I came accross this issue all over the net, with no real solution. So I did some testing and this is what I found.

     

    (An update to iOS 6 was released today..unfortunately that still didn't fix the problem..for me anyway).

     

    From what I understand:

     

    This new 'feature' of iOS6 dissables the wifi radio when an iOS device has been in sleep for abit, but it also somehow turns the iOS device's wifi radio back on when it needs to (i.e. when a push email/ notification/ imessage is coming through) even when the device is in sleep. This is when the feature works. But there is a buggy loophole that arrises which causes the wifi radio to not automatically 're-engage' when it should.

     

    If you find that you only get emails/notificaitons and imessages when you wake up your ios device, and not as they come in, it's because, at some point, you have done a series of actions that result in the wireless radio not knowing how to turn itself on when in sleep.

     

    This is how you fix it

     

    1) Turn wifi on (doesn't matter if you connect to a wifi network now or later, but the wifi toggle must be on). If your ios device supports mobile data, turn it off for now.

     

    2) Turn off the device (by keeping the sleep button pressed and then swiping)

     

    Wait 30s

     

    3) Turn it on

    4) After the home screen loads, reset it (hold the home and sleep buttons down and keep holding until you see the apple logo)

     

    That's it.

     

    Now, when your device is in sleep, the wifi radio will re-engage when it needs to.

     

    People with 3G always on won't experience this problem because when an iPad/ iPhone is in sleep (and hence, the wifi radio is turned off), having the mobile/cellular data on somehow wakes up the wifi radio if messages and stuff are coming in.

     

    (I believe in Apple. It would be just plain stupid to introduce a feature that completely dissables wifi when in sleep, just to save battery..this isn't the feature people, this is a bug of an actually great feature. Attempting to save battery life by only having the wireless radio turn itself off when in sleep (and not having it turn itself back on) is creating a problem in the attempts to get rid of a reduced battery life problem. Have some faith in apple! Haha. This is not going backwards..this is going forward, with style...and a bug.)

     

                               -------------------------------------------------

     

    Below are the series of actions (if you're curious) that you have done at some point in time that have caused the wifi radio to forget to reengage when in sleep: (so there's a set of actions to induce the bug, and to hide it)

     

    Turn wifi off

    Turn off device

    Turn on device

    Reset device

    Turn on wifi

     

    Now you won't get push emails and stuff when your device is sleeping.

  • Morac Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jan 30, 2013 9:45 PM (in response to Muji_23)

    iOS has always disabled Wifi when the screen locks if a cellular connection is available.  My old iPhone 3GS did that back in iOS 3 and 4 and my iphone 4S and iPad 2 3G do that with iOS 5 and 6 so it's not a new feature in iOS 6.  It's always worked that way.  What changed is that the iOS 6 code is very picky about Wifi (I.e. not as compatible as iOS 5) and sometimes has trouble connecting to networks.  iOS 6 also has a Internet connection test built in so if it connects to a Wifi network, but can't connect to the Internet, it will drop the Wifi connection. I think that's only for cellular capable devices though.

     

    I'll mention though that since upgrading to iOS 6.1, the Wifi seems less flakey. I haven't noticed my iPad dropping the Wifi connection for no reason as of yet.

     

    I'll also mention that even when the wifi sleep works correctly, sometimes the device will still use the cell connection when getting push emails if it takes too long to establish a wifi connection.

     

    Finally I'll mention Wifi only iOS devices can't shut off Wifi when the screen locks because then push notifications won't work unless Apple found some kind of magic Wifi that works when the wifi radio is turned off.  iOS devices maintain a constant connection to Apple's push servers.  Models with cellular capability prefer using that for that push server connection (even when Wifi is active), but wifi only devices have no choice but to use wifi.  Occasionally the push server connection drops if there's a poor signal and doesn't get re-established.  Turning on airplane mode, waiting 10 seconds and turning off airplane mode should fix that.

  • iditsuda Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 31, 2013 8:12 AM (in response to yanipopo)

    That's all interesting information. But it doesn't address the user requirement.

     

    We need an option to Keep WIFI ON when the phone is sleeping because we do not wish to use cell data at home and office where wifi is available and stable.  This is mainly because cell data is not cheap, and battery usage is not a concern in those locations.

  • hfuelle Calculating status...
    Currently Being Moderated
    Jan 31, 2013 12:52 PM (in response to yanipopo)

    I guess another mistake is connected to this behaviour.

    Activitating the personal hotspot works only sometimes, especially when I am activating it, and no power supply is connected and I manuall switch off the diplay after activating. Then my PC cannot see the hotpsot.

     

    If I don't put it into sleep mode, the hotpsot can be seen - once the PC is connected it stays stable, doesn't matter wether it is in sleepmode or not.

     

    Any one any idea ?

  • Penny00Lane Calculating status...
    Currently Being Moderated
    Jan 31, 2013 8:43 PM (in response to Muji_23)

    Finally!! Thank you muji23 this worked beautifully with my ipod and ipad 3!

     

    Cheers.

  • abfield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2013 7:53 AM (in response to Muji_23)

    I tried this on my iPad 2 (WiFi-only) and it didn't work. I have not upgraded to 6.1 yet but I can try that as well. I'm very frustrated.

  • Muji_23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2013 8:47 AM (in response to abfield)

    Hmm. Can I suggest doing the actions that cause the problem (end bit of my post), and then the actions that 'solve' it again?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.