3 Replies Latest reply: Feb 1, 2013 5:40 AM by Linda MCCrary
Linda MCCrary Level 1 Level 1 (0 points)

I have over 600 purchased songs in my library.  When I try to play one it only plays for a minute or so. I even tried redownloading some of the songs and the message is "already purchased".  My sister-in-law died today and I'm trying to learn a Gospel favorite of hers that's in my library, for her funeral.  I can't believe I only get about a minute or so of the song.


MacBook Pro (13-inch Mid 2010), Mac OS X (10.7.5), Songs purchased play for a minute
  • 1. Re: My purchased music is truncated
    Jon Milan Level 1 Level 1 (110 points)

    First of all, check the Info on the downloaded song (File -> Get Info) after you select the track, or <cmd-I>.

     

    Make sure in the Options tab there's nothing odd about the Start Time and End Time.   While you're there, go to the Summary tab and note where the song file is stored on your hard drive.

     

    You might try moving the file from your iTunes folder on your hard drive to a safe location,  Then remove the file from iTunes (iTunes should show the little grey exclamation next to the song since the file's not where it expects any longer).   Then reimport the file <cmd-O> from wherever you moved it.   This is just in case it is the Library that's messed up and not the download.

     

    If that doesn't change things, then the downloaded file is the problem and you can contact Apple.  They've been good for me when I've had download faults.

  • 2. Re: My purchased music is truncated
    Steve Taylor1 Level 5 Level 5 (4,660 points)

    to redownload content from the iTunes Store.

     

    First delete the content from iTunes. Just try one track first

     

    Then in iTunes Store click on the purchased link under Quick LInks on the right

     

    Navigate to the music and use the cloud button to re download.

     

    If it works for one track repeat for the others

  • 3. Re: My purchased music is truncated
    Linda MCCrary Level 1 Level 1 (0 points)

    My get info selection is greyed-out. I've tried deleting a trac also and can't do that either. when I select the trac, it just begins to play the truncated version.