7 Replies Latest reply: Feb 1, 2013 7:56 AM by The Art Of Sound
Abbzman Level 1 Level 1 (0 points)

sorry guys i know you must hear this all the time, i am very new to the mac community.

 

I have just downloaded Logic Pro 9 and i am getting the following error

 

Process:         Logic Pro [806]

Path:            /Applications/Logic Pro.app/Contents/MacOS/Logic Pro

Identifier:      com.apple.logic.pro

Version:         9.1.8 (1700.67)

Build Info:      Logic-17006700~2

App Item ID:     459578486

App External ID: 10394291

Code Type:       X86-64 (Native)

Parent Process:  launchd [148]

User ID:         501

 

 

Date/Time:       2013-02-01 14:31:14.393 +0000

OS Version:      Mac OS X 10.8.2 (12C60)

Report Version:  10

 

 

Interval Since Last Report:          348 sec

Crashes Since Last Report:           3

Per-App Interval Since Last Report:  1 sec

Per-App Crashes Since Last Report:   3

Anonymous UUID:                      07F946FF-8A06-7569-5B22-C8011683E337

 

 

Crashed Thread:  0

 

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

 

 

Application Specific Information:

dyld: launch, loading dependent libraries

 

 

Dyld Error Message:

  Library not loaded: /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

  Referenced from: /Applications/Logic Pro.app/Contents/MacOS/Logic Pro

  Reason: no suitable image found.  Did find:

          /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit: no matching architecture in universal wrapper

 

 

Binary Images:

       0x100000000 -        0x100c18fef  com.apple.logic.pro (9.1.8 - 1700.67) <EDA152B8-910C-6010-621F-7A2CB64BC6CB> /Applications/Logic Pro.app/Contents/MacOS/Logic Pro

       0x101086000 -        0x1010a4fef  com.apple.XSKey (1.0.0 - 52) <800DD908-E341-2BCD-11D9-DEAC7E8197E9> /Library/Frameworks/XSKey.framework/Versions/A/XSKey

       0x1010b6000 -        0x1010f0ff7  com.apple.music.apps.MAAudioUnitSupport (9.1.8 - 233.53) <B92629D6-A8BC-D2CA-EC11-CE2133CC973D> /Applications/Logic Pro.app/Contents/Frameworks/MAAudioUnitSupport.framework/Versions/A/MAAudioUnit Support

       0x101115000 -        0x101143ff7  com.apple.musicaudiodataservices (1.1 - 251.4) <93B2F8C3-E091-C1CA-8932-91840CC968BC> /Applications/Logic Pro.app/Contents/Frameworks/MAAssetSharing.framework/Versions/A/MAAssetSharing

       0x101157000 -        0x101159fff  com.apple.ExceptionHandling (1.5 - 10) <47FF83ED-0C07-308C-A375-2A2189DB1056> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHand ling

       0x10115e000 -        0x1011c1ff7  com.apple.music.apps.MALoopManagement (9.1.8 - 219.66) <78F9FDA0-502C-DB75-1963-FEA5B7187087> /Applications/Logic Pro.app/Contents/Frameworks/MALoopManagement.framework/Versions/A/MALoopManagem ent

    0x7fff6da24000 -     0x7fff6da5893f  dyld (210.2.3) <36CAA36E-72BC-3E48-96D9-B96A2DF77730> /usr/lib/dyld

    0x7fff8c3ec000 -     0x7fff8c459ff7  com.apple.framework.IOKit (2.0 - 755.18.10) <142E19DD-1C8D-3D61-ABC8-83994A73279F> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x7fff8fb65000 -     0x7fff8fc38ff7  com.apple.DiscRecording (7.0 - 7000.2.4) <E5F3F320-1049-32D8-8189-916EF5C40A1A> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording

    0x7fff90a90000 -     0x7fff90aa2ff7  libz.1.dylib (43) <2A1551E8-A272-3DE5-B692-955974FE1416> /usr/lib/libz.1.dylib

    0x7fff928d8000 -     0x7fff92a29fff  com.apple.audio.toolbox.AudioToolbox (1.8 - 1.8) <833DA682-A3C1-39E7-AEC3-9EDC734DE2A9> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

    0x7fff93868000 -     0x7fff93868fff  com.apple.Carbon (154 - 155) <1B2846B1-384E-3D1C-8999-201215723349> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

    0x7fff93947000 -     0x7fff93b30fff  com.apple.CoreFoundation (6.8 - 744.12) <EF002794-DAEF-31C6-866C-E3E3AC387A9F> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x7fff965db000 -     0x7fff965dbffd  com.apple.audio.units.AudioUnit (1.8 - 1.8) <29E2C990-3617-3FA2-BDD7-DB7DF493E443> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

    0x7fff97a6b000 -     0x7fff97a71fff  com.apple.DiskArbitration (2.5.1 - 2.5.1) <F7DAF7CC-5893-3F06-9168-3B0192B66D15> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

    0x7fff989e6000 -     0x7fff98a43fff  com.apple.audio.CoreAudio (4.1.0 - 4.1.0) <B3198BD6-EA1D-3E5E-ADD4-37D8E6B72678> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

    0x7fff990a7000 -     0x7fff9936aff7  com.apple.AddressBook.framework (7.1 - 1167) <92EF9CE4-A42B-3D30-8CA2-79C0A66BB4CE> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

 

 

Model: MacBookPro8,1, BootROM MBP81.0047.B27, 2 processors, Intel Core i5, 2.4 GHz, 4 GB, SMC 1.68f99

Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 384 MB

Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80AD, 0x484D54333235533642465238432D48392020

Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80AD, 0x484D54333235533642465238432D48392020

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (5.106.98.81.22)

Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports

Network Service: Wi-Fi, AirPort, en1

Serial ATA Device: ST9500325ASG, 500.11 GB

Serial ATA Device: OPTIARC DVD RW AD-5970H

USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfd100000 / 2

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 3

USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfa100000 / 2

USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0253, 0xfa120000 / 5

USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 6

 

I am running Mountain Lion and Logic on 64 bit if that helps. Please bear in mind i'm new to Mac so sorry if i am being stupid

 

thanks in advanced


Logic Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: Logic pro 9 will not open
    The Art Of Sound Level 5 Level 5 (6,530 points)

    Did you recently upgrade to Mountain Lion from Leopard or Snow Leopard?

     

    I ask because the issue appears to be that you have an old or corrupted Prokit...

     

    You could try installing a recent one from here but I suspect you will get a "newer one is already installed' error.. but it's worth a try...

     

    Here is the link to Prokit 7....

     

    http://support.apple.com/kb/DL1385

     

    Install (if you can) and then restart your Mac.... (Important to do this)

     

    Then try running Logic again...

  • 2. Re: Logic pro 9 will not open
    Abbzman Level 1 Level 1 (0 points)

    Hey thanks for reply, yes you are right i have just upgraded.

     

    I did try to re instal pro kit however last time it said i have the newer one etc...

     

    What is strange is that on my app store it says i have to download mountain lion again, do you think this could be if?

     

    If not are there any suggestions on what to do next?

     

    Thanks

  • 3. Re: Logic pro 9 will not open
    The Art Of Sound Level 5 Level 5 (6,530 points)

    It's normal to see Mountain Lion in your App Store list, ready to install... so I wouldn't worry about that...

     

    However, it does seem something went awry with your Prokit...

     

    What was your previous OS X version before you upgradedd to Mountain Lion?

  • 4. Re: Logic pro 9 will not open
    Abbzman Level 1 Level 1 (0 points)

    I was using snow leapord before this. To be honest i just wanted the imessage app and am now regretting it.

     

    Furthermore i tried to instal logic studio 8 on this mac before downloading pro 9.. i did not realise mountain lion did not support 8. not sure if that helps.

  • 5. Re: Logic pro 9 will not open
    The Art Of Sound Level 5 Level 5 (6,530 points)

    It does help as it might explain what has gone wrong with your upgrade...

     

    Unfortunately there is no easy solution for this problem.. I have seen it several times in the past with my clients...  and in reality, the only real fix is to start from scratch with Mountain Lion as i describe in this thread....

     

    https://discussions.apple.com/message/21094000#21094000

     

    Sorry.. I know it is a huge pain in the butt.... but apart from going back to Snow Leopard and using Logic Pro 9.1.8 with that (Which you can do if you made full backups before you upgraded) this method is really your only solution I'm afraid to say.... as it seems your upgrade 'screwed the pooch' so to speak....

  • 6. Re: Logic pro 9 will not open
    Abbzman Level 1 Level 1 (0 points)

    Whilst posting my original question i was in the process of re downloading mountain lion, considering i downloaded it I continued the re installation and it has worked! I'm very shocked..

     

    Thank you so much for your help, i will no doubt have 1000 more questions in the future.

  • 7. Re: Logic pro 9 will not open
    The Art Of Sound Level 5 Level 5 (6,530 points)

    Well, that's excellent news indeed! Glad you got it fixed and relatively simply too!

     

    Thanks for letting us know....

     

    ...and you are most welcome!