Skip navigation

MBP Retina bad display on external Dell display

11873 Views 45 Replies Latest reply: Mar 14, 2014 9:07 PM by prumps RSS
  • Constans337 Calculating status...

    I just tried it for my HP ZR24w and it didn't help.  Like tradingrumble, my rMBP is properly detecting and displaying the monitor's native resolution and, while I tinkered with it, I can't see any settings in SwitchResX that will help with the font problem.

  • @mgl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2013 11:25 AM (in response to GreenAsJade)

    Same here with Asus vh242h 1080p Display connected to a MBP Retina 13'' via HDMI.

  • LordLeo Calculating status...

    I bought an rMBP 13" 2.5GHz i5 w/8GB RAM.  I have been won over to the mac environment gradually the last few years with first on iPod Touch, then iPhone 4, another iPhone 4, and 3 iPads.  I have always had a difficult time changing fully to mac due to the software I need to use for work, etc. BUT with the ability to run Parallels I took the plunge.  So far I am thrilled with the actual MBP, BUT customer services has been less than desired regarding issues like the one noted here.  I have an HP 2311x monitor that is excellent when I use it with my windows laptop, but connected to the rMBP it is horrible for text.  I can stream Netflix fine enough, but I really need this for text for the huge spreadsheets I use for my job.  This is a huge problem.  I called support and got the "it is an HP issue" response.  HP does not provide drivers for Mac.  What?  from this forum and MANY others on the web I can see this is a HUGE issue for many people that has been on going for a long time.  I have always avaoided the Apple brand due to the significant $ paid over equivalent equipment in the windows world, but the thought was that customer service was excellent and you really get what you pay for.  Well, this is NOT what I paid for.  I am seriously considering reversing direction and returning the rMBP.  APPLE!!!!!  Please address this external monitor issue.

  • heycoach Level 1 Level 1 (0 points)

    I had the same problem, I've posted the solution in the thread below. It has worked for me and for others.

    http://discussions.apple.com/message/21415276#21415276

  • The King of Limbs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2013 3:10 PM (in response to heycoach)

    Please send your solution to Apple. Maybe they can find a way to make this work for all external monitors and then slipstream it into the next update!

     

    If they get this fixed, I may consider giving them another try. But not until the fix is proven and official. Until then, it's just too risky. Thx!

  • heycoach Level 1 Level 1 (0 points)

    Sure, if you can point me in the right direction I'll be happy to send them the info. I would presume they already know about it (and that it's not a priority), but it wouldn't hurt.

     

    I can almost guarantee that their solution would be the same. If you browse to the /System/Library/Displays/Overrides folder you might see that there are numerous EDID override files already in there to cater for different monitors.

     

    But as I said before, I completely understand your reluctance. It's something that you shouldn't have to do, and so the fix ought to be demanded of Apple.

  • The King of Limbs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 4, 2013 4:47 PM (in response to heycoach)

    Thanks. I wish I knew how to contact the people "in the know" at Apple. Before I returned my new MBP, I wasted two weeks trying to find them. I got really tired of hearing all the excuses along the way.

     

    Maybe Apple will fix this eventually. Not just for the HP displays I use at work, but for all the other displays I have need to use when I am on the road. I would hate to have to execute the script and go through the steps every time I connect to an external display.

     

    Thanks for the link to the patch. I just wish Apple would fix its defective OS.

  • odelfo Calculating status...

    Hello all -

     

    I just bought Macbook 15'' retina and connected it to my HP LP2475W monitor through HDMI; result is horrible (text difficult to read at native resolution 1920x1200).

    I use extended desktop, I have tried applying the EDID patch but did not help - Any other idea ?

     

    I had no problem connecting the monitor to my previous PacBook Pro (mid 2010) through DP/DVI adaptor. Odd that upgrading my Mac creates some problems ...

     

    Any idea welcome

     

    Thanks

     

    Olivier

  • odelfo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2013 7:27 AM (in response to odelfo)

    A follow up -

     

    I have eventually discovered that my old Dipslay Port --> DVI adapter was fitting into thunderbolt port on the new MBP and guess what : crystal clear display on the external monitor through DVI input. Seems that problem is linked to HDMI

     

    I hope this will help others (the adapter is the basic Apple Mini Display Port to DVI)

     

    Thanks

     

    Olivier

  • Constans337 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2013 3:06 PM (in response to Constans337)

    I've found a solution to this.  I tried all the suggestions above and elsewhere and none worked.  By accident I selected "best for macbook" rather than "best for external monitor" on the settings screen one day and I got much sharper fonts.  Not sure if this is tied to the OS update a couple of months back, or it was always a viable solution.  Any way, worth a try if you haven't already.

  • Steven.Jiang Calculating status...
    Currently Being Moderated
    Nov 12, 2013 4:05 PM (in response to GreenAsJade)

    I'm using DELL U2913WM, same problem.

     

    Finally I found the solution.

     

    DellMonitorMenu

    --DisplaySetting

    ----Sharpness

    -------Set it to 0. (It was 50 by default)

     

     

    This finally solved it.

     

    Message was edited by: Steven.Jiang

  • NormySan Calculating status...
    Currently Being Moderated
    Dec 20, 2013 2:31 AM (in response to Steven.Jiang)

    This solved my problems! Thanks

     

    Edit: Nope, problem still not fully solved. It's a heck of a lit better when turning down the sharpness but the image and color quality is still really bad compared to when i've got the monitor running on my stationary windows 7 pc.

  • NormySan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 20, 2013 2:59 AM (in response to NormySan)

    Could not edit my previous post. I found this solution that works great for my DELL U2413 monitor. Seems like OSX Maverics thiks that the monitor is a TV and sends out the wrong type of signal so you have to force it to use RGB instead with an override.

     

    Link to the solution:

    http://embdev.net/topic/284710

  • jdmccalpin Calculating status...
    Currently Being Moderated
    Jan 30, 2014 1:22 PM (in response to GreenAsJade)

    When I had exactly the same problem (fuzzy HDMI display even with correct resolution), the problem was that the MacBook Pro was assuming that the monitor was a television, so it was using the  "underscan" feature to map the 1920x1080 display into a smaller number of pixels on the actual display.  

     

    Apparently some/many televisions are set up so that the outermost couple of rows and columns are not visible, so the MacBook Pro "shrinks" the display by default to avoid losing this stuff around the edges.   Unfortunately mapping a 1920x1080 display to (for example) the innermost 1840x1000 pixels results in terribly blurry text.

     

    So look in the Display Preferences dialog for an "underscan" slider and adjust it to "off".     This should only apply to HDMI displays.    Most recent televisions based on LCD or Plasma technology don't "overscan" significantly anyway, so there is seldom a need to "underscan" as a correction.

     

    For a few more words, see http://www.themacfaq.com/2010/11/11/understand-overscan-and-underscan/

  • Urs77 Calculating status...
    Currently Being Moderated
    Mar 2, 2014 9:32 AM (in response to NormySan)

    Yes, it worked for me as well. But I am really frustrated with Apple. This problem has been around for more than a year and they were not able (or did not want to???) fix it. VERY POOR CUSTOMER SERVICE!!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.