Skip navigation
This discussion is archived

"Browse Other Time Machine Disks" not working properly

1964 Views 26 Replies Latest reply: Apr 10, 2013 8:51 AM by Pondini RSS
  • Pondini Level 8 Level 8 (38,710 points)

    Zarquon42 wrote:

    . . .

    In fact I was hoping to be able to remove older backups from my Time Capsule in order to free up some space. But without the "Browse Other Time Machine Disks" function working, this is impossible.

    Uh, that's an entirely different thing from what you were asking earlier. 


    Please clarify -- it sounds like you already started making backups of the new Mac, and Time Machine made a separate sparse bundle for it.


    If so, and you want to delete backups from the old sparse bundle, you can do that via the Browse option, although it will take quite a while to delete a lot of them.  See Time Machine - Frequently Asked Question #12.  Then you'll have to manually "compact" it when done, to recover the space, per the pink box there.



    Or, If you want to copy part or most of an entire backup to an external drive, follow LaPastenague's instructions (note: that will not result in a bootable system). 

  • LaPastenague Level 7 Level 7 (32,590 points)


    Or, If you want to copy part or most of an entire backup to an external drive, follow LaPastenague's instructions (note: that will not result in a bootable system). 

    LOL.. more correctly,  you could say your original instructions as copy and pasted ..


    which I found worked really well.

  • Pondini Level 8 Level 8 (38,710 points)


    Perhaps between us, we can help him do what he wants.


    He'd emailed me for help via the link on my website; you'd posted back and forth a couple of times while I was composing and had a distraction, so we've been sort of talking across each other. 

  • Pondini Level 8 Level 8 (38,710 points)

    Zarquon42 wrote:


    After (Why did "Backup of Jane" mount?

    What does the Choose Time Machine Disk to Browse window look like?





    And why am I looking at the top level of my computer rather than inside the backup of Herbie?):

    As mentioned before, the initial display is always the Today (Now) window showing the current contents of the Mac you're on. 


    That may be a bit misleading, but isn't a problem as long as you don't select anything on the Finder window, but do select a backup in the TimeLine on the right.


    Inside "Backup of Herbie":

    You're missing a step.  You selected "Backup of Herbie" on the Today (Now) window.


    Don't select anything there -- instead, select the desired backup in the timeline on the right.

  • Pondini Level 8 Level 8 (38,710 points)

    Zarquon42 wrote:

    . . .

    Now to see if I can follow Pondini's instructions and delete older backups to make room for backups of my new MBP on the TC. I want to be clear: I go to the oldest backup and choose "Delete Backup" from the Gear menu, right?

    Yes;  select the desired backup, then either right-click or click the "gear" icon and select the Delete Backup option.  Then you'll get a confirmation prompt, then one to enter your Admin password.  The actual deletion may take anywhere from a few seconds to several minutues, so connect via Ethernet cable if at all possible.


    You usually won't gain much space from a single deletion, as only the items that are only on that particular backup really get deleted.

  • jessnutt Calculating status...

    Hi Pondini,

    I'm having the same issue. I'm attempting to get files out of a backup for an old (and now broken) computer with my new mac laptop (OS X 10.8.3). When I select "Browse Other Time Machine Disks" and choose the old computer's disk, time machine opens, with a finder window from my current mac. You say that next, we should select a backup in the timeline on the right (without touching anything in the finder window displayed) - however, although the backups are all listed, they're un-clickable. (They're pink, which if I recall, just indicates that they're stored on the external drive; there are some recent backups in white that I can click, but they are just the backups from my current laptop.)


    What am I missing?

  • Pondini Level 8 Level 8 (38,710 points)

    It sounds like there's a mismatch between user accounts on the Mac you're using vs. the backups.


    Once in the TM browser (the "Star Wars" display), try pressing Shift+Cmd+C.   Then select the backup you want.


    See the green box in #E3 of Time Machine - Troubleshooting.  That should allow you to see at least the home folder(s) you're interested in, but you may not have permission to see the contents.  If so, post back and we'll work around that.

  • jessnutt Level 1 Level 1 (0 points)

    Hi Pondini - thanks for the prompt response!


    Shift+Cmd+C did great - pulled up a finder window of my old computer when I selected a backup.


    You were right though; I did run into permissions issues. Although, the strange thing is, the particular folder I was hoping to dig into (Documents) was denied; when I came back to this a couple days later however, all the folders in the user I'm exploring were still locked except the Documents folder. So I was in the end able to get to the file I wanted, but I'll ask anyway for future backup spelunking: any ideas on an actual way to work around the permissions block?



  • Pondini Level 8 Level 8 (38,710 points)

    jessnutt wrote:

    . . .

    but I'll ask anyway for future backup spelunking:

      About a hundred years ago, I did some actual spelunking.




    any ideas on an actual way to work around the permissions block?


    That depends on the situation.  If the user account you're logged on with isn't recognized as the same one as on the backups, it won't have access to much of anything in the home folder, and you'll need to use a different user account.  That often happens after using Migration Assistant, but could be the problem in your case, too -- see the blue box in Problems after using Migration Assistant for an explanation.


    In other cases, especially with a user account that's been upgraded through a few releases of OSX, there may be problems with the permissions on a folder or package, or its contents.  In those cases, one of the workarounds in #E10 of Time Machine - Troubleshooting will usually work.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.