Skip navigation

macbook wifi won't connect to internet

1407 Views 6 Replies Latest reply: Feb 1, 2013 3:43 PM by Calvinator RSS
Calvinator Calculating status...
Currently Being Moderated
Feb 1, 2013 2:24 PM

Cannot connect MBP to the 'net using wifi or ethernet. My iMac (on the same network) has no problem doing so (wifi).

"Network Preferences" shows green for ethernet connection. "Wi-Fi has the self-assigned IP address 169.254.22.253 and will not be able to connect to the internet"

[The Airport icon changes from connected and (! ) not connected. It doesn't seem to be limited to a wifi problem because an ethernet connection has the same inability to connect.]

Clues: Restarting computer, cable and wifi modems doesn't help. I have renewed DHCP lease without change to the problem (no Client ID required). There is no "Router Address" below the subnet mask (255.255.0.0) on the TCP/IP page. Configure IPv6: Automatically.

Creating a new network doesn't help.

IMPORTANT: My (Cisco) router shows a yellow light at the ethernet connection with the MBP but is otherwise operational with other devices.

This leads me to believe I have a hardware issue on MBP... very much appreciate your input; thanks.

OS X Mountain Lion (10.8.2)
  • rearviewmirror Calculating status...
    Currently Being Moderated
    Feb 1, 2013 2:30 PM (in response to Calvinator)

    Even if the SSID is being broadcast try adding it manually with the correct encryption type.  This is especially critical if you're using WPA Enterprise (w/ external RADIUS Auth).  Even for PSK adding the SSID (wireless profile) manually and selecting the encryption type usually does the trick.  If you're wireless network is Cisco gear as well then it should be quite easy to debug your client's mac address to see where it's falling down.

  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    Feb 1, 2013 3:04 PM (in response to Calvinator)

    Your time and date are likely not correct in System Preferences, so check that first that it's updated via Apple's time servers for your location.

     

    I think you also need to head to System Preferences > Network and create a New Location (Unlock, then Edit Locations), then delete the old one, head to Airport > Avdanced > Ariport and delete all the wireless connections. Because fooing around you likely messed other things up.

     

    Check this link out for more fixes.

     

    ..WiFi, Internet problems, possible solutions

     

     

    Then simply start over new via the Airport connection in the top right corner and when it askes to save in KeyChain, do so.

     

    I don't like Cisco/Linksys routers, they spy on your web traffic via their Cloud Connect.

     

    http://tech.slashdot.org/story/12/06/29/1425210/cisco-pushing-cloud-connect-rout er-firmware-allows-web-history-tracking

     

    Going to sell their home router division to Belkin I read.

     

     

    For the best router IMHO, I advise the top end Netgear dual band, it's already plug and play with decent passwords provided, also you can increase the security and turn off PING.

     

    Apple's routers require setup and you can't turn off PING so you can be Ping flooded by bothnets or it announces itself to hackers online, and if you don't set a awesome password, your fish food. Apple needs to improve their router software IMHO.

     

    WiFi security issues, at home and WiFi hotspots

     

    http://howsecureismypassword.net/

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.