4 Replies Latest reply: Feb 1, 2013 5:30 PM by stedman1
fesgeshes11 Level 1 Level 1 (0 points)

I have a MacBook --

Mac OS X 10.5.8

 

The system is too old to support my current needs on BlackBoard...

Is there a possibility to upgrade the OS?

 

Thanks

Lise