Skip navigation

2011 MacBook Pro and Discrete Graphics Card

458593 Views 4,366 Replies Latest reply: Apr 17, 2014 4:40 PM by Mark Armstrong1 RSS Branched to a new discussion.
1 2 3 ... 292 Previous Next
abelliveau Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 1, 2013 4:45 PM

I have an early 2011 MacBook Pro (2.2 GHz Intel Core i7, 8 GB 1333 MHz DDR3 memory) running OS 10.8.2.  It has two graphics components: an AMD Radeon HD 6750M and a built-in Intel HD Graphics 3000. Since I've had the computer, the screen would get a blue tint when the computer switched between them.

 

However, as of two days ago, the problem has become substantially more severe.  The computer was working fine, when all of a suddent the screen when completely blue.  I had to force restart the computer.  Since then, the screen has gone awry on numerous occassions - each time necessitating a hard reset.

 

I installed gfxCardStatus, and have discovered that the computer runs fine using the integrated card, but as soon as I switch to the discrete card - the screen goes .

 

I am just wondering what my options are (any input on any of these would be appreciated!):

 

1) Replace the logic board.  Would this necessarily fix the issue?

 

2) Is there any way to "fix" the graphics card? 

 

3) Keep using gfxCardStatus and only use the integrated graphics card.  This is definitely the easiest/cheapest option, but to have such a computer and not be able to use the graphics card seems like a real shame.

 

4) Is there any other alternative?

 


MacBook Pro, OS X Mountain Lion (10.8.2), 2.2 GHz Intel Core i7, 8 GB memory
  • leroydouglas Level 6 Level 6 (13,300 points)
    Currently Being Moderated
    Feb 1, 2013 5:20 PM (in response to abelliveau)

    You can look at this thread https://discussions.apple.com/thread/4505106?start=0&tstart=0

     

    and then to the right side is a box that says "More Like This"

    MacBook Pro (15-inch Mid 2010), OS X Mountain Lion (10.8.2), 2.4GHz IntelCorei5 320GB HD 8GB RAM
  • Neshill Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 19, 2013 5:25 AM (in response to abelliveau)

    Hey!

     

    I ran into the exact same issue around the same time like you. I have a early 2011 MBP 15", and the same issue arose. First, my external monitor (and laptop monitor) screen shifted like in your first shot. It happened a couple of times, unplugging/plugging the external monitor would help solve it. I restarted the comp and it didn't happen.

     

    Tomorrow, though, the screen started exhibiting worse issues like you described. Lock ups, screen tearing, graphics glitches etc. I tried to localize the problem to be a software one, but failed. Althought Windows was stable, it also started showing glitches, and eventually they started appearing on the recovery partition as well.

     

    I sort of identified the issue to be with the discrete graphics, as switching to integrated didn't cause the problems.

     

    I brought it into the service center, where they noticed my laptop heats up substantially more than they would expect. They ran a couple of tests, many of which failed because my laptop locked up.

     

    They offered two procedures: one is to switch out the logic board, which is the usual path they would take, and the other one (cheaper) was to actually re-solder in the graphics chip. They said it was a bit detached and not soldered well to the board. Either as a result of falling damage (a slight fall happened, but a very long while ago and I never had issues after that - I slipped while the laptop was in my backpack) or heating over time, it got fuzzed up. I had them do the resoldering and the laptop worked fine for about 10 days, and now it's acting up again.

     

    I'll go for the logic board solution, but if you find any solutions, let me know. If you're interested, I can ping in with the results of the procedure.

  • thierryfrommulhouse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 19, 2013 6:32 AM (in response to abelliveau)

    Hi.

     

    Same problem here with a MacBook Pro early 2011.

    First symptom like abelliveau's image : http://imageshack.us/a/img26/9898/screenshot20130201at758.png

     

    Sometimes when i boot, the Apple logo is red/pink with stripes, and after that a grey screen or a blue screen with vertical stripes.

     

    I'm sure all this problems come with the last MacBook Pro SMC Firmware Update 1.7 http://support.apple.com/kb/DL1633

  • Neshill Level 1 Level 1 (10 points)

    I just installed that update today (after the issue started happening) hoping it may fix something, but it didn't.

     

    After I installed it was the first time I had the blue screen with vertical stripes, though, to be fair.

     

    So I don't think the update is the cause of the problem, but it might modify certain parameters of it.

  • Neshill Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 19, 2013 10:29 AM (in response to abelliveau)

    Bah. Well I'm not covered by Applecare either, and I'm also on a tight budget, so tough luck for us.

  • Neshill Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 20, 2013 3:42 AM (in response to abelliveau)

    I was quoted around $530 for board and replacement work.

  • clintonfrombirmingham Level 7 Level 7 (26,675 points)
    Currently Being Moderated
    Feb 20, 2013 3:51 AM (in response to Neshill)

    I had the same problem with my late 2011 15" - blue tint when discrete card was in use. Then, after about two weeks, it just went away. Don't recall if there was an OS update or not, but the problem didn't last long - you may just have to wait this one out.

     

    Clinton

  • Neshill Level 1 Level 1 (10 points)

    As OP and I noted, the blue tint (I don't have that problem btw) is not the issue. The system breaking lock-ups and screen distortions are.

1 2 3 ... 292 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (193)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.