Skip navigation

Can NOT drag and drop to combine Events

373 Views 6 Replies Latest reply: Feb 2, 2013 12:32 AM by Terence Devlin RSS
tzargregory Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 30, 2013 11:42 AM

I've combined Events zillions of times in iPhoto and drag-'n-drop in Aperture 3 also. Today, when I tried to drag one Event into another, it didn't work. It didn't 'release' into the new event when I let go of the mouse button. I restarted iPhoto - same problem. Rebooted my MBP, same problem.


Tried to drag and drop a new photo into my Photostream (from Aperture this time) and the same problem. I click to drag, move the event, and then it appears 'ghosted' and will not release.


I even went into my Sys Prefs to see if it was my mouse, but that looked OK, and I could not replicate this problems in other applications.


I'd love to know why it does this (did I inadvertently check something somewhere) but more importantly, how do I fix this?


Oh yes - I got an error message the first few time about repairing iPhoto, which I let it do - took about 10 minutes, and I've never seen that before in iPhoto. (Aperture, yes, a LOT...)


Oh yes - I can 'Merge Events' from the Menu - that works, but seems cumbersome and the drag-and-drop has worked fine until today...


I am stumpped...





  • Terence Devlin Level 10 Level 10 (121,630 points)
    Currently Being Moderated
    Jan 30, 2013 12:03 PM (in response to tzargregory)

    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • Terence Devlin Level 10 Level 10 (121,630 points)
    Currently Being Moderated
    Jan 30, 2013 2:21 PM (in response to tzargregory)

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.


    If that fails:


    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)



    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.



    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 




  • Terence Devlin Level 10 Level 10 (121,630 points)
    Currently Being Moderated
    Feb 2, 2013 12:32 AM (in response to tzargregory)

    Try the 'Using Mac OS X forum' for whatever version of the OS you have.


    Or try a new mouse...


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.