1 2 3 4 5 6 Previous Next 75 Replies Latest reply: Mar 8, 2013 9:33 AM by Shareef Yousef Go to original post
  • 60. Re: restart disables javaws again
    yabbanoname Level 1 Level 1 (0 points)

    your java  version is probably different on your macs, use the proper version string on every mac.

  • 61. Re: restart disables javaws again
    William Lloyd Level 6 Level 6 (19,350 points)

    An updated version of Java 1.7 is now available which will run on Mountain Lion:

     

    http://www.oracle.com/technetwork/topics/security/javacpufeb2013-1841061.html

  • 62. Re: restart disables javaws again
    Robert Jones30 Level 1 Level 1 (95 points)

    It may run on Mountain Lion but it won't be compatible with the Java application I need it to run with.

  • 63. Re: restart disables javaws again
    Robert Jones30 Level 1 Level 1 (95 points)

    You were correct. I had to tweak the JavaComponentMinimumVersion on each machine. I found the right version to use my entering "java -version" in Terminal and looking at the Runtime Environment variable.

  • 64. Re: restart disables javaws again
    William Lloyd Level 6 Level 6 (19,350 points)

    That Java application needs to be updated soon as Java 1.6 is disappearing very soon:

     

    http://www.java.com/en/download/faq/java_6.xml

  • 65. Re: restart disables javaws again
    trashgod Level 1 Level 1 (0 points)

    alucasTHX wrote:

     

    Um.  Isn't that what I already said?

     

    Yes, I overlooked your more thorough exmaination here: https://discussions.apple.com/message/21097725#21097725

  • 66. Re: restart disables javaws again
    JimmyChicago Level 1 Level 1 (0 points)

    "Admittedly, Apple should be a bit more open about what's going on here. However, it's extremely short-sighted to criticize them for trying to keep you safe from threats that you are unaware of. If you don't like security, switch to Windows, where you can keep using Java just fine... assuming the viruses don't cripple your machine, steal your identity and destroy all your important data."

     

    Great thinking! Of course your criticisms of the Windows platform are only accurate if you're still beating up on Windows 98, but hey, I like to drive old muscle cars. 

     

    As a network engineer, we call this approach to security/problem solving the Nirvana approach (from their Unplugged album).  Its where you don't consult or do any troubleshooting, you just yank out all the wires from the switch and then deal with the calls regarding loss of internet, everything else was the problem and/or those people that don't notice didn't need the interwebs anyway. 

     

    Ever wonder why the business community stays away from crApple? Security through obscurity and the heavy handed approach are just two reasons.

  • 67. Re: restart disables javaws again
    Sergani Level 1 Level 1 (0 points)

    Thank you very MUCH!!! Now I'm alive once again!!!!    

  • 68. Re: restart disables javaws again
    Shareef Yousef Level 1 Level 1 (5 points)

    Not sure what happened, but I'm now getting the Blocked Plug-in again in Safari. I ran the command:

     

    sudo /usr/libexec/PlistBuddy -c "Delete :JavaWebComponentVersionMinimum" /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist

     

    But still getting it. So very frustrating. I can't believe Apple is that ignorant to the corporate world where the legacy java apps just won't work with the newest version.

  • 69. Re: restart disables javaws again
    thomas_r. Level 7 Level 7 (27,930 points)

    Not sure what happened, but I'm now getting the Blocked Plug-in again in Safari

     

    Yup, they bumped up the blocked version of Java again, following new vulnerabilities that were being actively exploited and a subsequent Java update.

     

    I can't believe Apple is that ignorant to the corporate world where the legacy java apps just won't work with the newest version.

     

    It's the corporate world that is ignorant, in this case. Just using Java in a web browser at all is dangerous, but anyone using legacy versions of Java in a web browser is nuts! If your employer is making you use legacy versions of Java on web sites, you need to do that only on a cheap throwaway netbook, with absolutely no sensitive data on it and that gets used for nothing else, or in a virtual machine running in something like Parallels.

  • 70. Re: restart disables javaws again
    Shareef Yousef Level 1 Level 1 (5 points)

    I'm not accessing external java sites. For this particular instance, I'm trying to run Cisco UCS manager. Again, I get the risks, but I don't need Apple force feeding updates down my throat. It's my computer, and I should be able to dictate the versions of software I want to run on it. It's inexcusable that Apple makes these changes mandatory. They absolutely should have an opt out or at the very least, back out option.

  • 71. Re: restart disables javaws again
    Shareef Yousef Level 1 Level 1 (5 points)

    Well, I've reverted to using this command and was able to get it working successfully.

     

    sudo defaults write /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta JavaWebComponentVersionMinimum "1.6.0_37-b06-434"

  • 72. Re: restart disables javaws again
    William Lloyd Level 6 Level 6 (19,350 points)

    There *is* an opt out.  Software Update preference pane, uncheck "Install system data files and security updates."

  • 73. Re: restart disables javaws again
    Shareef Yousef Level 1 Level 1 (5 points)

    Thank you so much. Never noticed that. Went ahead an unchecked it and hope to avoid these java issues in the future.

  • 74. Re: restart disables javaws again
    yabbanoname Level 1 Level 1 (0 points)

    Updates are still possible, but you need to fix some "things":

    My Xprotect:

     

            <key>JavaWebComponentVersionMinimum</key>

            <string>1.6.0_41-b02-446</string>

     

    sudo ln -fs /System/Library/Java/Support/Deploy.bundle/Contents/Home/bin/javaws /usr/bin/javaws

     

    $ sudo mkdir -p /Library/Internet\ Plug-Ins/disabled

    $ sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled

     

    And enable java webstart in the Java Preferences panel (must be restored from Time Machine backup to /Applications/Utilities)

     

    And it works again (without the need of keeping the older java6 software).