14 Replies Latest reply: Feb 2, 2013 4:38 AM by ds store
aroundme74 Level 1 Level 1 (0 points)

Greetings to everyone

 

I suddenly have had problems with Java plug-in  connecting to a  web site for playing chess.

There is a message in the middle of the page when I try to log in: "plug-in not working".

Click on this message the software update starts to check for new release.

Obviously my mac is perfectly updated and Java is installed.

I was able to log in till yesterday.

What can I do to fix the issue?

 

Thank you


Mac Pro, Mac OS X (10.6.8)
  • 1. Re: Java plug-in no longer works!
    Klaus1 Level 8 Level 8 (44,485 points)

    UPDATE:

    Oracle on Friday February 1 released a new version reportedly addressing vulnerabilities seen with the last build.

    Apple disabled Java 7 through the OS X XProtect anti-malware system, requiring users to have at least version "1.7.0_10-b19" installed on their Macs. The release dated February 1 carries the designation "1.7.0_13-b20," meeting Apple's requirements.

     

    Oracle "strongly recommends" applying the CPU fixes as soon as possible, saying that the latest Critical Patch Update contains 50 new security fixes across all Jave SE products.

  • 2. Re: Java plug-in no longer works!
    aroundme74 Level 1 Level 1 (0 points)

    Mac os X version 10.6.8...what can I do?

  • 3. Re: Java plug-in no longer works!
    aroundme74 Level 1 Level 1 (0 points)

    Klaus in a few words, what shall I do? Shall I download files form Oracle site?

  • 4. Re: Java plug-in no longer works!
    Durandal1717 Level 1 Level 1 (0 points)

    I too am running 10.6.8 and can not install this latest update without Lion, which is something I can not afford simply to get java working..... Is there any fix for those of us below 10.7.3?

  • 5. Re: Java plug-in no longer works!
    Lanny Level 5 Level 5 (4,485 points)

    Run Software Update.

  • 6. Re: Java plug-in no longer works!
    Durandal1717 Level 1 Level 1 (0 points)

    Yeah, I tried that and nothing....I'm up to date on everything. Is there ANY workaround for those not fortunate enough to have Lion installed?

  • 7. Re: Java plug-in no longer works!
    Michael Wineke Level 1 Level 1 (5 points)

    Bear in mind that overriding the block leaves your machine and the data therein exposed to attack without your knowledge or consent.

     

    Got any sensitive info on there? I'm sure your contacts won't mind having various spam, fishing attempts, phone calls, etc. directed at them.

     

    Anyhoo, who needs money?

     

    Having said that:

    https://discussions.apple.com/message/21109819#21109819

  • 8. Re: Java plug-in no longer works!
    Durandal1717 Level 1 Level 1 (0 points)

    Indeed who needs money, and I require java to work in order to continue receiving a paycheck.....when Apple decides to finally release a patch for Snow Leopard I'll gladly update but until then I'll take the lesser of two evils....

  • 9. Re: Java plug-in no longer works!
    Michael Wineke Level 1 Level 1 (5 points)

    But in fact, Java does still work. The Java Plugin does not.

     

    If you feel the risks to your business are acceptable to you (and your contacts) then by all means, override the lockout.

     

    Perhaps you need to raise your rates.

  • 10. Re: Java plug-in no longer works!
    ds store Level 7 Level 7 (30,305 points)

    Java 7 updated  for 10.7-10.8

     

    Released Feb 1, 2013,  fixes 50+ security flaws
     
    http://www.esecurityplanet.com/patches/oracle-responds-to-java-security-flaws-wi th-50-fixes.html

     

    Download and install

     
    https://www.java.com/en/download/faq/java_mac.xml
     

     

    For Java versions 6 and below OS X 10.5-10.6 machines


    Apple supplies their own version of Java. For Mac OS X 10.6 and below, use the Software Update feature available under the Apple menu to check that you have the most up-to-date version of Java 6 for your Mac.
     
    https://www.java.com/en/download/faq/java_6.xml
      


    Java SE 6 End of Public Updates
     
    After February 2013, Oracle will no longer post updates of Java SE 6 to its public download sites. We highly recommend downloading and installing Java 7.

     

     

    If your considering upgrading OS X from 10.6.8 to 10.8 via AppStore to run Java 7

     

    Be forewarned no PowerPC based programs or driver software will run any longer.

     

    Check here BEFORE you upgrade OS X!

     

    http://roaringapps.com/apps:table

     

     

    Alternatives if you must run Java 7

     

    If Apple disabled Java 6 in 10.6, and you can't upgrade OS X to 10.8, then your pretty much done with Java in OS X because Oracle won't issue updates for Java 6 anymore.
     
    However you can install Windows 7 and continue to use Java 7+ there until support for Windows 7 ends in 2020.


    Windows in BootCamp or Virtual Machine?

     

    If your on 10.6, I very highly recommend the free Virtualbox for the virtual machine software as it gets updates, VMFusion and Parallels have moved on with only 10.7+

  • 11. Re: Java plug-in no longer works!
    MadMacs0 Level 4 Level 4 (3,725 points)

    Check Software Update...

    APPLE-SA-2013-02-01-1 Java for Mac OS X v10.6 Update 12

     

    Java for Mac OS X v10.6 Update 12 is now available and addresses the

    following:

     

    Java

    Available for:  Mac OS X v10.6.8, Mac OS X Server v10.6.8

    Impact:  Multiple vulnerabilities in Java 1.6.0_37

    Description:  Multiple vulnerabilities exist in Java 1.6.0_37, the most serious of which may allow an untrusted Java applet to execute arbitrary code outside the Java sandbox. Visiting a web page containing a maliciously crafted untrusted Java applet may lead to arbitrary code execution with the privileges of the current user.

    These issues are addressed by updating to Java version 1.6.0_39.

    Further information is available via the Java website at http://www.oracle.com/technetwork/java/javase/releasenotes-136954.html

  • 12. Re: Java plug-in no longer works!
    aroundme74 Level 1 Level 1 (0 points)

    Please could someone tell me which is the solution? I have read all the artciles all the cooments but I need solutions. Software update is empty. 

    Thank you

  • 13. Re: Java plug-in no longer works!
    aroundme74 Level 1 Level 1 (0 points)

    I got the update!!

  • 14. Re: Java plug-in no longer works!
    ds store Level 7 Level 7 (30,305 points)

    Java for Mac OS X 10.6 Update 12 delivers improved security, reliability, and compatibility by updating Java SE 6 to 1.6.0_39. (released Febuary 2, 2013)

     

    On systems that have not already installed Java for Mac OS X 10.6 update 9 or later, this update will configure web browsers to not automatically run Java applets. Java applets may be re-enabled by clicking the region labeled "Inactive plug-in" on a web page. If no applets have been run for an extended period of time, the Java web plug-in will deactivate.

     

    Please quit any web browsers and Java applications before installing this update.

     

    See http://support.apple.com/kb/HT5575 for more details about this update.

     

    See http://support.apple.com/kb/HT1222 for information about the security content of this update.

     

    Java 6 users on 10.6.8, Oracle has moved on with Java 7 on OS X 10.7-10.8, thus will be ending support for Java 6 in Febuary 2013.

     

    Apple is providing a method that disables Java web browser applets from running if they are not being used, it's not a replacement for a secure Java.

     

    Websites that use Java 6 will move on to Java 7 and thus those on OS X 10.6.8 will be left behind from running Java any further unless they upgrade OS X to 10.8.

     

    Upgrading to OS X 10.8 will incur some penatly, as older PowerPC based software running in Rosetta will no longer function.

     

    http://roaringapps.com/apps:table

     

    Also OS x 10.8 has a minimal RAM requirement of 2GB, which 4GB is highly recommended.

     

    Some Intel Mac's cannot be upgraded to OS X 10.8 for other reasons, check your compatability for 10.8

     

    If one cannot upgrade 10.6.8 to 10.8 (or doesn't want to), and one requires to run Java 7 on websites, then purchasing Windows 7 and installing it into Apple's BootCamp or the free VirtualBox virtual machine software and 4GB of RAM is recommended.

     

    Windows in BootCamp or Virtual Machine?