6 Replies Latest reply: Feb 2, 2013 11:23 AM by Terence Devlin
CarlJos Level 1 Level 1 (0 points)

Hi,

 

Using iPhoto 9.4.2 on Mac OS X 10.7.5. Recently whenever I try to synch an albumn with Facebook it crashes. I've tried creating a new library and still get the same problem. Below is part of the crash report. Appears to be a problem with the app itself, yet the thread it crashes on seems to always have something to do with "URLRequest".

 

Any thoughts?

 

CRASH REPORT

Process:         iPhoto [9852]

Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

Identifier:      com.apple.iPhoto

Version:         9.4.2 (9.4.2)

Build Info:      iPhotoProject-710042000000000~2

App Item ID:     408981381

App External ID: 11723545

Code Type:       X86 (Native)

Parent Process:  launchd [119]

 

 

Date/Time:       2013-01-31 16:17:41.211 +0100

OS Version:      Mac OS X 10.7.5 (11G63b)

Report Version:  9

 

 

Interval Since Last Report:          22032 sec

Crashes Since Last Report:           9

Per-App Interval Since Last Report:  5830 sec

Per-App Crashes Since Last Report:   9

Anonymous UUID:                      41DA757A-8FFE-4554-B082-2EA05FF44F43

 

 

Crashed Thread:  18

 

 

Exception Type:  EXC_BAD_ACCESS (SIGBUS)

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000010

 

 

VM Regions Near 0x10:

--> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/iPhoto.app/Contents/MacOS/iPhoto

    VM_ALLOCATE            0000000000001000-0000000000087000 [  536K] ---/--- SM=NUL 

 

 

Application Specific Information:

objc[9852]: garbage collection is OFF

 

 

THREAD 18

Thread 18 Crashed:

0   com.apple.CFNetwork                     0x9ca370e6 URLRequest::initialize(URLRequest const*, unsigned char) + 40

1   com.apple.CFNetwork                     0x9ca370a3 _ZL18_createRequestCopyPK13__CFAllocatorPK13_CFURLRequesth + 104

2   com.apple.CFNetwork                     0x9ca37036 CFURLRequestCreateMutableCopy + 24

3   com.apple.Foundation                    0x94711324 createCFRequest + 57

4   com.apple.Foundation                    0x94831911 +[NSURLConnection sendSynchronousRequest:returningResponse:error:] + 57

5   com.apple.iPhoto.FacebookPublisher          0x14a9f3ea 0x14a89000 + 91114

6   com.apple.iPhoto.FacebookPublisher          0x14a9d24d 0x14a89000 + 82509

7   com.apple.iPhoto.FacebookPublisher          0x14a8ccd5 0x14a89000 + 15573

8   com.apple.iPhoto.FacebookPublisher          0x14a8d138 0x14a89000 + 16696

9   com.apple.iPhoto.FacebookPublisher          0x14a94f6d 0x14a89000 + 49005

10  com.apple.iPhoto                        0x005bbc07 0x87000 + 5458951

11  com.apple.iPhoto                        0x00799fe2 0x87000 + 7417826

12  com.apple.CoreFoundation                0x9c66cfe1 +[NSObject performSelector:withObject:] + 65

13  com.apple.proxtcore                     0x0239f22c -[XTSubscription postMessage:] + 191

14  com.apple.proxtcore                     0x0239eaef -[XTDistributor distributeMessage:] + 681

15  com.apple.proxtcore                     0x0239e313 -[XTThread handleMessage:] + 515

16  com.apple.proxtcore                     0x0239cf10 -[XTThread run:] + 434

17  com.apple.Foundation                    0x94704e25 -[NSThread main] + 45

18  com.apple.Foundation                    0x94704dd5 __NSThread__main__ + 1582

19  libsystem_c.dylib                       0x989afed9 _pthread_start + 335

20  libsystem_c.dylib                       0x989b36de thread_start + 34


iPhoto '11, Mac OS X (10.7.5)
  • 1. Re: iPhoto crashing on every synch with Facebook
    Terence Devlin Level 10 Level 10 (123,855 points)

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

  • 2. Re: iPhoto crashing on every synch with Facebook
    CarlJos Level 1 Level 1 (0 points)

    Thanks Terence. I'll give that a try soon and report back.

  • 3. Re: iPhoto crashing on every synch with Facebook
    CarlJos Level 1 Level 1 (0 points)

    Ok so I tried a fresh reinstall of iPhoto and the problem continued (same error as above). Then I created a new profile as suggested and run a fresh copy of iPhoto and tried to synch some photos. Again, the same error occured.

     

    It's really odd, but it's the same thread that the error occurs on (the one about URLRequest). I'm using a MacBook Air so am wondering if there might perhaps be a problem with the flash drive. I know normal hard drives can have bad sectors but not sure if the same happens with a flash drive?

     

    Any other thoughts?

  • 4. Re: iPhoto crashing on every synch with Facebook
    Terence Devlin Level 10 Level 10 (123,855 points)

    How did you reinstall?

     

    To re-install iPhoto

     

    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

     

    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

     

    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type

     

    /var/db/receipts/

     

    2c: on 10.7 they're at

     

    /private/var/db/receipts

     

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

     

    3. Re-install.

     

    If you purchased an iLife Disk, then iPhoto is on it.

     

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

     

    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • 5. Re: iPhoto crashing on every synch with Facebook
    CarlJos Level 1 Level 1 (0 points)

    Yeah, that's exactly the process I used (found elsewhere on this forum). I also tried removing the Facebook account and reapplying it.

  • 6. Re: iPhoto crashing on every synch with Facebook
    Terence Devlin Level 10 Level 10 (123,855 points)

    That suggests that you need to reinstall the OS then.