Skip navigation

mail duplicate last name

4106 Views 26 Replies Latest reply: Feb 27, 2014 6:10 AM by frigate356 RSS
  • Roy2006 Calculating status...
    Currently Being Moderated
    Feb 2, 2013 7:46 AM (in response to boyvinall)

    I have the exact same problem. 4-5 contact of the 500 or so I have in my address book get this duplicated last name during auto-complete. These are some of the most common contact I use. As with some of the other people in this thread, I'm using Exchange as my e-mail server.

  • Mammoth68 Calculating status...
    Currently Being Moderated
    Feb 3, 2013 12:41 AM (in response to Roy2006)

    Strange! It could be caused by those other users in the exchange environment. Are they also using Apple Mail and do they have the same issue?

  • ooninay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2013 10:25 AM (in response to Mammoth68)

    I don't think so. In my case the people it's happening with almost certainly don't ever use Apple mail.  They're using Outlook on Windows machines.  I think it's related to Apple Mail's (on my Mac) interaction with the Exchange server. 

  • Anthony Pearson Calculating status...
    Currently Being Moderated
    Feb 6, 2013 6:14 AM (in response to ooninay)

    Would like to clarify, for my part anyway:

    the problem occurs on my Mac, using Mac Mail, for contacts whom are primary business associates (yes, one of my several e-mail accounts inside Mail is an Exchange account). A few of them might also have a linked record, in say iCloud, but not many.


    Because of the frustration -- and no end in sight -- I have temporarily abandoned mail because the duplicate last name problem apparently also impacts the search token, so if I use the search bar for a message 'from' Joe Smith, I get different results than Joe Smith Smith. This feels very un-Apple, and is a major dissatisfier for me.

  • sk1sk1 Calculating status...
    Currently Being Moderated
    Mar 27, 2013 4:51 AM (in response to boyvinall)

    I'm having the same problem.  Genuis Bar couldn't fix.  I can clear it temporarily using some of the methods discussed in this thread, but the problem recurs in a day or two.


    For clarity, the problem as I experience it is that Mac Mail (OS X 10.8.3 fully updated) against Exchange 2010 scrambles up my contacts so that in autocomplete email addresses, I see contacts offered that are hashes of the real contacts, and the same when incoming mail addresses are displayed.  The formats include repeated last names, and repeated email address is ()'s, and both together.  The triangle on some of these references a contact that doesn't exist, and on some references the real underlying contact.


    The Genius had a good suggestion, but I haven't found a way to implement it.  He suggested exporting all the contacts, deleting them from the server, and re-importing them.  After a full backup, I tried doing that from the Mac Contacts app.  The contacts exported nicely (be sure to enable export of notes if you want to preserve these), and imported nicely too, however I discovered the Mac Contacts is not capable of uploading contact photos to Exchange.  Result: everything looks good on the Mac, but the contacts are restored without the contact photos.  I couldn't find any way of doing export/import that preserved all the contact data - notes, contact photos, etc.  Does anyone know how to do that?

  • chrisbarth Calculating status...
    Currently Being Moderated
    Oct 24, 2013 6:59 AM (in response to boyvinall)

    Has this ever been resolved in any way? I'm still getting the duplicated last names in Mail. Only happens on contact I have on an Exchange server, so I know this is not a problem for EVERY user. However, it's very frustrating.


    I should also note that I've been able to make it go away temporarily (following fix here or continuously deleting previous contact list or forcing the address by dragging it from contacts), but it always comes back.

  • chrisbarth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2013 7:04 AM (in response to chrisbarth)

    I did read another possible "solution" here, but this is really more about making the problem go away by limiting functionality:

    Stop using previous receipts, it will still autofilling the "To:" form with your addressbook contacts but you don't have to check previous receipts every time you send a mail. Delete all the list, close mail and enter "defaults write SuppressAddressHistory -bool true" in Terminal.


    There's also this advice (would be nice if this was compiled in some kind of shareware app) which requires editing the database itself:

  • Nonious Calculating status...
    Currently Being Moderated
    Oct 25, 2013 9:39 AM (in response to chrisbarth)

    @Chrisbarth -- I continue to have the same frustrating experience as you and also have an Exchange account (as well as an IMAP) configued within Mail. For the first half-day, I thought my recent OS upgrade to Mavericks had fixed the issue. It in fact has not. Very frustrating, as my contact cards are correct. I am yet to see a workaround that is satisfactory to me. Just wanted to let you know that Mavericks and Mail 7.0 do not -- by virtue of installing/upgrading alone -- resolve this issue.


    I have not tried any of the previous 'fixes', like clearing the previous recipients, since my upgrade. So I am open to be used as a test case / guinea pig given I have the newest OS and have a "blank slate" in terms of my still having the problem but not yet having implemented any attempts to fix on the new software; hope that helps some. //AP

  • Thimee Calculating status...
    Currently Being Moderated
    Oct 31, 2013 11:23 AM (in response to Nonious)

    Same problem, also on Mavericks.


    I reported a bug (15309599) on, and am telling their engineering teams that they're welcome to perform a remote debugging session on my machine, hopefully we can get this issue resolved.


    FWIW, I have 2 exchange accounts, hotmail and gmail (4 in total) configured on my environment, by only use 1 of the exchange accounts for contact storage (the rest are turned off in preferences).

  • Ratherbeinmaui Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2013 3:33 PM (in response to boyvinall)

    I am also having this issue and it seems to have nothing to do with contacts in either iContacts or the contact list in our exchange server.  All contact names are correct in each contact list.  It seems to be limited to an autocomplete bug.  i.e.  we have a new employee at our company, who was already in my contact list.  When he came over to the company, we assigned him a new email address, which has not been added to either my mac address book OR my PC address book, but upon sending emails from my mac, the double last name issue comes up on both his old address (in both address books) and his new email address (in NEITHER address book)


    A fix would be greatly appreciated, but since many of these thread items go back into the early 2012 calendar, I doubt Apple is working on it, much less reading these support community threads!

  • SeanCota Calculating status...
    Currently Being Moderated
    Jan 30, 2014 12:37 PM (in response to Ratherbeinmaui)

    I'm using Maveriks 10.9.1 with mail 7.1

    I have 3000 contacts.  The most common ones the autocomplete inserts them in the To and  CC fields mulitiple times, then I have to hit the destructive delete key to get rid of the duplicates.


  • frigate356 Calculating status...
    Currently Being Moderated
    Feb 27, 2014 6:10 AM (in response to Ratherbeinmaui)

    It's Apple. Apple has taken to embracing the good old Microsoft paradigm - your OS knows what you need more than you do. Apple won't fix this 'bug' because it's not a bug to them.. it's intentional. If the last name field is left empty, then the field is filled in if possible using info from other fields. I put fist and last name in first name field because I think in terms of first names and I want contacts sorted by first names for my own quick reference. Apple doesn't like my way of thinling, so it has been incessantly trying to correct it for 4 years. Thanks Steve Jobs Jobs.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.