Skip navigation

Versions of iMovie and iPhoto compatible with Snow Leopard

350 Views 3 Replies Latest reply: Feb 2, 2013 2:12 PM by mende1 RSS
Niku Level 2 Level 2 (285 points)
Currently Being Moderated
Feb 2, 2013 1:54 PM

I finally managed to reinstall iMovie and iPhoto into the Snow Leopard side of my hard drive (I have partitioned it into Snow Leopard and

Mountain Lion). I want to use the last versions of both that are still compatible with Snow Leopard, but I don't want to download any updates that will take me into Mountain Lion territory.The iMovie version that I have downloaded is 8.0.4 (807), and the iPhoto version is 81 (415).  What versions are only compatible with Mountain Lion?

iDVD 7.1.1 (1150)
  • mende1 Level 10 Level 10 (89,470 points)

    You have iLife '09. iLife '11 also works with Snow Leopard, but if you install it and use Software Update to update iMovie and iPhoto, you will see that they won't be updated to iPhoto 9.4.2 and iMovie 9.0.8.

     

    These versions require OS X Lion or Mountain Lion, so they won't work under Snow Leopard. However, your Mac won't allow you to install those updates

  • mende1 Level 10 Level 10 (89,470 points)

    You can install iLife '11 without any problem, and Snow Leopard won't allow you to install a non-supported version. However, you can continue using iLife '09

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.