1 2 3 4 5 Previous Next 64 Replies Latest reply: May 30, 2014 8:01 AM by brconflict1 Go to original post
  • 45. Re: Ethernet cable unplugged
    Webmason1 Level 1 Level 1 (0 points)

    I have finally solved this problem for myself and I am kind of irritated that it took me so many hours of scouring the net and trying everything recommended  in every forum, but it did finally pay off!

     

    The solution that worked for me - believe it or not - was that the cable was simply not making a good connection. It wasn't the cable, it didn't work with several different cables. But I finally found someone on the web who had a similar problem and said that it was the port and he could tell by watching the System Prefs>Network Panel and by lifting and wiggling around with the cable in the port he could see when it connected. I tried that and sure enough it connected intermitently.

     

    So I shut down the computer, and ever so gently took fine pointed tweezers and gave each little wire in the port a tug. Then I plugged in the cable and used the hole on the back of the iMac stand to keep the cord in a sort of lifted position to keep as much pressure as possible on the connection.

     

    I believe this damage happend when I moved. When I went to set up the computer, I inadvertantly plugged the second monitor cable into the ethernet port. To bad it fit in! I think it pushed the pins down ever so slightly because it never worked after. I just never put 2+2 together. I could see others doing this because the ports are similar in size and shape.

     

    It works absolutely perfectly now. It litterally just took elbow grease. Ugh...

  • 46. Re: Ethernet cable unplugged
    codemahn Level 1 Level 1 (10 points)

    Manually resetting the ethernet via System Prefs>Network>Ethernet Advanced>Hardware only worked temporarily for me. But I tried resetting the PRAM on my Mid 2010 27 inch iMac, and my ethernet connection seems to be back in action.

    Follow these steps to clear the PRAM:

     

    --Shut down your computer.

    --Press and hold the Command, Option, P, and R keys during boot up (make sure to press all four keys before the gray screen appears on boot up)

    --Allow computer to restart and release the keys after the second startup sound

     

    This worked perfect for me, hope it works for others!

  • 47. Re: Ethernet cable unplugged
    its.me Level 1 Level 1 (0 points)

    Mabook Pro 2.53, 8G, 500G HDD, Snow Leopard,

     

    I observed the same problem, Macbook running on Ethernet yesterday evening, shutdown, this morning it would not connect anymore with status "cable unplugged", tried other ports, cables, no result, reset PRAM without effect, extensive h/w diag showed no h/w error. then tried the setting the port speed to 100TX in the system preferences of MAC and it came up. As i have different location profiles running i thought to also change this in the other locations, but there doing the same thing didn't work and ethernet status remained "cable unplugged", nevertheless when changing back to automatic in this profile did the trick. So my assumption at the moment is that any change of settings on ethernet might cause some kind of reset that will bring the ethernet up again.

     

    Anybody observed the same, or has has a "real" explanation for this?

  • 48. Re: Ethernet cable unplugged
    MG10000 Level 1 Level 1 (0 points)

    Hi.

    I have the same problem and identified that the cause is cat 5E wires. You need to connect to an infraestructure based on cat 6. You can test it. Connect directly to a 1G switch with a cat 6 patch cord and you will see how the connection negotiates at 1Gbps. But if you're connecting to a phisical remote point and the wire between your point and networking rack patch pannel is cat 5E or less, you can only negotiate connection at 100Mbs or slower.

    This is my case and now I feel better because I lnow the reason.

    Excuse my english if any mistake

     

    Regards

  • 49. Re: Ethernet cable unplugged
    iGary Level 4 Level 4 (1,565 points)

    My experiences do not match yours. I don't have a single user connecting via Cat6. Every single one of them is successfully at 1000bT with Cat5e cables.

  • 50. Re: Ethernet cable unplugged
    TonyToniTone Level 1 Level 1 (0 points)

    I am having the same "Ethernet cable unplugged" on my early 2001 MBP, it works fine in Win7 Bootcamp.

     

    I deleted the selected service from Network and rebooted, when I try adding Ethernet back into network it is not available.

     

    Does anyone have any ideas?

    Thanks

  • 51. Re: Ethernet cable unplugged
    TonyToniTone Level 1 Level 1 (0 points)

    2011 MBP.

  • 52. Re: Ethernet cable unplugged
    brconflict1 Level 1 Level 1 (0 points)

    Obviously there's lots of different scenarios assumed, but having worked for a major Telecom Electronics provider, this doesn't and shouldn't discount the fact that people ARE having an issue, and they are asking for help where the manufacturer's own support isn't capable. Ignoring this could be detrimental to the business.

     

    Now, I assume Apple read this original post and all of the responses. I assume that Apple has at least asked the Engineering team(s) whether they have seen this in Design Verification Tests. I also assume that there is a way to research what I'm about to describe, because this is where I would investigate if I were a detective who could research these things. There's one aspect that manufacturers are painfully aware of, but also try hard not to look into because of the efforts involved: Date Codes.

     

    If the people on this board are not giving enough information, then why not pose a few simple questions to at least find some common ground? That's what I do. In this cae, I have the "exact same issue", or "symptom" might be the more appropriate note to sound. This issue with specific, but not all Unibody MBPs running either Snow Leopard or Lion, using CAT5e or CAT6 patch cabling, Dell 3548P, 6248P switches, or Cisco 3550X switches, across less than 300' of 23AWG Oxygen-free Plenum cabling, terminated at CAT6 standards with some compliance to spare, points to a Duplex or Speed Negotiation issue. If you set the Ethernet port to 100-Full, no issues, even if the switch is still set to Auto (yep, I said that erroneous configuration.). NOTE: If you perform the "sudo ifconfig en0 down", then "...up" commands, Ethernet recovers every time. I suspect an issue with the NIC "giving up" on speed/duplex negotiation too quickly. Driver issue? I doubt this with Snow Leopard vs. Lion. Just doubting, not validating.

     

    After considerable testing, in several different scenarios with other new and dated Macs, and PCs, I (Apple Corp.) would immediately start checking date codes on the Ethernet chips on the NIC. This is the one variable I have not been able to rule out. If there's a way for people on this post to check that date-code rthough the OS, that would help. From there, Apple can find a duplicate hardware configuration and run internal tests.

     

    Again, this type of issue should not necessarily be ignored, even if lacking information because where these issues may crop up in a Corporate environment, especially in accumilating numbers will give executives more inclination to drop the Mac's in favor of WIndows PCs. Don't underestimate the power of business and the perceptions of executives.

     

    If it's not worth the effort or time, then it is what it is, and the users will just have to devalue the product in their own minds and we move on.

  • 53. Re: Ethernet cable unplugged
    brconflict1 Level 1 Level 1 (0 points)

    DISCLAIMER: I'm not stating this is in fact the root-cause issue, but merely suggesting Apple start looking here.

     

    I also wanted to add an additional bit of information. My company uses over 100 MBP's, and have found the following in reference to this issue:

     

    1. Seems related to iCore7 models (not iCore5), using the Broadcom 57760-B0 Ethernet Controller.

    2. Seems to be Duplex/Speed negotiation tolerance malfunction. In our case older switches tend to make this occur more often. We mainly see this only with Dell 6200 Series switches and 3548P Switches.

    3. Seems the MBPs' Ethernet Controllers don't wait long enough for the Speed/Duplex negotiation to take place and simply "give up" without retry.

    4. Hard-coding the laptop to 100-Full fixes the issue.

    5. Add a QA step in manufacturing to test for this. Connectivity is a high requirement for laptops.

     

    Obviously, if the Ethernet port would simply retry the negotiation again with a slower process, this would potentially resolve itself.

     

    Ethernet Model Information:

    =====================

    Broadcom 57765-B0:

     

      Name:    ethernet

      Type:    Ethernet Controller

      Bus:    PCI

      Vendor ID:    0x14e4

      Device ID:    0x16b4

      Subsystem Vendor ID:    0x14e4

      Subsystem ID:    0x16b4

      Revision ID:    0x0010

      Link Width:    x1

      BSD name:    en0

      Kext name:    AppleBCM5701Ethernet.kext

      Firmware version:    57765-v1.37, 0x7287af41

      Location:    /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleBCM570 1Ethernet.kext

      Version:    3.0.8b2

  • 54. Re: Ethernet cable unplugged
    berrisj1 Level 1 Level 1 (0 points)

    Appear to have same problem as people above:

     

    Home network (more robust than typical)

    27" Mid 2011 iMac

    10.7.4

     

    Locally onnected to Trendnet Gigabit switch (green technology) via Cat6. That switch is connected via Cat6 to Cisco Gigabit switch in basement. That switch is connected to ATT Uverse residential gateway via Cat6 cable, but it is a 100BT unit.  I have several other 100 and 1000 devices connected to Cisco.

     

    Only trouble is with iMac.

     

    Constant cycle of connected, disconnected with no ability to actually connect.

     

    Airport has worked fine and I have been using it until today.  When I watched how slowly 10.8 was downloading I tried to go back to the ethernet connection to pick up some speed.  It didn't work and then I found this tread.

     

    I changed the hardware from automatic to Full/energy/flow... didn't work.  Changed to Full/energy....didn't work. Changed to Full/flow... immediatly started working.

     

    This seems to be an energy effiency related problem.  Maybe it is related to the Trendnet (green) router.  Maybe something else. 

  • 55. Re: Ethernet cable unplugged
    berrisj1 Level 1 Level 1 (0 points)

    A few hours later and I have updated to 10.8

     

    Ethernet no longer works.

     

    There is no longer an option for effiency on the hardware section of the network connection.  Per my post above, when I turned off effiency everything worked great. 

     

    Apple... you have made things worse.

  • 56. Re: Ethernet cable unplugged
    Alsuwaidi89 Level 1 Level 1 (0 points)

    This solved the problem with me.. all I did is removed the ethernet entry, unpluged the cable, added new one, pluged the cable again and bam its working

  • 57. Re: Ethernet cable unplugged
    berrisj1 Level 1 Level 1 (0 points)

    So I realized my Mac was under warranty.

     

    I called support and spent and hour with them doing everything I had already done:

    Zap Pram, new location, remove and re-enter ethernet setting, new user, reboot in recovery and more.

     

    They sent out a repair guy who swapped out the logic board.  It now works.

     

    There is no question everything was working fine just before the 10.8 upgrade.  I had a similiar hardware failure (speakers stopped working) years ago on a PowerBook after a software upgrade.  That too resulted in a logic board swap under warranty.

  • 58. Re: Ethernet cable unplugged
    Christoph Franke Level 1 Level 1 (0 points)

    This is exactly the problem I am having for quite a while now. See my posting on the Cisco SBS community forum. My iMac 27 Mid 2011 running OS X 10.8.2 (driver version 3.2.5b3) is connected to a Cisco SG 300 via a Cat6 cable. Hopefully Apple will take a look at this issue.

  • 59. Re: Ethernet cable unplugged
    Allex2501 Level 1 Level 1 (0 points)

    FIxed my problem!

     

    Go to System preferences

    Go to Ethernet
    Go to Advance
    Go to Hardware

     

    The just make the changes like in the pictures below

     

    it work for me

     

     

    Screen Shot 2013-02-02 at 8.18.21 PM.png