Skip navigation

I can no longer connect to my Canon MG5450 printer...

1169 Views 7 Replies Latest reply: Feb 11, 2013 1:10 PM by rpt007 RSS
asterisk1991 Calculating status...
Currently Being Moderated
Dec 7, 2012 7:08 AM

either by USB or WiFi. I was printing OK until two days ago - then I updated iTunes and Safari and since then I haven't been able to connect with my iMac.


Bizarrely, I can connect via USB with my son's Windows 7 laptop, so I believe that the printer is working fine.


I've tried resetting the Print System and adding the printer again - and now it is not even appearing in the 'Add Printer' dialog.


The printer is connected to the Wireless router (I can see it in the Devices list on the router) and the iMac is connected to the router too (web pages are loading).


I have exhausted every possible solution and I'm still stuck.

iMac (21.5-inch Mid 2011), OS X Mountain Lion (10.8.2)
  • rpt007 Calculating status...

    Hi asterisk1991,


    see the following discussion:

    Re: Canon Pixma MG5450 Wireless Printer  where I confirmed the issue with Canon and OSX and some workarounds before Canon eventually comes out with a stable driver for the printer and Apple users.


    Like you I have at least 3-4 times re-installed the whole software package, the driver etc. - no way. It is the driver that doesn't work as it should.


    Good luck with the workarounds and hopefully we don't have to wait too long for better connectivity.

  • PAHU Level 6 Level 6 (14,400 points)

    So with the MG connected to the Mac via USB, if you open System Information (Applications > Utilities) and select USB in the left column, the MG should appear under one of the USB busses in the top right pane. If it does not, then try another USB cable.


    As for the network, Bonjour is used to discover the device on the network. If there is an issue with Bonjour, then your Mac will not see the MG. To check Bonjour on the Mac you can get a utility called Bonjour Browser. With this installed on the Mac and open, you will see all devices advertising with Bonjour on your local network. Do you see the MG listed?

  • rpt007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2013 1:56 AM (in response to PAHU)



    thanks for the advice.


    I have connected the MG5450 via WLAN as the location is out of reach of the existing wiring and that was the reason to go for the wireless printer.


    With Windows everything is ok (Win7 and Win8).


    Only my OSX machine cannot print right away as it should. I installed the Bonjour Browser and: voilà - the MG5450 showed up immediately. I sent a print job a second later - no way; OSX tells me "the printer is not connected, looking for ... and after some minutes: unable to find the printer" - again, after another 5 minutes the print job was executed as it should.


    When executing the print job there were 3 MG5450 entries in the Bonjour browser with different priorities (the first had priority 0, the second priority 60 - the whole entry disappeared after some minutes and the third one was under the Spooler with priority 60.


    What puzzled me was, that there were two different URLs - mightbe that's why I have the trouble or does the integrated scanner come with a second URL? I guess that are the fragments of the 3-4 installations of that stupid printer and that might be a cause, but the same issues imediately came up after the first installation ...


    See the screenshots with more details:


    Hope, someone can see what's wrong and what I can do.

  • PAHU Level 6 Level 6 (14,400 points)

    rpt007 wrote:


    What puzzled me was, that there were two different URLs - mightbe that's why I have the trouble or does the integrated scanner come with a second URL?

    I think you are correct regarding the second URL being the scanner. With models previous to the MG series, there would be two separate entries in the Add printer window. The printer would be shown as "canonijnetwork" in the Kind column while the scanner would be shown as Bonjour Scanner. Now with the MG you get just the one entry - Bonjour Multifunction.


    There is another method available for connecting to the MG via the LPD protocol instead of Bonjour. I have an MG6250 at work (only have an MP990 here at home) so I will confirm tomorrow how to enable this and then the actions for adding the printer.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Feb 3, 2013 10:21 PM (in response to PAHU)

    Checking the MG series, the LPR protocol appears to be now enabled by default. You can check by entering the IP address of the MG in a web browser, which will connect you to the MG home page. You then press the Advanced button and then select Other Settings in the left sidebar. On this page you will see the LPR protocol setting. If this is not enabled, change it and OK the change. Then turn off the printer for a minute and then back on.


    For your reference, the image below shows the MG6250 shows two entries in the Add printer browser. As shown in the Kind column, one shows Bonjour Multifunction, which adds the printer and scanner, and the other shows Canon IJ Network.

    MG6200 Add Printer.png

    If you were to select the entry showing Canon IJ Network instead of the one showing Bonjour Multifunction, does this work better on your Mac?

  • rpt007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2013 8:10 AM (in response to PAHU)

    Hi Pahu,


    today I found the time to come back to my problem.

    As I hadn't used the printer for some days - I had to realize that things had gone worse. The printer is detected as installed with all options in the printer utility menu. But when I try to print something - the printer isn't found at all.


    Also my workarounds that I had mentioned earlier failed. Thus I am currently de-installing all the Canon stuff with CleanMyMac - which now is taking about more than 30min (!!) deinstalling 1,5GB of about >8500 single files that the crazy Canon installation routine has spammed on my Mac. I want them to install only the stuff I need, not thousands of other language puzzle stones and - it should work!! If my 5th reinstallation fails again I will sell the printer right away and go for another brand which works oob.


    I have spend now a working day or so in total (and I am an experienced Mac user). That drives me crazy indeed.

    Will report later, when the de-installation and re-installation is done.

  • rpt007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2013 1:10 PM (in response to rpt007)



    Installation went thru; then updated the latest driver.

    First attempt: no success to print anything. Then access via browser to the printer's webserver. Checked all options - everything looked ok.


    Then opened OSX System Tools - printer setup. Installed a new printer using the IP-address and LPD. Driver was presented - this was the breakthru (so far).


    After that I tried to print a Disc label and: success! Ok, let's see how long it lasts. Will continue to report if/when something happens again. But: this is no way to set up a printer - people with no clue about computers mus fail and will be very disappointed. A long way to go, my dear friends from CANON. They should eventually realize that it might make sense to occupy a Mac OSX experienced developer as Apple market shares continues to grow.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.