Skip navigation

App Store can not connect to the internet, why ?

380 Views 11 Replies Latest reply: Feb 2, 2013 6:02 PM by HACKINT0SH RSS
alpshiker Level 2 Level 2 (445 points)
Currently Being Moderated
Jan 26, 2013 3:16 PM

Hi, I have installed a new PowerBook with ML for a friend and migrated her data to it.

Being myself new to anything post Leopard, I am trying to find my way. The new approach to upgrades only in relation to a personal account is a bit disconcerting. I have not been able to connect so far. I could retrieve her Apple ID and password and connect to her ID page through Safari, but when I want to check for software updates, the App Store page stays greyed and there is a message saying that in order to use App Store, an Internet connection is required, and this despite being otherwise connected. I installed a patch for passwords found on Apple's website, but there is no change. Are we required to open an iTunes account first? We tried so but were stuck when asked a credit card. Is it possible to open that account on the money deposited on an iTunes gift card? Thanks if you can help us through!

 

Message was edited by: alpshiker

  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Jan 26, 2013 9:48 PM (in response to alpshiker)

    A lot of variables can be happening here.

     

    First of all, let's create a test account and see what happens there when trying to connect to do software updates from there.

     

    OS X Mountain Lion: Create a new user account

              http://support.apple.com/kb/PH11468

  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Jan 28, 2013 7:40 PM (in response to alpshiker)

    Slow down brown cow. I only have very little time every day to troubleshoot here

     

    A couple of your next posts has now given us some more clues, so now it is time to change your DNS:

     

    Network Preferences --> Advanced --> DNS --> DNS Servers

    Add these two entries:

    8.8.8.8

    8.8.4.4

     

    Remove everything else. Leave Domains as is.

     

    Reboot if this fails.

  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Feb 1, 2013 11:37 PM (in response to alpshiker)
  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Feb 2, 2013 6:02 PM (in response to alpshiker)

    Looks like the server is gone now. No worries:

     

    1. Delete the files /var/db/crls/crlcache.db and /var/db/crls/ocspcache.db. These can be found using Finder’s Go >; Go To Folder menu (Cmd + Shift + G). This resets the cache of accepted certificates in the system. It doesn’t remove them, it just forces the system to rebuild the caches upon restart.
    2. Open Keychain Access (/Applications/Utilities/Keychain Access). Select Certificates in the Category picker on the left side. In the search bar, type in the word Class. Look through that list, and find any certificates that have a blue + symbol over their icon. These are the ones you need to modify.
    3. Select one that has a blue +, and hit Command + I. Click the disclosure triangle beside the “Trust” list to show the list of permissions. Now, what we need to do is to set this certificate to use the system defaults. However, for some reason, when you select it, it doesn’t save. So what you need to do is this. Under “Trust”, where it says “Secure Sockets Layer (SSL)”, change the dropdown menu to say “No Value Specified”. Then, close the window. It will ask for your administrator permissions. Then, open the info pane for that certificate again. Under “Trust” again, now set the dropdown that says “When using this certificate:” to say “Use System Defaults”. You can then close out of the info pane, and enter your password again. Do this for any of the certificates that have a blue + on their icon. There should only be one or two at most.
    4. Restart your system.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.