Skip navigation

Why won't Final Cut Pro 7 allow me to Shift, Command or Option-select items?

957 Views 16 Replies Latest reply: Mar 28, 2013 5:20 PM by xangelsdemons13x RSS
1 2 Previous Next
daviesgeek Calculating status...
Currently Being Moderated
Feb 2, 2013 4:32 PM

I am having a major problem with Final Cut Pro 7. I commonly select multiple items using the Shift (⇧), Command (⌘), or Option (⌥) keys. However, just recently it started not allowing me to select multiple items this way. What happens is either the timeline, the slug, or the canvas will play (depending on which one is selected) I didn't change anything on the computer; it just started happening. I even tried reinstalling the whole entire Final Cut Studio. However, the problem still remains. This is a real problem and really is causing major issues for me. How do I fix this!?!? I'm at a loss. I've tried everything that I could think of short of reinstalling the entire OS (which I may end up doing). Can someone help me?

Final Cut Pro 7
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.