Skip navigation

special characters do not work on firefox

597 Views 9 Replies Latest reply: Feb 3, 2013 7:28 AM by Tom Gewecke RSS
axelbottenberg Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 3, 2013 1:35 AM

Hi all,

 

I'm doing a lot of web work in German language, using a standard English keyboard on a MacBook, using Os 10.8.2

 

This involves using special characters, such as in "ständig können erhältlich Grüsse verzögert veröffentlichen". Now, I cannot use special characters when using firefox. They simply will not work. They work on Safari, but I prefer Firefox.

 

Has someone else experienced this glitch? is it a MacOs problem? Seems more like a Firefox problem to me.

 

Solutions gladly received! Web work is a pain, even with special characters!

 

Cheers, Axel

MacBook, OS X Mountain Lion
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Feb 3, 2013 5:01 AM (in response to axelbottenberg)
  • Barney-15E Level 7 Level 7 (33,270 points)
    Currently Being Moderated
    Feb 3, 2013 5:24 AM (in response to axelbottenberg)

    Well, if you wanted to view the keyboard, why didn't you ask in the first place? You asked about Firefox, which isn't an Apple program.

     

    Almost every Edit menu has a Special Characters item which shows all the different characters. Sometimes, thats a bit overwhelming, though.

     

    To have easy access to the keyboard viewer, open Language & Text system prefs, Input Sources, and check the Keyboard & Character Viewer.  Also check the Show Input menu in menu bar.

     

    Now, in the input menu (flag), you can pick the keyboard viewer.

    If you are using a lot of accented characters where you use the option-accent, character pattern, and the normal keyboard doesn't have enough of those accents, then the US Extended has a bunch of them.

  • Tom Gewecke Level 9 Level 9 (70,815 points)
    Currently Being Moderated
    Feb 3, 2013 5:26 AM (in response to axelbottenberg)

    Could you provide more details about what is not working?  If you are using the US keyboard layout, then you can get special characters by just holding down the base letter and selecting what you want from the popup menu which appears.  Does that work?

     

    Or you can use the standard Mac keyboard shortcuts:  Option/alt + u, then o gives you ö , etc.  Option/alt + s gives you ß.  Do those not work?

     

    As for keycaps, that is now called Keyboard Viewer.  To activate it you check its box in system preferences/language & text/input sources, plus the box for Show Input Menu in Menu Bar, and then select it in the "flag" menu at the top right of your screen.

  • Tom Gewecke Level 9 Level 9 (70,815 points)
    Currently Being Moderated
    Feb 3, 2013 5:50 AM (in response to axelbottenberg)

    axelbottenberg wrote:

     

    äöööö©©©©©¥¥¥¥¥¥€€€€®®®äää

     

    It works

     

    That's great!

     

    But it would still be helpful if you could tell everyone what process was not working for you and what process you are now using that does work.

  • Tom Gewecke Level 9 Level 9 (70,815 points)
    Currently Being Moderated
    Feb 3, 2013 7:28 AM (in response to axelbottenberg)

    Are you saying that, when the Union Jack is the flag on the screen, neither of the two standard ways to make special characters work for  you, not holding down the vowel and getting a popup menu, and not typing option/alt plus u, then o to get ö?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.