Skip navigation

Audio Output not working!!!

5353 Views 13 Replies Latest reply: Apr 6, 2013 2:13 PM by lonelyplanet RSS
AyalaOfficial Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 23, 2012 11:38 AM

Hey Guys,

 

New to the forum and just seeking some advice!

 

i have recently purchased a macbook pro running osx lion 10.7.5.

 

Now i wanted to use my macbook pro with logic (music production) and i have a audio interface novation nio 2/4 and genelec 8020a's

 

i have gone into system prefences and made sure that the nio is selected for the output sound, now when i play mp3s from itunes the output will play but when swtiching between tracks and videos on youtube sound will stop as if i have muted it? i have unplugged the audio interface and reconnected using usb and seems to work fine but then problem will occur again!!

 

anybody have any idea?

 

i must say before i had the macbook pro i was running a mac pro for about 4years with the nio and no problems what so ever so i am completey baffed!!

 

Please help guys its driving me insane!!

 

Ayala

MacBook Pro, Mac OS X (10.7.5)
  • Jan Due1 Level 2 Level 2 (345 points)
    Currently Being Moderated
    Sep 23, 2012 6:44 PM (in response to AyalaOfficial)

    I´m not sure I can help. but there is a new driver for the NIO, on their website.

    For Lion, that would be. Maybe you should dig deeper and go to utilities>Audio MiDi setup,

    and see what it looks like. We have an Avid HD Native !6x16 system, and it behaves just the same.

    If you have Pro Tools open, and want to go Youtube, you are f.....

    BTW, Whats´s your experience with the 8020A? I skipped mine, they began to be a bit "tired" in the bottom.

    Got the 8020B, fantastic, but now the tweeter to the right has gone silent..And i borrowed a pair of Focal....

    Hmm! Our 8050 also went down....Genelec?

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Oct 5, 2012 10:13 AM (in response to AyalaOfficial)

    Try downloading the OSX 10.7.5 supplement install that was recently released.

     

    The driver was originally written for Lion but there have been several incremental updates and 10.7.5 broke some things that were working in 10.7.4.

     

    Something to try...if you select the nio as output in sysprefs also select it as the input, this could help keep the driver stable. 

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Oct 5, 2012 11:27 AM (in response to AyalaOfficial)

    Try downloading the Mountain Lion 10.8.2 supplement just released.

     

     

    "the selected device has no output controls"

     

    That is correct, most professional interfaces do not have output controls of the type that show up in System Preferences. My RME Interface shows the same.

     

    Unfortunately, the new Mac operating systems are far less efficient than they used to be, Both OSX 10.7.x and 10.8.x make Windows 7 seem light, fast and nimble.

  • lonelyplanet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2013 4:45 AM (in response to AyalaOfficial)

    I have this exact same problem as well, but with a minor difference:

     

    Sometimes when I play Youtube videos, or sounds on Soundcloud, the video/sound stops playing (but the play/pause icon doesn't change) when I try to play them through Saffire 6 USB. And as soon as I unplug the Saffire 6, the video/sound begins playing again normally. I've tried to repeat that procedure quite a few times already and everytime the same thing happens.

     

    But when I restart my MBP, the problem will go away for a while and then come back again. It's really frustrating.

     

    (I have the 10.7.5 with supplemental install.)

     

    So is there any solution to this problem yet?

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Feb 2, 2013 9:45 AM (in response to lonelyplanet)

    I can only offer a possible workaround.

     

    In my experience I've found it best to keep the Pro/Semi-pro audio interfaces for use with Logic only, that means setting everything in "Audio-MIDI Setup" to "Built-In" audio. if you wish to monitor the built-in audio through the Focusrite you would run a cable from the Line-Out of the Mac into a pair of Focusrite inputs.

     

    Not a good solution.

     

    My guess is this is a problem with the Focusrite drivers not being 100% Lion/ML compatible.

     

    Just to be clear, this "cutoff" happens outside of Logic, (with Logic not running)

  • lonelyplanet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2013 3:05 AM (in response to Pancenter)

    Thanks! I could do that in Ableton Live too... but yeah, that's not a good solution actually.

     

    It seems that going into sleep mode triggers the problem, as you said, it's not 100% compatible with the OS.
    http://www.focusrite.com/answerbase/en/article.php?id=006

     

    So I'm now going to unplug my Saffire 6 everytime before going into the sleep mode on my MBP. Hope that will work!

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Feb 3, 2013 7:47 AM (in response to lonelyplanet)

    Ok, Sleep Mode...   that's a known "problem" with many audio interfaces, I'm not sure it's even a problem as it's normal for USB to "disconnect" or power down to save energy, that's what sleep mode is designed for.

     

    I suppose the driver could keep the connection active but that would be up to Focusrite.

  • lonelyplanet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2013 5:07 AM (in response to Pancenter)

    Yeah you're right, but it's a bit weird because usually it will work after sleep mode and no disconnection, but then after a while it won't work again...

     

    So, I tried disconnecting it before going into sleep mode but it didn't work either. The problem occured likewise when I had had my MBP in sleep mode for a while, and then turned it on again and connected the Saffire 6. It worked fine for a while but then again, the same problem.

     

    So probably it's the sleep mode that will trigger some things that will then cause the Saffire 6 to not work properly. Maybe if I shut the computer down everytime I would normally use the sleep mode, I need to see if that works to get rid of the problem...

  • lonelyplanet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2013 2:13 PM (in response to lonelyplanet)

    OK so I've been fooling around and got my head around how the problem is triggered. I've tested these a lot now and I'm very sure about them:

     

     

    1. The problem is triggered only by manually going into sleep mode. And that happens everytime you do that.

     

    2. Waiting for the system to put itself into sleep mode does NOT trigger anything.

     

    3. Restarting the computer makes the problem go away (until you go manually into the sleep mode).

     

    4. It doesn't matter when I connect the hardware, any unplugging and reconnecting doesn't help at all:

     

    The problem appears only everytime that I have manually put the computer into sleep mode (either through the menu or by closing the lid). If I only wait for the system to go into sleep mode by itself, I can have the hardware connected as long as I want and it works just fine, no matter how many times the computer goes into sleep mode.

     

    So I think this is quite funny and interesting, how the sleep mode only triggers the problem and only when you manually make the system to go into the sleep mode!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.