3 Replies Latest reply: Feb 4, 2013 11:31 AM by léonie
logicprobe Level 1 Level 1 (0 points)

I finally upgraded my iMac (iMac7,1 Core 2 Duo) from Snow Leopard to Mountain Lion and Aperture from 3.2.2 to 3.4.3. When I start Aperture, all I get is its menu bar with all menu actions grayed out. Activity monitor shows it's using 100% of one core. The only way to stop it is Force Quit.

I removed Aperture preferences and deleted and re-installed Aperture from the App Store. Makes no difference if I start Aperture while pressing Option or Option-Command; I get no pop-up asking me which library to use or showing repair/rebuild options. I re-installed Mountain Lion from the App Store. I deleted my Aperture library (after backing it up). I found and deleted every file on the system with "Aperture" in the name. I ran Repair Disk Permissions in Disk Utility. I started in single user mode and ran fsck (no problems reported). Nothing makes any difference; all I get is the menu bar and a pegged CPU.

I have determined that it's something in my account. I created a new account and copied my Aperture library to it. Aperture started up normally and upgraded my library to 3.4; it runs fine in a different account on the same machine.

I don't want to nuke my user account and make a new one, but it looks like that's the only thing left to try if I want to run Aperture in the same account where I read email, surf the web, edit documents, etc.

Any ideas what could be causing Aperture to hang when started from my account but run fine in another account after upgrading to Mountain Lion and Aperture 3.4.3?

  • 1. Re: 3.4.3 hangs at startup after Mountain Lion upgrade
    léonie Level 9 Level 9 (51,775 points)

    Any ideas what could be causing Aperture to hang when started from my account but run fine in another account after upgrading to Mountain Lion and Aperture 3.4.3?

    • Have you checked your Login items? (in System Preferences > Users&Groups)
    • And looked for installed kernel extensions (third party software), that are only active when working from your account? For example helper apps, like "Camera"
    • Non-Standard System Preferences panes, that are only installed for your account (the "Others" brick in "System Preferences"). Look for example for haxies, like Fruit menu, Windowshade,...
    • Non Apple Quicktime components in : ~/Library/Quicktime or  /Library/Quicktime
    • Non Apple Fonts or duplicate fonts, ~/Library/Fonts

     

    There is a neat little utility script "EtreCeck". It will run an inventory of your Mac and list non-standard installations. You can download it here: Etresoft: EtreCheck

    and paste the result into your next post, if still necessary.

     

    Also, I'd remove the ImageCapture Preferences (~/Library/Preferences/ImageCapture).

     

    Regards

    Léonie

  • 2. Re: 3.4.3 hangs at startup after Mountain Lion upgrade
    logicprobe Level 1 Level 1 (0 points)

    Thank you!

     

    The problem was Flip4Mac, which is in the "Others" brick in System Preferences. After I upgraded to the latest version (Flip4Mac 3.0) Aperture started properly.

     

    John

  • 3. Re: 3.4.3 hangs at startup after Mountain Lion upgrade
    léonie Level 9 Level 9 (51,775 points)

    You are welcome, John.

    After I upgraded to the latest version (Flip4Mac 3.0) Aperture started properly.

     

    I am glad you could find the cause of the problem.

     

    Léonie