Skip navigation

Ethernet Cable Unplugged - Software issue?

1011 Views 10 Replies Latest reply: Feb 4, 2013 7:37 AM by Allex2501 RSS
SNIPR806 Calculating status...
Currently Being Moderated
Jul 6, 2011 3:19 PM

OK I am running a Macbook Pro bought new on 11/14/10. I called Apple who informed me my phone support was over but I do have 1yr on my parts/labor for hardware. So they had me take it into a local Authorized Mac repair facility. I brought the Macbook Pro in and they ran diagnostics telling me its a software issue but because I didn't sign anything they couldn't charge me for the disgnostics. They informed me that the ethernet nic works in safe mode. I didn't even know Mac's had safe mode but ok. They instructed me to reinstall the OS X or they would do it for $170 and it would fix the issue. Well I did that myself and yes it did work that night however, this morning when I went to plug my ethernet cable in it once again tells me the cable is unpluged. Only airport will connect. To answer the typical questions: Yes, I did swap out cables. Yes, I did use the same cables and connected to other peripherals just fine. Apple will not help unless I pay them for apple care. This even includes telling me where in the knowledge base the answer lies. This is my last hope as I am new to Mac's and not sure where to begin with it? Thank you all in advance for all and any help you can provide me.

MacBook Pro, Mac OS X (10.6.8)
  • Kappy Level 10 Level 10 (221,065 points)
    Currently Being Moderated
    Jul 6, 2011 3:34 PM (in response to SNIPR806)

    You could try:

     

    1. Open Network preferences in System Preferences.
    2. Click on your Ethernet port
    3. Click on the Delete [-] to remove it. (You may have to click the lock icon and authenticate with your admin password.)
    4. Click on the Add[+] to add your Ethernet port back.
    5. Check that the Location dropdown menu is set to Automatic.
    6. Click on the Apply button.

     

    Another workaround is to manually set the port to use 100BT. Some users have found that this solves the problem of the disconnect.

     

    Also, you can try resetting the SMC: Intel-based Macs: Resetting the System Management Controller (SMC).

     

    Be sure your Ethernet cable is at least CAT6 rated.

  • Kappy Level 10 Level 10 (221,065 points)
    Currently Being Moderated
    Jul 6, 2011 4:12 PM (in response to SNIPR806)

    So when you clicked on the Add[+] you did not see this under the Interface dropdown menu:

     

    Screen Shot 2011-07-06 at 4.09.57 PM.png

    Is the Ethernet cable connected?

     

    Have you tried any of the other possible fixes?

  • Kappy Level 10 Level 10 (221,065 points)
    Currently Being Moderated
    Jul 6, 2011 5:45 PM (in response to SNIPR806)

    Glad you are sorted out.

     

    < Edited by Host >

  • harkman Calculating status...
    Currently Being Moderated
    Jul 31, 2012 1:40 PM (in response to SNIPR806)

    This actually worked for me! After two weeks of struggling to find a solution. Apparently the Automatic setting wasn't choosed the correct Speed and Duplex settings.

  • Allex2501 Calculating status...
    Currently Being Moderated
    Feb 4, 2013 7:37 AM (in response to harkman)

    FIxed my problem!

     

    Go to System preferences

    Go to Ethernet
    Go to Advance
    Go to Hardware

     

    The just make the changes like in the pictures below

     

    it work for me

     

    Screen Shot 2013-02-02 at 8.18.21 PM.png

Actions

More Like This

  • Retrieving data ...

Incoming Links

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.