Skip navigation

Profile manager and wiki read error

4042 Views 7 Replies Latest reply: Feb 4, 2013 8:20 PM by trilogy1000 RSS
loup.bell Level 1 Level 1 (5 points)
Currently Being Moderated
Jan 24, 2013 1:22 PM

Hello everyone,

 

I did something dumb. REALLY dumb. I deleted /Library/Server on my Mac Pro running Mac OS 10.8 ML Server

 

Of course, no backup.

 

When I realised that Server.app was displaying tons of errors, I installed a fresh copy of ML Server in a VM. I then copied /Library/Server back in my main machine, deleted Server.app and reinstalled it through the mac app store.

 

Now everything works fine except the profile manager and the wiki that both display "Error reading settings". I tried to run wipeDB (http://support.apple.com/kb/HT5349) as root but here what comes out of this:

 

server:~ Loup$ sudo /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/wipeDB .sh

devicemgr:state = "STOPPED"

postgres_server:error = "CANNOT_START_SERVICE_TIMEOUT_ERR"

(in /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend)

Couldn't drop device_management : #<PGError: could not connect to server: No such file or directory

          Is the server running locally and accepting

          connections on Unix domain socket "/Library/Server/PostgreSQL For Server Services/Socket/.s.PGSQL.5432"?

>

(in /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend)

could not connect to server: No such file or directory

          Is the server running locally and accepting

          connections on Unix domain socket "/Library/Server/PostgreSQL For Server Services/Socket/.s.PGSQL.5432"?

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:9 41:in `initialize'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:9 41:in `connect'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:9 41:in `connect'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:2 17:in `initialize'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:3 7:in `new'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb:3 7:in `postgresql_connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:223:in `send'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:223:in `new_connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:245:in `checkout_new_connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:188:in `checkout'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:184:in `loop'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:184:in `checkout'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor. rb:242:in `synchronize'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:183:in `checkout'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:98:in `connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_poo l.rb:326:in `retrieve_connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_spe cification.rb:123:in `retrieve_connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/activerecord/lib/active_record/connection_adapters/abstract/connection_spe cification.rb:115:in `connection'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/railties/lib/tasks/databases.rake:70:in `create_database'

/Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/vendor/ rails/railties/lib/tasks/databases.rake:31

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 636:in `call'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 636:in `execute'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 631:in `each'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 631:in `execute'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 597:in `invoke_with_call_chain'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/monitor. rb:242:in `synchronize'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 590:in `invoke_with_call_chain'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 583:in `invoke'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2051:in `invoke_task'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2029:in `top_level'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2029:in `each'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2029:in `top_level'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2068:in `standard_exception_handling'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2023:in `top_level'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2001:in `run'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 2068:in `standard_exception_handling'

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb: 1998:in `run'

/usr/bin/rake:31

Couldn't create database for {"adapter"=>"postgresql", "host"=>"/Library/Server/PostgreSQL For Server Services/Socket", "pool"=>5, "database"=>"device_management", "username"=>"_devicemgr", "encoding"=>"UTF8"}

devicemgr:state = "STARTING"

server:~ Loup$

 

 

I think that I will have to wipe my Macintosh HD and reinstall the OS again. the problem is that I have "software-based RAID" and I'm affraid that it won't mount the drives correctly if I wipe my Macintosh HD and reinstall ML server again.

 

Help please !

 

Thanks!

  • UptimeJeff Level 4 Level 4 (3,390 points)
    Currently Being Moderated
    Jan 24, 2013 7:11 PM (in response to loup.bell)

    did you start postgres?

    sudo serveradmin start postgres

  • UptimeJeff Level 4 Level 4 (3,390 points)
    Currently Being Moderated
    Jan 25, 2013 1:25 PM (in response to loup.bell)

    Look at your postgres logs using the Console app

         /Library/Logs/PostgreSQL

    post any results

     

    post output of

    sudo serveradmin settings postgres

     

    Look at the output of above and note the path for "postgres:data"

    Run this command if it matches your path:

    sudo chown -R _postgres:_postgres /Library/Server/PostgreSQL/Data

     

    Try starting postgres again and post anything interesting

  • UptimeJeff Level 4 Level 4 (3,390 points)
    Currently Being Moderated
    Jan 26, 2013 6:51 AM (in response to loup.bell)

    Glad you are on the way to sorting this out.

     

    I can't be much help on device manager, I've never used it.

     

    Looking at the first line you provided, it lists a permission issue at

       /var/devicemgr/ServiceData/Data/migration

     

    Check your permissions there with

         ls -al /var/devicemgr/ServiceData/Data/*

     

    Everything there should be owned by user=_devicemgr and group=_devicemgr

    If its not, you can fix with

         sudo chown -R _devicemgr:_devicemgr /var/devicemgr/ServiceData/Data

     


    Hope that gets you closer..

     

    Jeff

     


  • trilogy1000 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Feb 4, 2013 8:20 PM (in response to loup.bell)

    Kudos to loup.bell!!

     

    This solved it for me. After trying any number of other options this was the only thing that worked.  I had no idea there was anything in /var/ and I'm sure this is where the problem was. Anyway, a huge thank you, we're happily running without the anoying read settings errors.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.