Skip navigation

Adjustments applied to wrong image.

778 Views 20 Replies Latest reply: May 12, 2013 7:56 AM by d60Dave RSS
1 2 Previous Next
d60Dave Level 1 Level 1 (10 points)
Currently Being Moderated
Feb 4, 2013 11:47 PM



I'm a daily aperture user and I frequently notice that when I select a new image and apply adjustments nothing happens and I later discover they've been applied to the previously selected image which is frustrating and time consuming. It's only when I unselect and reselect the desired image that the changes then start to have any affect.


Has anyone else experienced this? Is there a way to over come it? I think I may have posted this problem a month or two ago and it was suggested that I delete the Aperture plist file which I did but it didn't fix it.


It happens on both my MacBookPro (late '12 model) and my MacPro (late '09 model) both running Aperture v3.4.3 and OSX 10.8.2.


Other than this I find Aperture an excellent image editing and organizing environment.


Hope you can help,



MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.2)
  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Feb 5, 2013 10:01 AM (in response to d60Dave)

    This is not something I (or I would guess most users) have experienced.


    So you are saying that if you have an image in the viewer and apply adjustments to it, while you are applying the adjustments it seems fine (they appear in the image in the viewer) but when you leave the image and go back to it the adjustments aren't there?

  • léonie Level 8 Level 8 (46,540 points)
  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Feb 5, 2013 11:40 AM (in response to d60Dave)

    This happens all the time, it is reproducible or it's a once in a while thing?

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Feb 5, 2013 6:11 PM (in response to d60Dave)

    Have you tried Léonie'a suggestion of doing a library repair? That should be your first step.


    As a suggestion I would work in film strip mode until the problem is located. This way you can see if the image in the viewer window is the image that is selected in the browser.


    Other things you can try if the problem is reproducible or at least happening often enough so you rely on it occurring. Make a new library and import some images into it and see if the problem still occurs. If it doesn't happen in the new library that will at least tell you it is something in the old library.


    If it also happens in the new library try making a new user and run Aperture as that user. This will tell you if the problem is system wide or restricted to your environment.


    I wish I had more but in a situation like yours with a strange intermittent problem trying to pin down the source of the error is going to take some time.



  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Feb 7, 2013 1:01 PM (in response to d60Dave)

    That is bizarre. It does seem that if you select the Adjustment tab by using ctrl-a adjustments aren't applied!


    To reproduce:


    1)  While in the Library pane of the inspector with the browser open select an image.

    2) Switch to the viewer

    3) ctrl-a to switch to Adjustment tab

    4) apply adjustment


    Adjustment is not applied.

  • léonie Level 8 Level 8 (46,540 points)
    Currently Being Moderated
    Feb 7, 2013 1:03 PM (in response to Frank Caggiano)

    That is bizarre.

    Even worse; intermittently, the Adjustment tab comes up completely empty, when I switch to it using ctrl-A.

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Feb 7, 2013 1:04 PM (in response to léonie)

    Yep saw that also. Just tried applying an effect from the Effects menu that seems to work.


    OK Who want s to let Apple know?

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Feb 7, 2013 1:23 PM (in response to d60Dave)

    Exactly! I can't believe  no one has discovered this until now. Do you guys not normally use keyboard shortcuts to switch between projects, adjustments and metadata panes?

    Hard to say when this got into the system. It definitely wasn't like this in early version of Aperture 3.  While I'll use shortcuts for things like turning on and off metadata, when it comes to moving around in the library I pretty much stick to the mouse.


    You might want to point them to this thread also so they see its not just your problem.


    good catch.



1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.