11 Replies Latest reply: Feb 23, 2013 8:36 AM by jpdemers
octium Level 1 Level 1 (0 points)

Hello

 

I have a mac book pro 2.7 Ghz i& with 16 GB RAM

 

1) Whenever I search for something in spotlight, when I click on "Show all in Finder", nothing happensScreen Shot 2012-12-01 at 12.02.12 PM.png

 

 

Also, When I check the preferrences, I have some yellow triangles for the keyboadr shortcut

 

Screen Shot 2012-12-01 at 12.03.05 PM.png

 

I've reindex everything but same issues comes up.

 

 

 

2) Also, it seems that it only searches on local drive, not on my external drives as well, even though they are also indexed.

 

 

Thank you

  • 1. Re: Spotlight "Show all in Finder" not working
    jpdemers Level 1 Level 1 (20 points)

    It's a bug that Apple hasn't yet fixed.  Open Activity Monitor (in the Utilities folder), find the process "appleeventsd", and terminate it.  (You have to use "Force Quit", not "Quit".) 

     

    This is a workaround, and I don't know how long things remain "fixed" after you implement it.

  • 2. Re: Spotlight "Show all in Finder" not working
    Jim1233 Level 1 Level 1 (0 points)

    Thank you!

    That fixed the no "Show All in Finder" bug for me for now.  Hope it holds up.

     

    I'm on 10.8.2

  • 3. Re: Spotlight "Show all in Finder" not working
    jacobwb Level 1 Level 1 (0 points)

    Same issue and the 'appleeventsd' hotfix doesn't work for me. On 10.8.2 as well.

  • 4. Re: Spotlight "Show all in Finder" not working
    jpdemers Level 1 Level 1 (20 points)

    Do you have TotalFinder installed?  If so, uninstall it and reboot.

     

    The appleeventsd bug also prevents the OS-X "Archive Utility" from unpacking .zip archives.  If Archive Utility is working for you, your problem is not appleeventsd.  The next thing to try is to re-index Spotlight:  http://support.apple.com/kb/HT2409

  • 5. Re: Spotlight "Show all in Finder" not working
    jacobwb Level 1 Level 1 (0 points)

    I don't have TotalFinder installed and Archive Utility doesn't work (haven't noticed that before since I use Incredible Bee's Archiver App).

     

    When I kill appleeventsd it naturally goes away and then it opens again as soon as I hit "show in finder" – I assume it should act like that since the force quit is merely to force a restart on the process.

     

    Any other ideas :/?

  • 6. Re: Spotlight "Show all in Finder" not working
    warrendunlop Level 1 Level 1 (0 points)

    Thanks, force quitting "appleeventsd" worked for me (10.8.2).

     

    Hoping there is a fix soon, this is a daily occurance for me now.

  • 7. Re: Spotlight "Show all in Finder" not working
    jpdemers Level 1 Level 1 (20 points)

    Got me stumped there.  My understanding (limited) is that the Apple Events daemon works for a while when freshly launched, but for reasons unknown it gets bolloxed after a certain number of calls.  No error messages appear in Console, which makes it especially hard to track down.  If yours gets hosed immediately, that's not the usual pattern.

     

    iPhoto and iTunes use Apple Events quite a lot.... if you have either of those apps running, you might see what happens without them.  Failing that, see what happens when no applications are running.  Finally, see what login items are being fired up (System Preferences => Users and Groups => Login Items) and disable those.

     

    This bug only crops up on a small number of Macs, and as far as I know nobody's been able to track down what triggers it. 

  • 8. Re: Spotlight "Show all in Finder" not working
    drhoek Level 1 Level 1 (0 points)

    Just to add my 2 cents. I have the same problem on iMac 2.93 with 8GB RAM running 10.8.2. Quitting appleeventsd has no effect. I also note that in addition to restarting appleeventsd when you touch "show in finder" it also restarts immediately if you touch the yellow warning triangles next to the "erroneously" flagged keyboard shortcuts for spotlight noted above. I've reset all the keyboard shortcuts to default and don't know of any shortcuts in other appl that overlap these (much less the fact that none are running at this point).

     

    Changing the keyboard shortcuts however to alt space and shift alt space, immediately stopped the wierd show in finder problem.

     

    Can someone smarter than me figure out where the problem is?

  • 9. Re: Spotlight "Show all in Finder" not working
    jpdemers Level 1 Level 1 (20 points)

    drhoek:

     

    "Changing the keyboard shortcuts however to alt space and shift alt space, immediately stopped the wierd show in finder problem." 

    Are you saying that this is a fix? If it is, that's great -- but it's one of the strangest I've ever seen.

  • 10. Re: Spotlight "Show all in Finder" not working
    drhoek Level 1 Level 1 (0 points)

    It's been a week and it's still working. I don't consider it a fix, for sure. But, it does seem to be a work around. I would still prefer to get back to command-space as my keyboarding muscle memory has that one already stored and I keep hitting it. I suspect that there is something else assigned to command-space (hence the little yellow triangles under spotlight prefs as noted above by octium). I can't figure out what it is though. My most key combo intensive application is Logic Pro and I reset that to defaults so there shouldn't be any overlap. I'm not enough of a code monkey (not to mention too lazy) to have gone through and actually changed keyboard commands for any of my other apps.

     

    I'm open to suggestions for troubleshooting this, but the alt-space alternative is still working.

  • 11. Re: Spotlight "Show all in Finder" not working
    jpdemers Level 1 Level 1 (20 points)

    Shortcuts generally kick in only for the application that's currently "in front", but some apps are "system wide" and trump the usual rule.  One of those might be the culprit. 

    First thing to do is check the preference panel at System Preferences > Keyboard > Keyboard Shortcuts, to see what else might have comandeered the cmd-space combo.  If nothing there, see what happens if you start in safe mode, or when all startup items are disabled.