Skip navigation

Novation Impulse 49 - Sound cuts out after a few seconds

2439 Views 17 Replies Latest reply: Jun 16, 2013 8:35 AM by pheal RSS
1 2 Previous Next
williamfromfintry Calculating status...
Currently Being Moderated
Feb 4, 2013 8:24 AM

First here's the details of my setup:


MacBook Pro with Mountain Lion

Garageband 11

Novation Impulse 49 USB MIDI keyboard connected to USB port


I bought this keyboard yesterday and it came with Ableton Live Lite 8 which I've installed and everything works fine in that.


I'm more used to GarageBand and wanted to use the Impulse with it but the audio cuts off after a few seconds. The keyboard still registers MIDI signals in GarageBand but there's no audio. The keyboard has a built-in template for GarageBand.


If I change instruments in the instrument browser the audio comes back for a few seconds and then cuts off again.


Same if I click 'Play' and then 'Stop', the audui comes back for a few seconds.


I get the same behaviour when trying to play along to any of the GarageBand piano lessons. The audio from the lesson and my keyboard both come through at first then after a few seconds my keyboard audio cuts out.


I'd welcome any suggestions as I would like to get this working reliably with GarageBand.


Thanks in advance.



GarageBand (Mac) '11, OS X Mountain Lion (10.8.2), 8GB Ram, Intel Core i7 Quad Core
  • Edgar Level 3 Level 3 (965 points)

    Are you saying that the Keyboard makes your audio output in GarageBand disappear? That would be really strange. The Novation is a MIDI keyboard and has no audio driver that could mess up the audio portion of your system.


    Two things I would do:

    • Check the manufacturers website to see if you have the latest update for the drive or if the current driver supports you OSX version.
    • Login with a different user on you computer to make sure that there are no corrupt preference files that causes the problem


    Hope that helps


    Edgar Rothermich

    'I may receive some form of compensation, financial or otherwise, from my recommendation or link.'

  • Edgar Level 3 Level 3 (965 points)

    You have to be clear about something:


    The Novation is a MIDI Device and not an Audio Device. It produces MIDI signals and no audio signal. THat's why you don't; see it in the System Preferences Audio window.

    You have to use the Audio MIDI Setup utility app (inside the Applications/Utilities/ folder). There you can see all your MIDI devices including your Novation

  • Edgar Level 3 Level 3 (965 points)

    You are right, the click from the AMS utilty tells you that OSX is receiving MIDI events.


    The way you are describing the problem looks that GarageBand is "re-acting" to the MIDI signal in a strange way. Re-installing GarageBand would eliminate any factors on the GarageBand that got screwed up. However, at the moment I would be curious about the actual MIDI signal that is coming from the Novation.


    I don't know how much you know about various MIDI messages. If you just press a key, then you would end up just with a MIDI on message and MIDI off message. However there are all kinds of MIDI events that a keyboard could send out (on purpose or by accident). Maybe that happens and that is what GarageBand gets confused while Ableton just ignors it.


    If you can interpret MIDI messages, I would try one of the free MIDI utilities, that logs all incoming and outgoing MIDI messages of connected devices. Maybe that will tell you something. (In the "old" WIldWIldWest days of MIDI we had those little boxes with dip switches to connect between MIDI devices to filter out specific MIDI messages)



    Hope that helps


    Edgar Rothermich

    'I may receive some form of compensation, financial or otherwise, from my recommendation or link.'

  • pheal Calculating status...

    Hello Bill,


    I'm an Ableton user and I've been using the Novation Impulse 49 and this DAW for one year without problems.


    I used to follow the piano lessons on GarageBand last year with that controller and I also never had a problem. But today, I tried to use my Impulse with GaraBand to resume the lessons and I'm having the same exact problem. The sound disappears after hitting a certain number of keys. The MIDI signals are still being sent out, so the problem must be exactly as you described.


    I hope this will be fixed soon!


    All the best,


  • pheal Level 1 Level 1 (0 points)

    Hey Bill,


    Thanks a lot for your quick reply. Unfortunately I don't have Logic so I guess I can't use the Main Stage template. I will look further into that issue and let you know if I find a solution.


    Kind regards,


  • michaeltownsfocusrite Level 1 Level 1 (10 points)

    Hi, What is your case number so i can look in to the issue and help you find a resolution.


    Best Regards,

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.