7 Replies Latest reply: Apr 20, 2013 9:57 AM by MacUserAE
Stevesvp Level 1 Level 1 (0 points)

The Verizon Actiontec router MI424WR does not allow Bonjour with its default settings.

 

To allow Bonjour to operate, one must open the Router and select >Advanced>IGMP Proxy.  Change the setting IGMP Proxy from Enabled to Disabled, then apply the setting.

 

This will allow Documents to Go to sync using WiFi, and will probably solve problems for other items that use Bonjour.

  • 1. Re: Bonjour and Verizon Actiontec router MI424WR
    ehagberg Level 1 Level 1 (0 points)

    Actually, the Actiontec router works fine - it's Mountain Lion that breaks, IMO.

     

    Older versions of MacOS have no problem with Bonjour and IGMP Proxy enabled on the router - I have an old Mac running 10.4 (Tiger) which has no problems seeing the printer it's been using for years, but I had to disable IGMP Proxy on the router to get Mountain Lion to see it.

     

    So now I'll have to remember this stupid setting from now on because MacOS is doing something different here.

  • 2. Re: Bonjour and Verizon Actiontec router MI424WR
    JohnDCCIU Level 1 Level 1 (10 points)

    Stevesvp is correct:  it's an Actiontec router issue.  And it's not just with Mac OS X:  the same problem happens with other devices that have nothing to do with Apple (TiVo, Samsung TVs, etc).  I'm not sure why 10.4 works, maybe it's using an older way of accessing Bonjour (the Bonjour protocol has been undergoing changes to try to address complaints from large network admins about chattiness), but it's not Apple's fault.  And this problem doesn't happen with any other router than Actiontec.

     

    The Disabling IGMP Proxy via the Actiontec's "Advanced -> IGMP Proxy" menu works fine and solves the problem.

     

    One complication is that the new Rev I of the Actiontec router removed the link to the IGMP page from the Advanced menu.  If you have that Rev, however, you can still get to the IGMP Proxy menu via a deep link discovered by user BigDaddy on DSLReports.  Just loging to your router as normal, then use this link, which will take you directly to the now-hidden IGMP Proxy config page:

     

    192.168.1.1/index.cgi?active_page=6059

     

    I can confirm that this works on my Rev I router.

  • 3. Re: Bonjour and Verizon Actiontec router MI424WR
    MacUserAE Level 1 Level 1 (10 points)

    So i went ahead and disable the IGMP proxy on my rev I router, and initially I thought it was a great.  A couple of hours later the wifi sync from ios devices to my imac does not work, I cant screen share or file share to my iMac from my Mac Book Pro.  Is anyone else experiencing this?  Is there a fix?

  • 4. Re: Bonjour and Verizon Actiontec router MI424WR
    ggarcia75 Level 1 Level 1 (0 points)

    This worked for me. Thank you John so much for posting the deep link, exactly what I needed!

  • 5. Re: Bonjour and Verizon Actiontec router MI424WR
    MacUserAE Level 1 Level 1 (10 points)

    What version of the firmware are you running on the actiontec?

  • 6. Re: Bonjour and Verizon Actiontec router MI424WR
    ggarcia75 Level 1 Level 1 (0 points)
    40.20.1
  • 7. Re: Bonjour and Verizon Actiontec router MI424WR
    MacUserAE Level 1 Level 1 (10 points)

    40.20.1 is the one that fixed all actiontec bonjour issues according to Verizon.  Also even if you disable it it will reenable itself in a few days.  I believe it is Mac OS 10.8.3 that fixed a lot of the wake on LAN issues.  The one issue that still remains for me is that once my Mac is asleep the wifi sync from my iOS devices is hit or miss (mostly miss)