Skip navigation

sudo syslog weirdness

105 Views 1 Reply Latest reply: Feb 5, 2013 8:20 PM by Linc Davis RSS
Todd Heberlein1 Level 1 Level 1 (30 points)
Currently Being Moderated
Feb 5, 2013 6:18 PM

On one of my machines I am having some weirdness with syslog. It runs differently, with a lot less information, if I escalate to root privilege. For example,

 

$ syslog

 

shows results from Jul 25 18:49:21 to Feb  5 18:06:16  (piping the results through "more" and "tail")

 

$ sudo syslog

 

only shows results from Dec 31 10:53:58 to Jan 31 19:17:12. For example, *nothing* for February.

 

I only get this on my Mac Pro running Mt. Lion. My other machines show the same result whether I am running them with sudo or not.

 

Unfortunately, for some esoteric reasons I need to run syslog as root to harvest the lastest logs.

 

Any help as to how to resolve this would be appreciated!

Mac Pro, OS X Mountain Lion (10.8.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.