Skip navigation

Lost Safari on OS X 10.5.8

780 Views 4 Replies Latest reply: Feb 6, 2013 4:44 PM by Piwichu RSS
Piwichu Calculating status...
Currently Being Moderated
Feb 5, 2013 1:21 PM

I've tried various solutions offered on-line; I've searched and spotlighted; I've downloaded various versions of Safari, which are either too old ("you have a more recent version of Safari running...), or too new. I tried downloading the one I should apparently be running (5.0.3 Leopard) and got message saying it couldn't be run on my system. Now what??

iMac, Mac OS X (10.5.8)
  • andyBall_uk Level 6 Level 6 (17,595 points)
    Currently Being Moderated
    Feb 5, 2013 2:15 PM (in response to Piwichu)
  • andyBall_uk Level 6 Level 6 (17,595 points)
    Currently Being Moderated
    Feb 6, 2013 2:58 AM (in response to Piwichu)

    Did this message show when attempting to run the installer , or did that go w/o incident, and the message comes when opening the new Safari ?.


    If you do a get-info in Finder on Applications/Safari, it shows 5.0.6 ?

    About this Mac shows 10.5.8 ?


    If it won't install & the OS version is correct, there's likely a mismatched

    /System/Library/Frameworks/WebKit.framework from attempting to use an incorrect Safari version... using the shareware Pacifist to 'force' the install of the 5.0.6 package usually takes care of that w/o needing to reinstall OS X or manually deleting the framework. As always, back up first.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.