Skip navigation

Deleted some LaunchDaemons files and now Mac doesn't start

2299 Views 21 Replies Latest reply: Mar 20, 2014 8:57 AM by Venetian77 RSS
  • Kappy Level 10 Level 10 (221,010 points)

    That can only happen if you erased the drive because reinstalling OS X does not erase the drive unless you specifically do it first.

     

    I assume you can reinstall your third-party software from the installer DVDs and/or downloads.

  • Kappy Level 10 Level 10 (221,010 points)

    I'm sorry, but I don't know how to help you if all those files are missing since reinstalling would not have erased the drive. I don't suppose you keep backups?

  • Pat.Walton86 Calculating status...

    Kappy

     

    We have the same problem with my sons Macbook Pro, he deleted all the LaunchDaemon files on his Mac now all we get is the white screen with the grey apple logo with the spinning wheel. We have tried to boot from our Snow Leopard disc by holding down 'C', we can then hear the Mac trying to load the disc but eventually fails and ejects the disc and the white screen with grey logo reappears.

     

    The Mac books original OS was 10.4.8 Tiger but we don't have the Discs.

     

    Should the Mac load from the snow leopard disc? As it doesn't does that mean that there is a greater issue? Would the Mac boot from the original tiger discs? If we transferred the contents of the disc on to a USB device from another Mac would this be something we can boot from easier?

     

    Your help would be greatly appreciated

  • Venetian77 Calculating status...

    I think the advice above should include one other thing

     

    -first get another macbook, launch the problem one in target disk mode (hold T down and power on), then you can see it as a hard drive.

     

    Back evrythinng up onto another external drive. At least you have all files. Time Machine obviously a better way to go here using frequently.

     

    Secondly, try powering pon in Verbose mode (apple-v and power on)

     

    you'll now see the problems - launch agents and daemons are skipped etc

     

     

    This is actually where I'm at now. I have no optical drive working on the problem mac - how can I repair the problem one? (I deleted launch daemons and copied them back across)

     

    I feel the problem might be fixable with repair permission (eg ls -l in terminal and chmod to change permissions)

     

    or else a re-install method (from disk image or something?)

     

    any ideas?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.