Skip navigation

FCP X "unexpectedly quits" every time I click "Import Media."

238 Views 6 Replies Latest reply: Feb 7, 2013 9:12 AM by francesfromchicago RSS
francesfromchicago Calculating status...
Currently Being Moderated
Feb 6, 2013 1:39 PM

I recently decided to upgrade our office software from FCP 7 to FCP X. I've worked with FCP X on my personal laptop with no issues, but for some reason, the MacBooks and iMacs at work are having issues. The biggest issue is the application "unexpectedly quitting." On my personal iMac, any time I try to "Import Media" in any way (hitting Command I, via the Event Library or the Project Library) Final Cut just unexpectedly quits and brings up a huge long error message.

 

I've read other threads on here that suggest trashing your preferences using Digital Rebellion software and hiding events, and I've tried those things, but they didn't work. I trashed the whole application and reinstalled it already. I've rebooted about 100 times. Am I missing something?

 

Also, why does this seem to be such a big problem for FCP X users? Why does FCP X crash so frequently? FCP 7 very rarely crashed on me.

 

 

 

 

I'm using the following:

 

iMac

27-inch, Mid 2010

Processor: 2.8 GHz Inrtel Core i5

Memory: 8 GB 1333 MHz DDR3

Graphics: ATI Radeon HD 2750 1024 MB

Software: OS X 10.8.2 (12C60)

iMac, OS X Mountain Lion (10.8.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.