Skip navigation

Wiki Service error message (continuous) in OS X Server (ML) 2.2

9011 Views 56 Replies Latest reply: Aug 9, 2013 3:01 PM by Peter Graves1 RSS
  • andrewnesbitt Calculating status...

    Can you run `sudo -s` to become root?  Then you should be able to omit the sudo from each of the commands I gave you.

  • trilogy1000 Level 1 Level 1 (45 points)

    I tried running sudo psql -U collab -h "/Library/Server/PostgreSQL For Server Services/Socket"  and got the following error:

    psql: could not connect to server: No such file or directory

              Is the server running locally and accepting

              connections on Unix domain socket "/Library/Server/PostgreSQL For Server Services/Socket/.s.PGSQL.5432"?

     

    I can connect to Postgres with PgAdmin but I'm assuming that's not the same as Postgres for Server Services. I tried to simply start the postgres_server but this also returned an error.

     

    sudo serveradmin start postgres_server

    postgres_server:error = "CANNOT_START_SERVICE_TIMEOUT_ERR"

     

    I'm not sure where to go from here - any advice would be greatly appreciated.

  • joel2931 Calculating status...

    Most likely the initialization of the postgres database failed for some reason when you installed Server.  Otherwise its broken (or not running) for some other reason.

     

    Could you post the contents of /Library/Logs/ServerSetup.log? That should answer several questions that I have.  If postgres failed to initialize, a hint as to why should be found in that log.  Was this a migration of data from another server or Time Machine backup? An in-place upgrade from an older server?  A clean install on a system that hasn't had server installed on it in the past?

     

    Also, had you installed a third party distribution of postgres on the system before installing server?  We've found that this may cause problems.

     

    Version 2.2.1 is available now and fixes several bugs related to postgres, if you have the option of doing a fresh installation.

  • Jan Lukens Calculating status...

    What I did to resolve these errors: I trashed the Server.app, causing the OS to stop all server services. After that, I trashed the entire /Library/Server folder, after which I retrieved Server.app from the trash and reinstalled it in the Applications folder. This will cause the Server to reinstall with a new, fresh PostgreSQL database, and the errors are gone.

     

    So, at least on my system, it wasn't necessary to reinstall completely from scratch.

  • aptmxLS Level 1 Level 1 (0 points)

    @Jan Lukens,

     

    When you did this, did all data and services restore properly?  Did you lose anything?  I have the issue as well and Apple told me I had to rebuild the PostgreSQL database which wipes out all data related to Profile Manager.

     

    Does your solution keep all the data in tact?  I would must rather do what you suggest if no data loss occurs.  Please let me know.  

     

    Thanks!

  • aptmxLS Level 1 Level 1 (0 points)

    I did not want to go that route.  I wanted to see if @Jan Lukens had any data loss doing what he did.  He did not have to reinstall...

  • joel2931 Level 1 Level 1 (15 points)

    HenryS: If you did an install of 2.2 and everything is working now, you definitely should not need to reinstall your OS to apply further Server updates via MAS.

     

    Jan and aptmxLS both make good points. Regarding the process of trashing Server.app then /Library/Server, and then reinstalling Server, that process has worked for me and I haven't observed any problem.  You will lose most of the server's data but otherwise it is a way to attempt to fix a problem like a broken postgres installation if you just want to start with a fresh install.

  • aptmxLS Level 1 Level 1 (0 points)

    Still have this issue and can not get it resolved no matter what I try.  

     

    Here's what I have done:

     

    Trashed Server.app and entire Library/Server folder.  Moved app back and re-built.  Wiki Error reading settings message still there.

     

    Did same as above but with trashing the Server.app and re-downloading a fresh copy.  Same result.

     

    Did the "last resort" of trashing the Server and Library/Server folder and ran the WipeDB script as per Apple's request.   Had to set up all of Profile Manager again (no easy way to back up and restore Profile Manager database at all) and Wiki still states Error reading Settings!   

     

    Unfixable in my case? 

  • aptmxLS Level 1 Level 1 (0 points)

    Turns out it was an issue with a program running on the Server called GoodSync.  Worked with Apple Enterprise support and we finally figured out that a service was running called gs-server.  This process was listening on port krb524, essentially blocking the process teamserver (Wiki) from listening. The gs-server process would overtake the teamserver process which caused the Error Reading Settings just to appear in the Wiki service.  Uninstalled GoodSync and made sure the process gs-server was not active.  All is working well now.  I would have never figured that out.  I knew it was something small like that.  Hope this can help everyone else out who happens to use that program and runs the Server.app.   

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.