Skip navigation

MBP gets frozen after sleep

445 Views 10 Replies Latest reply: May 2, 2013 4:57 AM by zaak911 RSS
Máté Calculating status...
Currently Being Moderated
Jan 25, 2013 3:12 PM

Hi! I have an early 2011 15" MBP running OS X 10.8.2. For some time I experience a problem which happened rarely in the past and got more and more frequent and now it happens always.


The symptom is that whenever I leave my MBP running with the display black (I configured the upper left corner of the screen to switch it off) for some time after like 3-5 hours it gets forzen. When I move the mouse the screen comes back, and the program running in the top window responds sometime, but latest after the first attempt when I try to switch to any other running programs or click the Apple menu, it hangs and nothing works any more. (Usually the CPU fans are on top speed but I'm not sure wether it's always the case.)


Then I press the power btn for 10sec and restart it. If I'm luckey the system boots if not is does not and either a question mark or a folder icon appears on the grey background. Then I usually reboot it in repair mode and lunch the disk utility, and make it repair all the problems, but it rarely finds any.


This behaviour is experienced even with no programs running (so after a fresh restart), so I don't think it's related to any of the user software. Yesterday I also tried to reinstall the system completely but it didn't help.


I have a feeling that it might be related to the indexing process, because after such a forced reboot, a long indexing starts usually; but if it were the reason, others might have the same issue i guess, so I'm really out of ideas...


Any hints/help is appreciated, thank you in advance!

MacBook Pro, OS X Mountain Lion (10.8.2)
  • leroydouglas Level 6 Level 6 (13,370 points)
    Currently Being Moderated
    Jan 25, 2013 4:17 PM (in response to Máté)

    My suspicion is the hard drive is failing.


    I would back upimmediately and trouble shoot this further

  • leroydouglas Level 6 Level 6 (13,370 points)
    Currently Being Moderated
    Jan 25, 2013 6:32 PM (in response to Máté)

    You look at S.M.A.R.T. status  but this is limited


    To check on SMART status in Mac OS X, open Disk Utility (/Applications/Utilities) and take a quick glance at your drive(s).


    Pending failures will be obvious: the S.M.A.R.T. Status will read Failing. If a drive has completely failed, it won’t even show up.




    You can run Disk Repair from Recovery using Disk Utility. Reboot holding the command-R


    You can run Appple Hardware Test from Recovery as well option-command-R, or boot hold D key

  • MaximilianWalker Calculating status...
    Currently Being Moderated
    Feb 7, 2013 10:27 AM (in response to Máté)

    I am having the exact same problem (MacBook Pro Mid 2010). I went to the Apple Store twice. They replaced the SATA cable first, then the hard disk, and then reinstalled Mountain Lion. After each attempt, the MacBook was working fine for about a week, then the problem reappeared.

  • Eric Root Level 6 Level 6 (13,950 points)
    Currently Being Moderated
    Feb 7, 2013 10:42 AM (in response to Máté)

    Try starting in the Safe Mode and see if you get the same results:


    Starting Up in the Safe Mode


    What is Safe Mode


    Also try using another account to see if you get the same results. Disk Utility doesn't repair permissions for your user account. To do this,boot to your Recovery partition (holding down the Command and R keys while booting) and open Terminal from the Utilities menu. In Terminal, type:  'resetpassword' (without the 's) and select the admin user. You are not going to reset your password. Click on the icon for your Macs hard drive at the top. From the drop down below it select the user account which is having issues. At the bottom of the window, you'll see an area labeled Restore Home Directory Permissions and ACLs. Click the reset button there. The process takes a few minutes. When complete, restart.  


  • MaximilianWalker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 6:49 AM (in response to Eric Root)

    Thanks for your reply, Eric!

    I tried all of your suggestions. Unfortunately the problem is still there.

  • zaak911 Calculating status...
    Currently Being Moderated
    May 2, 2013 4:57 AM (in response to Máté)

    this happens to me also.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.